Bug 613709 - Yum repolist command display “Bad id for repo” message for subscribed product
Summary: Yum repolist command display “Bad id for repo” message for subscribed product
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 568421 636830
TreeView+ depends on / blocked
 
Reported: 2010-07-12 15:51 UTC by spandey
Modified: 2015-04-23 23:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-23 16:14:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
entitlement cert (19.32 KB, text/plain)
2010-07-15 14:19 UTC, wes hayutin
no flags Details

Description spandey 2010-07-12 15:51:36 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Prerequisites:
Candlepin : IT Env (Candlepin1)
Client : Rhel6 with SM version 66

Steps to Repro :
Login to client console with valid credentials 
subscribe product entitlement via pool id 
execute following command on console to display yum repo for subscribed product

yum repolist

Expected Result : 

Proper yum repo should display for subscribed product 

Actual Result : 

[root@sachrhel6 ~]# yum repolist

Loaded plugins: refresh-packagekit, rhnplugin, rhsmplugin

Updating Red Hat repositories.

Bad id for repo: Red Hat Enterprise Linux Advanced Platform - Optional Beta (Source RPMs), byte =   3

Bad id for repo: Red Hat Enterprise Linux Advanced Platform - Optional (RPMs), byt

Comment 2 wes hayutin 2010-07-14 21:40:44 UTC
recreated:


[root@oldceremony ~]# subscription-manager-cli register --username=xeops --password=redhat
f8260a47-1f98-45ea-8f01-38968fbb2d27 admin XEOPS
[root@oldceremony ~]# subscription-manager-cli list --available
f8260a47-1f98-45ea-8f01-38968fbb2d27 <connection.UEPConnection instance at 0x9586d6c>
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


Name:              	Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) w/ 24 x 7 Phone/Web Support
ProductId:         	SYS0373                  
PoolId:            	198                      
quantity:          	12                       
Expires:           	2012-02-12               


Name:              	Red Hat Enterprise Linux Advanced Platform, Standard (Unlimited Sockets)
ProductId:         	SYS0372                  
PoolId:            	199                      
quantity:          	1                        
Expires:           	2010-12-31               


Name:              	JBoss jBPM Framework (for up to 4 CPUs), Premium (w/ 24 x 7 Phone/Web Support)
ProductId:         	SYS0415                  
PoolId:            	200                      
quantity:          	2                        
Expires:           	2012-02-05               


Name:              	Red Hat Enterprise Linux Advanced Platform, Standard (Unlimited Sockets)
ProductId:         	SYS0372                  
PoolId:            	201                      
quantity:          	1                        
Expires:           	2010-12-31               


Name:              	RHN Provisioning + Management
ProductId:         	SYS0081                  
PoolId:            	202                      
quantity:          	1                        
Expires:           	2010-12-31               

[root@oldceremony ~]# subscription-manager-cli subscribe --pool=198
[root@oldceremony ~]# ls /etc/pki/entitlement/product/
338.pem
[root@oldceremony ~]# yum repolist
Loaded plugins: presto, refresh-packagekit, rhnplugin, rhsmplugin, security
Updating Red Hat repositories.
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) - Optional Beta (RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) (Source RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) - Optional (RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) Beta (Debug RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) (Debug RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) - Fastrack (RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) Beta (Source RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) - Fastrack (Debug RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) Beta (RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) (RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) - Optional (Source RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) - Optional (Debug RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) - Optional Beta (Source RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) - Optional Beta (Debug RPMs), byte =   3
Bad id for repo: Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373) - Fastrack (Source RPMs), byte =   3
This system is not registered with RHN.
RHN support will be disabled.
rhel-latest                                                                  | 3.7 kB     00:00     
repo id                                       repo name                                       status
rhel-latest                                   Latest RHEL 6                                   2,643
repolist: 2,643
[root@oldceremony ~]#

Comment 3 wes hayutin 2010-07-15 14:18:37 UTC
Must have been a hosted issue.. could not recreate.

[root@oldceremony ~]# subscription-manager-cli register --username=xeops --password=redhat
7ec487fb-1d2d-4b8e-8636-9690851f83fe admin XEOPS
[root@oldceremony ~]# subscription-manager-cli list --available
7ec487fb-1d2d-4b8e-8636-9690851f83fe <connection.UEPConnection instance at 0x860dd6c>
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


Name:              	Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) w/ 24 x 7 Phone/Web Support
ProductId:         	SYS0373                  
PoolId:            	198                      
quantity:          	12                       
Expires:           	2012-02-12               


Name:              	Red Hat Enterprise Linux Advanced Platform, Standard (Unlimited Sockets)
ProductId:         	SYS0372                  
PoolId:            	199                      
quantity:          	1                        
Expires:           	2010-12-31               


Name:              	JBoss jBPM Framework (for up to 4 CPUs), Premium (w/ 24 x 7 Phone/Web Support)
ProductId:         	SYS0415                  
PoolId:            	200                      
quantity:          	2                        
Expires:           	2012-02-05               


Name:              	Red Hat Enterprise Linux Advanced Platform, Standard (Unlimited Sockets)
ProductId:         	SYS0372                  
PoolId:            	201                      
quantity:          	1                        
Expires:           	2010-12-31               


Name:              	RHN Provisioning + Management
ProductId:         	SYS0081                  
PoolId:            	202                      
quantity:          	1                        
Expires:           	2010-12-31               

[root@oldceremony ~]# subscription-manager-cli subscribe --pool=198
[root@oldceremony ~]#

Comment 4 wes hayutin 2010-07-15 14:19:04 UTC
Created attachment 432099 [details]
entitlement cert

Comment 5 RHEL Product and Program Management 2010-07-15 14:25:51 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 6 wes hayutin 2010-07-15 20:46:12 UTC
putting this on_qa until the hosted akami server becomes available.
Please do not retest

Comment 7 wes hayutin 2010-07-21 15:22:01 UTC
K.. RETEST this, could be a client issue

Comment 8 spandey 2010-07-23 12:24:10 UTC
[[root@sachrhel6 ~]# subscription-manager-cli list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+


Name:               	JBoss jBPM Framework (for up to 4 CPUs), Premium
ContractNumber:       	1525456                  
SerialNumber:       	634                      
Active:             	True                     
Begins:             	2010-07-23               
Expires:            	2012-02-05               


Name:               	Red Hat Enterprise Linux Advanced Platform, Premium (Unlimited Sockets) (Legacy SVC0373)
ContractNumber:       	1523750                  
SerialNumber:       	637                      
Active:             	True                     
Begins:             	2010-07-23               
Expires:            	2012-02-12               

[root@sachrhel6 ~]# yum repolist
Loaded plugins: refresh-packagekit, rhnplugin, rhsmplugin
Updating Red Hat repositories.
This system is not subscribed to any channels.
RHN channel support will be disabled.
repolist: 0
[root@sachrhel6 ~]# 
[root@sachrhel6 ~]# rpm -qa | grep subscription
subscription-manager-gnome-0.71-1.el6.x86_64
subscription-manager-0.71-1.el6.x86_64
subscription-manager-debuginfo-0.71-1.el6.x86_64
[root@sachrhel6 ~]# 


Yum repo not getting displayed for subscribed product

Comment 9 Adrian Likins 2010-09-21 16:22:01 UTC
what do the yum repo files look like for this? /etc/yum.repos.d/

Looks like there is whitespace in the repo ids, which isn't valid.

Comment 10 James Bowes 2010-10-19 18:01:52 UTC
munging the ids now on the client side, if necessary

Comment 11 spandey 2010-10-20 11:40:54 UTC
Verified Using following setup 

Candlepin : Candlepin1 
Client : Rhel6 with sm version 0.92.1-1

Working fine 

Changing defect status from Modified to Verified

Comment 12 John Sefler 2010-11-23 16:14:51 UTC
This bug was opened/resolved/closed against the Entitlement-Alpha release.


Note You need to log in before you can comment on or make changes to this bug.