Bug 613742 - Laptop screen flickers on Asus U30JC
Summary: Laptop screen flickers on Asus U30JC
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-12 18:11 UTC by Tamas Toth
Modified: 2011-03-14 13:49 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-14 13:49:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (56.86 KB, text/plain)
2010-07-14 10:20 UTC, Tamas Toth
no flags Details

Description Tamas Toth 2010-07-12 18:11:03 UTC
Description of problem:
Laptop screen flickers, screen resolution is set to 1366x768 60Hz. The flickering appears horizontally and observed on the entire screen including the log-on and splash screen.   

Version-Release number of selected component (if applicable):
Fedora 13 - 2.6.33.6-147.fc13.x86_64

Installed Packages
Name       : xorg-x11-drv-intel
Arch       : x86_64
Version    : 2.11.0
Release    : 5.fc13
Size       : 790 k
Repo       : installed
From repo  : updates
Summary    : Xorg X11 Intel video driver

lspci -v | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: nVidia Corporation GT218 [GeForce 310M] (rev a2) (prog-if 00 [VGA controller])

I'm using Gnome.

How reproducible:
The flickering is exist since installation of Fedora 13. Screen on Windows 7 doesn't flicker with similar settings (1366x768 60Hz). When I start Fedora with kernel argument 'nomodeset' then flickering disappears but the resolution could not be set higher then 1024x768. First I thought that the flickering happens due to the hybrid GPU therefore I switched off the nVidia card but it did not help with the flicker however proved that the issue is not due to the dual video card.


Steps to Reproduce:
1. Start Fedora 13, flickering can already be observed at the splash screen.
2. Flickering remains after log-in
3.
  
Actual results:
Screen flickers badly and hurts eyesight.

Expected results: 
No flickering with 1366x768


Additional info: I have attached the Xorg.0.log to support problem resolution. Please help to overcome on the screen flickering or please let me know if you require more information. Appreciate your help in advance.

Comment 1 Tamas Toth 2010-07-14 10:20:14 UTC
Created attachment 431726 [details]
Xorg log

Comment 2 Chuck Ebbert 2010-07-14 21:43:04 UTC
Does kernel-2.6.34.1-11.fc13 from koji work any better?

Comment 3 Tamas Toth 2010-07-14 22:50:23 UTC
(In reply to comment #2)
> Does kernel-2.6.34.1-11.fc13 from koji work any better?    

First, thanks for your quick reply. No, unfortunately not. The screen still flickers with the kernel you suggested:

uname -a
Linux bpea52lt 2.6.34.1-11.fc13.x86_64 #1 SMP Tue Jul 13 05:34:49 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

Interesting enough that I get a kernel crash shortly after log-in even with the new kernel. However this crash was happening with 2.6.33.6-147.fc13.x86_64 too that I have reported through the Automatic Bug Reporting tool. However I paste the back trace output here assuming it may helps with resolution:

------------[ cut here ]------------
WARNING: at fs/proc/generic.c:598 proc_register+0x152/0x18a()
Hardware name: U30Jc
proc_dir_entry 'video/GFX0' already registered
Modules linked in: nouveau i915(+) ttm drm_kms_helper video output drm i2c_algo_bit i2c_core
Pid: 122, comm: modprobe Not tainted 2.6.34.1-11.fc13.x86_64 #1
Call Trace:
[<ffffffff8104d10b>] warn_slowpath_common+0x7c/0x94
[<ffffffff8104d17a>] warn_slowpath_fmt+0x41/0x43
[<ffffffff8115a48a>] proc_register+0x152/0x18a
[<ffffffff8115a904>] proc_mkdir_mode+0x42/0x5a
[<ffffffff8115a932>] proc_mkdir+0x16/0x18
[<ffffffffa0059d94>] acpi_video_bus_add+0x28d/0x1099 [video]
[<ffffffff811633b4>] ? sysfs_find_dirent+0x21/0x36
[<ffffffff8116369a>] ? __sysfs_add_one+0x34/0x96
[<ffffffff81163d5d>] ? sysfs_addrm_finish+0x2f/0xb9
[<ffffffff81163f38>] ? sysfs_add_one+0x21/0xf3
[<ffffffff8144b607>] ? mutex_lock+0x29/0x50
[<ffffffff81164432>] ? sysfs_do_create_link+0xe2/0x137
[<ffffffff81257e3c>] acpi_device_probe+0x50/0x122
[<ffffffff812c365a>] driver_probe_device+0xea/0x217
[<ffffffff812c37e4>] __driver_attach+0x5d/0x81
[<ffffffff812c3787>] ? __driver_attach+0x0/0x81
[<ffffffff812c2a80>] bus_for_each_dev+0x53/0x88
[<ffffffff812c33ea>] driver_attach+0x1e/0x20
[<ffffffff812c2d7e>] bus_add_driver+0x11d/0x282
[<ffffffff812c3ae5>] driver_register+0x9e/0x10f
[<ffffffff8125962d>] acpi_bus_register_driver+0x43/0x46
[<ffffffffa005ac2f>] acpi_video_register+0x47/0x74 [video]
[<ffffffffa00b2d04>] intel_opregion_init+0x3f1/0x454 [i915]
[<ffffffffa008d471>] i915_driver_load+0xff3/0x1083 [i915]
[<ffffffff812c0ebb>] ? device_register+0x1e/0x23
[<ffffffffa001e14a>] drm_get_dev+0x39a/0x49b [drm]
[<ffffffffa00b32f0>] i915_pci_probe+0x15/0xdf [i915]
[<ffffffff81223dcd>] local_pci_probe+0x17/0x1b
[<ffffffff81224d40>] pci_device_probe+0xcd/0xfd
[<ffffffff812c348b>] ? driver_sysfs_add+0x4c/0x71
[<ffffffff812c365a>] driver_probe_device+0xea/0x217
[<ffffffff812c37e4>] __driver_attach+0x5d/0x81
[<ffffffff812c3787>] ? __driver_attach+0x0/0x81
[<ffffffff812c2a80>] bus_for_each_dev+0x53/0x88
[<ffffffff812c33ea>] driver_attach+0x1e/0x20
[<ffffffff812c2d7e>] bus_add_driver+0x11d/0x282
[<ffffffff812c3ae5>] driver_register+0x9e/0x10f
[<ffffffff81224f6c>] __pci_register_driver+0x58/0xc8
[<ffffffffa00d4000>] ? i915_init+0x0/0x96 [i915]
[<ffffffffa0019082>] drm_init+0x75/0xdb [drm]
[<ffffffffa00d4000>] ? i915_init+0x0/0x96 [i915]
[<ffffffffa00d4094>] i915_init+0x94/0x96 [i915]
[<ffffffff81002069>] do_one_initcall+0x5e/0x159
[<ffffffff8107d025>] sys_init_module+0xd6/0x235
[<ffffffff81009c72>] system_call_fastpath+0x16/0x1b

Please let me know if you require further information. Thanks in advance.

Comment 4 chris byrd 2010-07-24 17:31:06 UTC
I am also getting the screen flicker and Kernel crash after each login but I am still running 2.6.33 as shown below.


WARNING: at fs/proc/generic.c:590 proc_register+0x14d/0x185()
Hardware name: U30Jc
proc_dir_entry 'video/GFX0' already registered
Modules linked in: nouveau i915(+) ttm drm_kms_helper drm i2c_algo_bit video i2c_core output
Pid: 127, comm: modprobe Not tainted 2.6.33.6-147.fc13.x86_64 #1
Call Trace:
[<ffffffff8104aecc>] warn_slowpath_common+0x77/0x8f
[<ffffffff8104af31>] warn_slowpath_fmt+0x3c/0x3e
[<ffffffff8114b9e3>] proc_register+0x14d/0x185
[<ffffffff8114be1f>] proc_mkdir_mode+0x3d/0x55
[<ffffffff8114be48>] proc_mkdir+0x11/0x13
[<ffffffffa0014c64>] acpi_video_bus_add+0x298/0x101a [video]
[<ffffffff814290fd>] ? mutex_unlock+0x16/0x18
[<ffffffff81154dce>] ? sysfs_addrm_finish+0x2f/0xae
[<ffffffff81155030>] ? sysfs_add_one+0x1c/0xee
[<ffffffff81429440>] ? mutex_lock+0x24/0x4b
[<ffffffff81155479>] ? sysfs_do_create_link+0xdd/0x132
[<ffffffff8124314f>] acpi_device_probe+0x4b/0x11d
[<ffffffff812ad5e3>] driver_probe_device+0xe5/0x212
[<ffffffff812ad768>] __driver_attach+0x58/0x7c
[<ffffffff812ad710>] ? __driver_attach+0x0/0x7c
[<ffffffff812aca68>] bus_for_each_dev+0x4e/0x83
[<ffffffff812ad387>] driver_attach+0x19/0x1b
[<ffffffff812acd43>] bus_add_driver+0x118/0x27d
[<ffffffff812ada41>] driver_register+0x99/0x10a
[<ffffffff812447ca>] acpi_bus_register_driver+0x3e/0x40
[<ffffffffa0015a6b>] acpi_video_register+0x42/0x6f [video]
[<ffffffffa00aac47>] intel_opregion_init+0x3ec/0x44f [i915]
[<ffffffffa008612c>] i915_driver_load+0xd81/0xdf3 [i915]
[<ffffffff812aafe0>] ? device_register+0x19/0x1e
[<ffffffffa002fb27>] drm_get_dev+0x395/0x496 [drm]
[<ffffffffa00ab1fd>] i915_pci_probe+0x10/0xd0 [i915]
[<ffffffff81212803>] local_pci_probe+0x12/0x16
[<ffffffff8121351e>] pci_device_probe+0xc8/0xf8
[<ffffffff812ad41e>] ? driver_sysfs_add+0x47/0x6c
[<ffffffff812ad5e3>] driver_probe_device+0xe5/0x212
[<ffffffff812ad768>] __driver_attach+0x58/0x7c
[<ffffffff812ad710>] ? __driver_attach+0x0/0x7c
[<ffffffff812aca68>] bus_for_each_dev+0x4e/0x83
[<ffffffff812ad387>] driver_attach+0x19/0x1b
[<ffffffff812acd43>] bus_add_driver+0x118/0x27d
[<ffffffff812ada41>] driver_register+0x99/0x10a
[<ffffffff8121373b>] __pci_register_driver+0x53/0xc3
[<ffffffffa00c9000>] ? i915_init+0x0/0x96 [i915]
[<ffffffffa002ac48>] drm_init+0x70/0xd6 [drm]
[<ffffffffa00c9000>] ? i915_init+0x0/0x96 [i915]
[<ffffffffa00c9094>] i915_init+0x94/0x96 [i915]
[<ffffffff8100205f>] do_one_initcall+0x59/0x154
[<ffffffff8107a471>] sys_init_module+0xd1/0x230
[<ffffffff81009b02>] system_call_fastpath+0x16/0x1b


I suspect that the dual graphics feature of the U30jc is at play here.  I would be happy with a way to disable the nvidia card and simply use the intel vga device.

Comment 5 Tamas Toth 2010-07-27 22:01:00 UTC
(In reply to comment #4)

Chris,

I have been able to switch off the nvidia card on 2.6.33 by following the instructions under this link: 

http://linux-hybrid-graphics.blogspot.com/2010/07/using-acpicall-module-to-switch-onoff.html

I have updated the kernel and the notebook bios and since then I'm not able to switch off the nvidia anymore.

However when I had the Intel card active only the screen flickering was still an issue.

Hope this helps.

If you have any solution for the kernel crash or screen flicker please share it with me. Thanks.

Comment 6 Tamas Toth 2010-08-10 20:27:26 UTC
(In reply to comment #2)
> Does kernel-2.6.34.1-11.fc13 from koji work any better?    

Chuck,

In the meantime I have installed kernel 2.6.35-0.57.rc6.git5.fc15.x86_64 and it resolved the issue with the screen flickering however the kernel crash mentioned above is still the case.

Can you please suggest a solution for this kernel crash issue? Please let me know if you require more information. 

Thanks

Comment 7 Tamas Toth 2010-08-31 22:00:44 UTC
Can anyone please reply to the above kernel crash issue? Is there any solutions in place in Fedora 13?

Thanks in advance.

Comment 8 Tamas Toth 2011-03-14 13:49:53 UTC
Kernel crash is solved in 2.6.36 or higher.


Note You need to log in before you can comment on or make changes to this bug.