Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 613754 - Local Install and reboot fails
Local Install and reboot fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Alan Pevec
Virtualization Bugs
: Reopened, TestBlocker
: 627122 (view as bug list)
Depends On: 613679 623846
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 14:28 EDT by Mike Burns
Modified: 2016-04-26 11:45 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-1.9.3-12.git0ffa622.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 623846 (view as bug list)
Environment:
Last Closed: 2010-11-11 09:52:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt.log (35.16 KB, text/plain)
2010-07-12 14:29 EDT, Mike Burns
no flags Details
handle spaces in device names (2.98 KB, patch)
2010-08-23 17:47 EDT, Alan Pevec
no flags Details | Diff
ovirt.log for snapshot 13 (95.02 KB, text/plain)
2010-08-26 03:38 EDT, Vivian Bian
no flags Details
handle spaces in device names, follow-up (10.46 KB, patch)
2010-08-30 17:45 EDT, Alan Pevec
no flags Details | Diff

  None (edit)
Description Mike Burns 2010-07-12 14:28:31 EDT
Description of problem:
After configuring through firstboot menu, choosing "local install and reboot" fails. 

Local Installation and Reboot


This option will exit the menu, and require a reboot. 
Please ensure that you have configured the local storage 
and networking correctly on the previous menu before 
continuing.

Current kernel boot parameters are:
ksdevice=bootif lang= rootflags=loop text elevator=deadline ovirt_standalone crashkernel=128M@16M processor.max_cstate=1 console=tty1 console=ttyS0,115200n8 kssendmac

Please enter kernel boot arguments (hit return to use the above): 
Do you wish to continue ([Y]es/[N]o)? y
installing the image.
Root partition not available

ERROR: Local install and reboot FAILED. See /var/log/ovirt.log


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure rhev-h through firstboot
2.Choose "Local Install and Reboot"
3.
  
Actual results:
Failure

Expected results:
Installs and reboots

Additional info:
Comment 1 Mike Burns 2010-07-12 14:29:04 EDT
Created attachment 431238 [details]
ovirt.log
Comment 10 Mike Burns 2010-08-13 15:41:47 EDT
I've tried to work around the issue in RHEV-H, but it doesn't appear possible.  I've escalated bz 623846 to be a blocker for RHEL 6 because of this.
Comment 11 Mike Burns 2010-08-13 16:32:25 EDT
Moving to rhev-hypervisor to track inclusion of package with fix in it. No code change should be necessary.
Comment 12 Denise Dumas 2010-08-16 17:10:26 EDT
623846 is in Mod and will be picked up in tonight's nightly compose to enable pre-Snapshot sanity-checking on Tuesday.
Comment 16 Mike Burns 2010-08-17 16:39:25 EDT
This BZ is being closed since it is fixed by the parted bz and no actual changes need to be made on ovirt-node/rhev-h side.

*** This bug has been marked as a duplicate of bug 623846 ***
Comment 17 Alan Pevec 2010-08-20 08:07:31 EDT
See bug 624781 comment 4 and 6,
there still seems to be inconsistency between /dev/mapper/ and underlying sd* block devices.
Comment 18 Alan Pevec 2010-08-20 08:19:22 EDT
Here's example:

[root@localhost /]# grep parted /live/isolinux/manifest-srpm.txt 
parted-2.1-10.el6.src.rpm

[root@localhost /]# multipath -l /dev/sda  
0QEMU    QEMU HARDDISK   drive-scsi0-0-1 dm-3 QEMU,QEMU HARDDISK
size=2.0G features='0' hwhandler='0' wp=rw
`-+- policy='round-robin 0' prio=-1 status=active
  `- 0:0:1:0 sda 8:0  active undef running
[root@localhost /]# parted /dev/dm-3 print
Model: Linux device-mapper (multipath) (dm)
Disk /dev/dm-3: 2147MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start  End     Size    Type     File system  Flags
 1      512B   256MB   256MB   primary  ext2
 2      257MB  512MB   255MB   primary  ext2
 3      512MB  2147MB  1636MB  primary               lvm

[root@localhost /]# parted /dev/sda print
Error: /dev/sda: unrecognised disk label

So we need workaround from bug 623846 comment 14:
[root@localhost /]# echo 3 > /proc/sys/vm/drop_caches
[root@localhost /]# parted /dev/sda print
Model: QEMU QEMU HARDDISK (scsi)
Disk /dev/sda: 2147MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start  End     Size    Type     File system  Flags
 1      512B   256MB   256MB   primary  ext2
 2      257MB  512MB   255MB   primary  ext2
 3      512MB  2147MB  1636MB  primary               lvm

It also wouldn't hurt to align partition boundaries to 1M.
Comment 21 Alan Pevec 2010-08-23 17:47:13 EDT
Created attachment 440506 [details]
handle spaces in device names
Comment 26 Vivian Bian 2010-08-26 03:14:51 EDT
checked with rhev-hypervisor-6.0-13 

[ prerequisite ]
A clean machine with no HostVG created 

Steps to Reproduce:
1.Configure rhev-h through firstboot without shared root, and make root + HostVG on the same disk 
2.Choose "Local Install and Reboot"

actual result :
after installation can't boot 

[root@localhost ~]# ll /dev/disk/by-label/
total 0
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 CONFIG -> ../../dm-8
lrwxrwxrwx. 1 root root 11 Aug 26 07:04 DATA -> ../../dm-10
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 LOGGING -> ../../dm-9
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 RootBackup -> ../../dm-4
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 RootUpdate -> ../../dm-5
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 SWAP -> ../../dm-7
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 _rhev-hypervisor -> ../../dm-0
lrwxrwxrwx. 1 root root  9 Aug 26 07:12 rhev-hypervisor -> ../../sr0

There is no partition named Root , RHEVH can't find grub to boot . 


So set bug status to ASSIGNED
Comment 27 Vivian Bian 2010-08-26 03:38:24 EDT
Created attachment 441130 [details]
ovirt.log for snapshot 13
Comment 28 Alan Pevec 2010-08-26 04:34:43 EDT
What do you have in /boot/grub/device.map ?
Comment 29 Vivian Bian 2010-08-26 04:51:17 EDT
(In reply to comment #28)
> What do you have in /boot/grub/device.map ?

nothing under /boot directory , but
[root@localhost boot]# ll /dev/disk/by-label/
total 0
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 CONFIG -> ../../dm-8
lrwxrwxrwx. 1 root root 11 Aug 26 07:04 DATA -> ../../dm-10
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 LOGGING -> ../../dm-9
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 RootBackup -> ../../dm-4
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 RootUpdate -> ../../dm-5
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 SWAP -> ../../dm-7
lrwxrwxrwx. 1 root root 10 Aug 26 07:04 _rhev-hypervisor -> ../../dm-0
lrwxrwxrwx. 1 root root  9 Aug 26 08:48 rhev-hypervisor -> ../../sr0

[root@localhost boot]# mount /dev/dm-5 /mnt
[root@localhost boot]# cat /mnt/boot/grub/device.map 
(hd0) /dev/sda
Comment 31 Alan Pevec 2010-08-30 17:45:07 EDT
Created attachment 442043 [details]
handle spaces in device names, follow-up
Comment 37 Vivian Bian 2010-09-03 01:16:36 EDT
checked with rhev-hypervisor-6.0-13.1 

steps :
1. partition without shared root on SATA, virtio disk , FC LUN , CCISS disk 
2. install locally and reboot 

actual result :
after installation could boot from SATA, virtio disk , FC LUN , CCISS disk 

So set bug status to VERIFIED
Comment 38 Mike Burns 2010-09-03 08:46:43 EDT
*** Bug 627122 has been marked as a duplicate of this bug. ***
Comment 39 releng-rhel@redhat.com 2010-11-11 09:52:16 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.