Bug 613759 - requires aspell
requires aspell
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: emacs (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Karel Klíč
Ondrej Moriš
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 14:51 EDT by Bill Nottingham
Modified: 2014-12-15 11:04 EST (History)
4 users (show)

See Also:
Fixed In Version: emacs-23.1-21.el6
Doc Type: Bug Fix
Doc Text:
Previously, the emacs packages required the aspell and hunspell spell checkers to be installed. Since the use of a spell checker is completely optional, this update removes aspell and hunspell from the list of dependencies, so that Emacs can now be installed without these packages.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:10:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2010-07-12 14:51:43 EDT
Description of problem:

emacs in RHEL 6 requires aspell, however, hunspell is the only supported
spell checker. Oddly, it requires *both* aspell and hunspell.

Version-Release number of selected component (if applicable):

emacs-1:23.1-20.el6.x86_64

How reproducible:

100%
Comment 2 Karel Klíč 2010-08-04 12:56:48 EDT
It seems that hunspell is needed for some languages (#443549), and aspell for another ones (#508033).

We should test Emacs with the current (or newer) versions of the dictionaries and try to fix the remaining issues.
Comment 3 Karel Klíč 2011-01-14 08:49:01 EST
After more thinking, my conclusion is that Emacs should require neither aspell, nor hunspell. Emacs' ispell.el is not designed to work out of the box, without configuring it properly. By depending on aspell and hunspell we do not make it easier to configure it.

If both aspell and hunspell are installed and ispell-program-name variable is not set by user, Emacs automatically selects aspell, because it supports it better.

The best way how to setup spell checking in Emacs nowadays is to set ispell-program-name and ispell-dictionary in ~/.emacs, and add installed dictionaries to ispell-dictionary-base-alist (also in ~/.emacs).

The emacs package does not depend on external programs which might be used by various parts of Emacs, such as GDB, pychecker, (La)TeX, and version control systems. Spell checking should not be an exception, especially when it cannot work reliably out of the box.

I have removed both hunspell and aspell dependencies from Emacs in Rawhide, and I think we should do the same for RHEL.
Comment 7 Jaromir Hradilek 2011-03-22 11:36:23 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the emacs packages required the aspell and hunspell spell checkers to be installed. Since the use of a spell checker is completely optional, this update removes aspell and hunspell from the list of dependencies, so that Emacs can now be installed without these packages.
Comment 8 errata-xmlrpc 2011-05-19 10:10:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0717.html

Note You need to log in before you can comment on or make changes to this bug.