Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 613802 - glxBlockClients stays TRUE even after complete resume
glxBlockClients stays TRUE even after complete resume
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 16:44 EDT by Colin Walters
Modified: 2012-04-18 13:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 13:22:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 28998 None None None Never

  None (edit)
Description Colin Walters 2010-07-12 16:44:30 EDT
I'm getting my GLX app hanging like this:

(gdb) bt
#0  0x00639416 in __kernel_vsyscall ()
#1  0x00ecbe9b in __poll (fds=0xbfb31c38, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:83
#2  0x006a40c0 in ?? () from /usr/lib/libxcb.so.1
#3  0x006a5d52 in xcb_wait_for_reply () from /usr/lib/libxcb.so.1
#4  0x00705268 in _XReply (dpy=0x8a76ba8, rep=0xbfb31da0, extra=0, discard=0) at xcb_io.c:532
#5  0x062ef04a in QueryVersion (dpy=0x8a76ba8) at glxext.c:358
#6  __glXInitialize (dpy=0x8a76ba8) at glxext.c:847
#7  0x062eaefa in glXQueryVersion (dpy=0x8a76ba8, major=0xbfb31e2c, minor=0xbfb31e28) at glxcmds.c:647
#8  0x051f2701 in clutter_backend_glx_post_parse (backend=0x8a27020 [ClutterBackendGLX], error=0xbfb31f2c)
    at clutter-backend-glx.c:110
#9  0x05185230 in _clutter_backend_post_parse (backend=0x8a27020 [ClutterBackendGLX], error=0xbfb31f2c)
    at ./clutter-backend.c:269
#10 0x051a627c in clutter_init_real (error=0xbfb31f2c) at ./clutter-main.c:1537
#11 0x0804fa5a in ?? ()
#12 0x00e0bcf6 in __libc_start_main (main=0x804f8f0, argc=1, ubp_av=0xbfb31ff4, init=0x805f520, fini=0x805f510, rtld_fini=
    0x320160 <_dl_fini>, stack_end=0xbfb31fec) at libc-start.c:226
#13 0x0804f851 in ?? ()

This appears to be because
glxSuspendClients was called, without being undone from glxDRIEnterVT, but I'm clearly in a desktop login.  My guess is somehow the VT switch event is being lost?
Comment 1 Dave Airlie 2010-07-12 19:45:16 EDT
upstream bug, fixes not upstream yet. waiting for jbarnes and keithp.
Comment 2 Owen Taylor 2010-07-13 17:56:59 EDT
Looks like a fix landed upstream
Comment 3 Bug Zapper 2010-07-30 08:32:14 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Adam Jackson 2012-04-18 13:22:23 EDT
Presumably no longer an issue in F15+.

Note You need to log in before you can comment on or make changes to this bug.