Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 613846 - error in sorting a column of dates
error in sorting a column of dates
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: fedora-websites (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: Fedora Websites Team
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 19:35 EDT by John Reiser
Modified: 2013-06-17 20:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-17 20:02:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing bad sort of calendar dates (104.55 KB, image/png)
2010-07-12 19:36 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2010-07-12 19:35:42 EDT
Description of problem: Sorting the Updated column (calendar dates) of Fedora 14 Accepted Features gives a list which is not sorted correctly.


Version-Release number of selected component (if applicable):
last modified on 12 July 2010, at 14:01

How reproducible: every time


Steps to Reproduce:
1.https://fedoraproject.org/wiki/Releases/14/FeatureList
2.Sort the Updated column by clicking on the icon in the header of that column.
3.
  
Actual results: The two items with the most recent dates (in this case 2010-07-12 and 2010-07-11) are not in the correct order.


Expected results: The items are sorted correctly.


Additional info: See sceenshot attached.
Comment 1 John Reiser 2010-07-12 19:36:43 EDT
Created attachment 431300 [details]
screenshot showing bad sort of calendar dates
Comment 2 Sijis Aviles 2010-07-12 20:20:00 EDT
There was an extra space in the wiki page which was causing this inconsistency.

It should be fixed now.
Comment 3 John Reiser 2010-07-12 22:25:06 EDT
Yes, now the displayed order is correct.  However, there is some doubt whether the fix is robust.  If only the data was changed (extra space character removed) then that is not a good enough fix, because the problem will reappear when the next date is entered with an extra space.  Instead, the software must be changed either to parse the entry the sort as a binary value, or at a minimum to strip all whitespace characters before sorting as a character string (taking advantage of the feature of ISO 8601 format for representation of a date, where order as a character-string is isomorphic to order as a date.)
Comment 4 Pete Travis 2013-06-17 10:57:16 EDT
The current accepted features page at http://fedoraproject.org/wiki/Releases/19/FeatureList looks like it is sorting properly; John, are you satisfied with the current behavior, or should we keep this open?
Comment 5 John Reiser 2013-06-17 18:31:30 EDT
Yes, the "Updated" column for Fedora 19 Feature List sorts correctly.  Satisfied.
Comment 6 Pete Travis 2013-06-17 20:02:39 EDT
Thanks, looks like the wiki no longer has this issue.

Note You need to log in before you can comment on or make changes to this bug.