Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 613894 - Ping-Pong migration cause win2008 R2 guest reboot
Ping-Pong migration cause win2008 R2 guest reboot
Status: CLOSED DUPLICATE of bug 612481
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 02:30 EDT by Mike Cao
Modified: 2013-01-09 17:51 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 00:57:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reboot Screen dump (20.46 KB, image/png)
2010-07-13 02:38 EDT, Mike Cao
no flags Details

  None (edit)
Description Mike Cao 2010-07-13 02:30:56 EDT
Description of problem:
Do ping-pong migration with cpu loaded win2008 R2 guest,cause guest reboot.

Version-Release number of selected component (if applicable):
# uname -r
2.6.32-44.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.91.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1.start a VM in the src host,eg:
/usr/libexec/qemu-kvm -M rhel6.0.0 -enable-kvm -m 8192 -smp 8,sockets=8,cores=1,threads=1 -name win2k8r2 -uuid 93f30ee8-3af0-4c76-afd6-c166c7413fcc -nodefconfig -nodefaults -monitor stdio -rtc base=localtime -boot c -drive file=/dev/vgtest/win2k8,if=none,id=drive-ide0-0-0,boot=on,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=52:54:00:72:a4:a8,bus=pci.0,addr=0x4 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -device usb-tablet,id=input0 -vnc :3 -k en-us -vga std -device AC97,id=sound0,bus=pci.0,addr=0x5 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3
2.in the Guest ,run cpu-burn tools to load cpu ,In my case,I open 5 cpu-burn ,load cpu usage to 70%-80%
3.in the dest host # <commandLine> -incoming tcp:0:5888
4.in the src host (qemu) migrate -d tcp:<ip>:5888
5.use vncviewe to view the guest
  
Actual results:
After migration ,the guest is very slow for responding user's operation. After more or less 1 minute ,the guest reboot.

Expected results:


Additional info:

Host cpu:# cat /proc/cpuinfo 

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping        : 4
cpu MHz         : 1600.000
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 0
cpu cores       : 4
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida tpr_shadow vnmi flexpriority ept vpid
bogomips        : 5320.16
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping        : 4
cpu MHz         : 1600.000
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 1
cpu cores       : 4
apicid          : 2
initial apicid  : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida tpr_shadow vnmi flexpriority ept vpid
bogomips        : 5319.07
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 2
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping        : 4
cpu MHz         : 1600.000
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 2
cpu cores       : 4
apicid          : 4
initial apicid  : 4
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida tpr_shadow vnmi flexpriority ept vpid
bogomips        : 5532.00
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 3
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping        : 4
cpu MHz         : 1600.000
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 3
cpu cores       : 4
apicid          : 6
initial apicid  : 6
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida tpr_shadow vnmi flexpriority ept vpid
bogomips        : 5319.07
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 4
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping        : 4
cpu MHz         : 1600.000
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 0
cpu cores       : 4
apicid          : 1
initial apicid  : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida tpr_shadow vnmi flexpriority ept vpid
bogomips        : 5319.07
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 5
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping        : 4
cpu MHz         : 1600.000
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 1
cpu cores       : 4
apicid          : 3
initial apicid  : 3
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida tpr_shadow vnmi flexpriority ept vpid
bogomips        : 5319.07
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 6
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping        : 4
cpu MHz         : 1600.000
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 2
cpu cores       : 4
apicid          : 5
initial apicid  : 5
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida tpr_shadow vnmi flexpriority ept vpid
bogomips        : 5319.07
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 7
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping        : 4
cpu MHz         : 1600.000
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 3
cpu cores       : 4
apicid          : 7
initial apicid  : 7
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida tpr_shadow vnmi flexpriority ept vpid
bogomips        : 5648.63
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

# kvm_stat -1
efer_reload                    0         0
exits                    8281160         0
fpu_reload               2142199         0
halt_exits                135706         0
halt_wakeup               133325         0
host_state_reload        2143236         0
hypercalls                     0         0
insn_emulation           1223008         0
insn_emulation_fail            0         0
invlpg                         0         0
io_exits                  842663         0
irq_exits                5661350         0
irq_injections            522895         0
irq_window                 13108         0
largepages                     0         0
mmio_exits                 12679         0
mmu_cache_miss              1317         0
mmu_flooded                    0         0
mmu_pde_zapped                 0         0
mmu_pte_updated                0         0
mmu_pte_write                  0         0
mmu_recycled                   0         0
mmu_shadow_zapped            925         0
mmu_unsync                     0         0
nmi_injections                 0         0
nmi_window                     0         0
pf_fixed                  371785         0
pf_guest                       0         0
remote_tlb_flush            3416         0
request_irq                    0         0
signal_exits                   8         0
tlb_flush                      0         0
Comment 2 Mike Cao 2010-07-13 02:38:28 EDT
Created attachment 431359 [details]
Reboot Screen dump
Comment 4 Amit Shah 2010-07-15 07:12:24 EDT
The cmd line uses IDE device for the hard disk. This could be related to the h/d save/restore bug; Juan, can you confirm it's that?
Comment 5 Dor Laor 2010-07-22 16:45:17 EDT
Can QE re-test with virtio devices to narrow down the issue?
Comment 8 Juan Quintela 2010-07-26 14:16:27 EDT
We have backported this patches with my ide subsections work.  Upstream (and patches posted) are wrong (version is changed in the wrong place).

Trying to reproduce locally.
Comment 9 Dor Laor 2010-07-27 05:58:45 EDT
Please try to reproduce with latest qemu-kvm/kernel
Comment 10 Mike Cao 2010-07-28 00:22:51 EDT
(In reply to comment #5)
> Can QE re-test with virtio devices to narrow down the issue?    

Host info:
# uname -r
2.6.32-52.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.99.el6.x86_64

Retest win2008R2 Guest with load virtio device for 10 times ,

CLI:/usr/libexec/qemu-kvm -M rhel6.0.0 -cpu qemu64,+sse2,+x2apic -enable-kvm -m
8G -smp 8,sockets=8,cores=1,threads=1 -name win2k8_r2 -uuid `uuidgen`
-nodefconfig -monitor stdio -rtc base=utc -boot c -drive
file=/dev/mike/win08_r2.raw,if=none,id=drive-ide0-0-0,boot=on,format=raw,cache=none,werror=stop,rerror=stop
-device virtio-blk-pci,drive=drive-ide0-0-0 -netdev tap,id=hostnet0,vhost=on
-device
virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:20:8d:62:99,bus=pci.0,addr=0x5
-chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -device
usb-tablet,id=input0 -vnc :10 -device virtio-balloon-pci,id=balloon0 -qmp
tcp:0:4444,server,nowait

Actual Results:
Can not reproduced .After migration Guest can use successfully.
Comment 11 Mike Cao 2010-07-28 01:37:19 EDT
# uname -r
2.6.32-52.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.99.el6.x86_64

Retest win2008R2 Guest with load ide device for 10 times ,

Repeat steps in the comment #0.
CLI:/usr/libexec/qemu-kvm -M rhel6.0.0 -enable-kvm -m 8192 -smp 8,sockets=8,cores=1,threads=1 -name win2k8r2 -uuid `uuidgen` -nodefconfig -monitor stdio -rtc base=localtime -boot c -drive file=/dev/mike/win2k8,if=none,id=drive-ide0-0-0,boot=on,format=raw,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=52:54:00:72:a4:a8,bus=pci.0,addr=0x4 -chardev pty,id=serial0 -device isa-serial,chardev=serial0 -usb -device usb-tablet,id=input0 -vnc :3 -k en-us -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3

Actual Results:
After migraion ,Windown 2008 R2 guest with load ide disk can be used successfully.

Can not reproduce this issue.
Comment 12 Amit Shah 2010-07-28 02:05:55 EDT
(In reply to comment #11)
> 
> Repeat steps in the comment #0.
> CLI:/usr/libexec/qemu-kvm -M rhel6.0.0 -enable-kvm -m 8192 -smp
> 8,sockets=8,cores=1,threads=1 -name win2k8r2 -uuid `uuidgen` -nodefconfig
> -monitor stdio -rtc base=localtime -boot c -drive
> file=/dev/mike/win2k8,if=none,id=drive-ide0-0-0,boot=on,format=raw,cache=none

> Can not reproduce this issue.    

Can you try with qcow2 instead of raw? As per the earlier report, raw was fine but qcow2 was not.
Comment 13 Amit Shah 2010-07-28 02:11:33 EDT
(In reply to comment #12)

> Can you try with qcow2 instead of raw? As per the earlier report, raw was fine
> but qcow2 was not.    

Ah; I confused this with another bug report. Even then, it'll be interesting to see results with qcow2.
Comment 14 Juan Quintela 2010-07-28 20:53:58 EDT
I think this is a duplicate of 618601. raw works and qcow2 fails.  qcow2 can fail when migration with stressed IO.  I sent patches for this issue today, and hope that I will get ack's tomorrow.
Comment 15 Juan Quintela 2010-07-28 20:55:17 EDT
/me re-reads and sees this only happens with raw.  raw has the same issue that qcow2 here, but race should be way smaller (I haven't reproduced it there in the past).
Comment 16 Mike Cao 2010-07-28 21:56:06 EDT
(In reply to comment #12)  
> 
> Can you try with qcow2 instead of raw? As per the earlier report, raw was fine
> but qcow2 was not.    

Test with virtio qcow2 images and ide qcow2 images both 10 times with -smp 2 -m 4G 


Actual Results:
After migraion ,Guest does not reboot. 
Can not reproduce this issue.
Comment 17 Amit Shah 2010-07-29 00:57:22 EDT
Thanks; this was the ide migration bug, marking as a dupe of the one that fixed it.

*** This bug has been marked as a duplicate of bug 612481 ***

Note You need to log in before you can comment on or make changes to this bug.