Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 613906 - After the installation the file /var/log/yum.log has wrong selinux context
After the installation the file /var/log/yum.log has wrong selinux context
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 03:46 EDT by Karel Srot
Modified: 2014-01-21 01:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 10:21:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Srot 2010-07-13 03:46:09 EDT
Description of problem:
After the installation the file /var/log/yum.log has wrong selinux context

[root@dell-pe6950-01 ~]# ls -Z /var/log/yum.log 
-rw-r--r--. root root system_u:object_r:var_log_t:s0   /var/log/yum.log
[root@dell-pe6950-01 ~]# matchpathcon /var/log/yum.log
/var/log/yum.log	system_u:object_r:rpm_log_t:s0


Version-Release number of selected component (if applicable):
RHEL6.0-20100707.4, yum-3.2.27-12.el6

How reproducible:
always

Steps to Reproduce:
1. install fresh RHEL6 system
Comment 1 James Antill 2010-07-13 12:23:28 EDT
This being created by anaconda?
Do we need to do something?
Comment 2 Bill Nottingham 2010-07-13 12:47:55 EDT
Anaconda has a list of things to run restorecon on, this may need to be added there.
Comment 3 James Antill 2010-07-13 12:53:29 EDT
Ahh, at a guess this will affect everything that got fixed by one of the installroot path fixes (so they are now in the correct place instead of /mnt/sysroot/*).

I think that should be just /var/lib/yum/* and /var/log/yum.log ... but don't hold me to that list :)
Comment 4 RHEL Product and Program Management 2010-07-15 11:11:59 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Brian Lane 2010-07-15 12:17:52 EDT
How was this system installed? Was it a minimal install? Desktop? Or ?

After doing a minimal install I have no /var/log/yum.log file and the context of /var/lib/yum/* is all correct. If I run yum update on the new system it creates /var/log/yum.log with the correct context.
Comment 6 Karel Srot 2010-07-16 08:02:27 EDT
I tried few more installations and I can confirm your results. The original system was installed in Beaker therefore I expect the issue is probably caused by Beaker environment. I think we can close this bug, sorry for confusion.
Comment 7 Martin Cermak 2010-07-16 09:14:28 EDT
> After doing a minimal install I have no /var/log/yum.log file and the 
> context of /var/lib/yum/* is all correct. If I run yum update on the 
> new system it creates /var/log/yum.log with the correct context.    

I can confirm this. But even with the "Standard server" installation I didn't
get any /var/log/yum.log file.

Note You need to log in before you can comment on or make changes to this bug.