Bug 613920 - piranha init script -- status and stop actions do not work well
piranha init script -- status and stop actions do not work well
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: piranha (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 04:51 EDT by Milos Malik
Modified: 2012-09-21 04:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: piranha-0.8.5-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 17:13:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (480 bytes, patch)
2010-07-14 06:06 EDT, Marek Grac
no flags Details | Diff

  None (edit)
Description Milos Malik 2010-07-13 04:51:13 EDT
Description of problem:
Both "status" and "stop" actions implemented by init script do not work well. Does not matter if SELinux is in enforcing or permissive mode. The result is always the same.

Version-Release number of selected component (if applicable):
ipvsadm-1.25-7.el6.i686
piranha-0.8.5-6.el6.i686
selinux-policy-3.7.19-31.el6.noarch
selinux-policy-targeted-3.7.19-31.el6.noarch

How reproducible:
always

Steps to Reproduce:
# getenforce 
Permissive
# ps auxZ | grep piranha
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 8308 0.0  0.1 4308 748 pts/0 S+ 10:44   0:00 grep piranha
# service piranha-gui start
Starting piranha-gui:                                      [  OK  ]
# ps auxZ | grep piranha
unconfined_u:system_r:piranha_web_t:s0 root 8320 0.4  1.1 24220  6064 ?        Ss   10:45   0:00 /usr/sbin/httpd -f /etc/sysconfig/ha/conf/httpd.conf
unconfined_u:system_r:piranha_web_t:s0 piranha 8322 0.0  0.5 24220 3052 ?      S    10:45   0:00 /usr/sbin/httpd -f /etc/sysconfig/ha/conf/httpd.conf
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 8324 0.0  0.1 4308 744 pts/0 S+ 10:45   0:00 grep piranha
# service piranha-gui status
piranha_gui is stopped
# service piranha-gui stop
Shutting down piranha-gui:                                 [FAILED]
# ps auxZ | grep piranha
unconfined_u:system_r:piranha_web_t:s0 root 8320 0.0  1.1 24220  6064 ?        Ss   10:45   0:00 /usr/sbin/httpd -f /etc/sysconfig/ha/conf/httpd.conf
unconfined_u:system_r:piranha_web_t:s0 piranha 8322 0.0  0.5 24220 3052 ?      S    10:45   0:00 /usr/sbin/httpd -f /etc/sysconfig/ha/conf/httpd.conf
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 8350 0.0  0.1 4308 748 pts/0 S+ 10:45   0:00 grep piranha
#
  
Actual results:


Expected results:


Additional info:
One of the httpd processes is running under root and the other is running under piranha user. Is it intentional?
Comment 2 Marek Grac 2010-07-14 06:06:25 EDT
Created attachment 431725 [details]
Proposed patch

Two problems due to change for SELinux:
 * different path to PID file
 * different application to run
   piranha status returns 'httpd is running' but this is only minor problem as piranha is in fact httpd
Comment 6 releng-rhel@redhat.com 2010-11-10 17:13:44 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.