Bug 613976 - polkit shows authentication dialog on display 0 not the desired one
polkit shows authentication dialog on display 0 not the desired one
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: polkit-gnome (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: David Zeuthen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 08:20 EDT by Vladimir Benes
Modified: 2013-03-05 23:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 09:59:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2010-07-13 08:20:39 EDT
Description of problem:
when running vnc session from terminal from GNOME authenticating dialog shows itself on screen 0 not in the vnc session one. What more if I run vnc session with running Xorg authentication fails by default.
Hardcoded display 0? 

Version-Release number of selected component (if applicable):
polkit-0.96-2.el6.x86_64
polkit-gnome-0.96-3.el6.x86_64

How reproducible:


Steps to Reproduce:
1.open vnc session from GNOME
2.connect to the session
3.install package via add/remove software app
  
Actual results:
auth dialog shows on display 0

Expected results:
auth dialog shown on the same display as app needing it 

Additional info:
Comment 1 David Zeuthen 2010-07-13 09:59:40 EDT
This is a problem with VNC not properly registering with ConsoleKit. Since polkit relies on ConsoleKit having correct information available, this isn't something that can be fixed in polkit. I think bug 528511 is related to this.

Note You need to log in before you can comment on or make changes to this bug.