Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 613977 - Window xp guest only find one usb storage device after hot plug in two usb disk
Window xp guest only find one usb storage device after hot plug in two usb disk
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
:
Depends On:
Blocks: 580953
  Show dependency treegraph
 
Reported: 2010-07-13 08:22 EDT by juzhang
Modified: 2013-01-09 17:51 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-29 07:19:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description juzhang 2010-07-13 08:22:28 EDT
Description of problem:
Window xp guest only find one usb storage device after hot plug in two usb disk.In device manager,USB Mass Storage device show yellow !.

Version-Release number of selected component (if applicable):
#uname -r
2.6.32-44.el6.x86_64
#rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.91.el6.x86_64


How reproducible:


Steps to Reproduce:
1.boot guest
#/usr/libexec/qemu-kvm -m 2G -smp 2 -drive file=/root/zhangjunyi/winxp_32.raw,if=none,id=test,boot=on,cache=none,format=raw -device ide-drive,drive=test,bus=ide.0,id=ide0-0-0 -cpu qemu64,+sse2,+x2apic -monitor stdio -drive file=/root/zhangjunyi/boot.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,drive=drive-ide0-1-0 -boot order=cdn,menu=on -netdev tap,id=hostnet0,vhost=on -device rtl8139,netdev=hostnet0,id=net0,mac=22:11:22:45:66:97 -vnc :10 -qmp tcp:0:4444,server,nowait -drive if=floppy,file=/root/zhangjunyi/floppy.img -device piix3-usb-uhci,id=uhci123

2.telnet the qmp and issue qmp_capabilities
#{"execute":"qmp_capabilities"}

3. check usb device info
(qemu) info usb

4.hot add first usb storage driver and device
#{"execute":"__com.redhat_drive_add", "arguments": {"file":"/root/zhangjunyi/usb.img","id":"usb1"}}
#{"execute":"device_add","arguments":{"driver":"usb-storage","drive":"usb1","id":"dusb1"}}

5 check usb device info again
(qemu) info usb
 Device 0.1, Speed 12 Mb/s, Product QEMU USB MSD

6.hot add second usb storage driver and device
#{"execute":"__com.redhat_drive_add", "arguments": {"file":"/root/zhangjunyi/usb2.img","id":"usb3"}}
#{"execute":"device_add","arguments":{"driver":"usb-storage","drive":"usb3","id":"dusb3"}}

7. check usb device info again.
(qemu) info usb
  Device 0.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.0, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.0, Speed 12 Mb/s, Product QEMU USB MSD 
 
Actual results:
After step4, In guest,guest find device and work well.After step6,still just find one device.the other device was not found. step7 is very strange,compare to step5. add two "Device 0.0, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.0, Speed 12 Mb/s, Product QEMU USB MSD" 

Expected results:
Both two usb device was found in guest.

Additional info:
I also tested linux guest and win7 64 guest. all can find device in guest.
Comment 5 Markus Armbruster 2011-04-29 07:19:45 EDT
Closing NOTABUG, because because device usb-storage is not available in RHEL-6, and therefore any bugs it might have can't affect RHEL-6.

The bug was reported against qemu-kvm-0.12.1.2-2.91.el6.x86_64, which still had the device.  It's gone since 100.el6.

Note You need to log in before you can comment on or make changes to this bug.