Bug 614039 - jon 2.3.1 agent has problem with JmsXA when characters -, _ are in directory path name [NEEDINFO]
Summary: jon 2.3.1 agent has problem with JmsXA when characters -, _ are in directory ...
Status: CLOSED WONTFIX
Alias: None
Product: RHQ Project
Classification: Other
Component: Agent   
(Show other bugs)
Version: 1.3.1
Hardware: All All
low
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-13 14:46 UTC by dsteigne
Modified: 2018-10-27 16:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-07 16:02:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cwelton: needinfo? (ian.springer)


Attachments (Terms of Use)

Description dsteigne 2010-07-13 14:46:45 UTC
Description of problem:

when the path ${JBOSS_HOME}/server/<INSTANCE> contains special characters in <INSTANCE> the agent reports that JmsXA is not available.
we had "webs-default" for the instance name and experienced this problem.
In our troubleshooting we moved the directory to "default" and the problem went away.
We then moved the directory to "webs_default" and the problem came back.
There seems to be something in the agent code that prevents special characters (hyphen and underscore anyway) from being used in the instance.


Version-Release number of selected component (if applicable):
2.3.1

Comment 1 dsteigne 2010-07-13 15:21:54 UTC

SunOS 5.10 Generic_138888-01 sun4v sparc SUNW,SPARC-Enterprise-T5120

jboss - Release ID: JBoss [EAP] 5.0.1 (build: SVNTag=JBPAPP_5_0_1 date=201003301050)

java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Server VM (build 16.3-b01, mixed mode)

JON Server:
version: 2.3.1.GA
build number: 10566

Jboss AS 5 plugin:
jopr-jboss-as-5-plugin-2.3.1.GA.jar  Feb 24 19:02

Comment 2 Corey Welton 2010-09-28 12:39:11 UTC
 ips - can you track down the root cause?

Comment 3 Heiko W. Rupp 2013-12-07 16:02:03 UTC
Closing as outdated.


Note You need to log in before you can comment on or make changes to this bug.