Bug 61416 - clearpart --drives didn't work
Summary: clearpart --drives didn't work
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-19 11:35 UTC by Mitsuo Hamada
Modified: 2007-04-18 16:41 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2002-03-28 22:18:28 UTC


Attachments (Terms of Use)

Description Mitsuo Hamada 2002-03-19 11:35:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; T312461)

Description of problem:
clearpart --drives hda couldn't clear partitions on hda.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Whenever I use kickstart mode and use clearpart --drives.

Additional info:

Comment 1 Jeremy Katz 2002-03-19 16:48:48 UTC
What happens when you try to use it?

Comment 2 Mitsuo Hamada 2002-03-20 01:54:04 UTC
Because all partitions on hda still remain, anaconda cannot make / partition 
on hda.

Comment 3 Jeremy Katz 2002-03-28 22:46:55 UTC
Oh, sorry... I was being brain dead the first time I replied.

You also need to specify what is being removed, ie 'clearpart --all
--drives=hda' to remove all partitions from hda.  Otherwise, it still defaults
to not removing any types of partitions.

Comment 4 Mitsuo Hamada 2002-04-01 08:15:16 UTC
'clearpart --all --drives sda' delete all partitions on both sda and sdb
and stopped at 'part /backup --size 4096 --onpart sdb1 --noformat --grow'.
How can I delete all partitions on hda and reallocate sdb1?

Comment 5 Jeremy Katz 2002-04-04 22:31:49 UTC
This works for me here... my kickstart config looks like the following

lang en_US
langsupport --default=en_US
network --bootproto dhcp
nfs --server host --dir location
keyboard us
clearpart --all --drives=hda
part / --size 1500
part swap --recommended
part /home --noformat --onpart hdb2
install
mouse generic3ps/2
timezone US/Eastern
skipx
rootpw changeme
auth --useshadow --enablemd5
firewall --medium --ssh --dhcp
bootloader
%packages
@Base

Comment 6 Mitsuo Hamada 2002-04-11 01:36:54 UTC
OK! I will try it again.

Comment 7 Mitsuo Hamada 2002-04-12 01:26:14 UTC
I tried it.  Ananconda stopped with error which told me that
part command requires --size option.
Did your sample really work well?
Which version of anaconda did you use?


Note You need to log in before you can comment on or make changes to this bug.