This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 614259 - Problems in Publican Website docs
Problems in Publican Website docs
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Ruediger Landmann
Fedora Extras Quality Assurance
:
: 638811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 20:09 EDT by Ruediger Landmann
Modified: 2010-11-23 23:19 EST (History)
6 users (show)

See Also:
Fixed In Version: publican-2.2-0.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-10 19:26:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2010-07-13 20:09:39 EDT
Posted in Publican list by jwulf@redhat.com:

https://www.redhat.com/archives/publican-list/2010-July/msg00041.html

I built a Publican website the other day, and took the notes below on the user docs.

Anyone else tried to follow them and noticed similar things?

- Josh

Notes on section 6.2 in the Publican User Guide:

1. Should be a procedure, rather than an orderedlist.
2. Step 8 fails with "langs is a mandatory argument"
3. Adding --langs=en-US, fails with
"Beginning work on en-US
Cannot locate main XML file: 'JBoss_Enterprise_Application_Platform.xml' at /usr/bin/publican line 622"

 - this is caused by editing Article_Info.xml in accordance with step 3
Instruction should be given:

mv en-US/Home_Page.xml en-US/<replaceable>&lt;title&gt;</replaceable>.xml
mv en-US/Home_Page.ent en-US/<replaceable>&lt;title&gt;</replaceable>.ent

Where <replaceable>&lt;title&gt;</replaceable> is the value you entered in Article_Info.xml

4. Step 4 covers two completely different things - web_home, and search. Should be split up
Comment 1 Ruediger Landmann 2010-07-16 01:25:18 EDT
Thanks for these, Josh; I've just checked in a revised version of the chapter. I'm responding to some specific points below:

> 1. Should be a procedure, rather than an orderedlist.

It's always been a procedure, never an orderedlist.

> 2. Step 8 fails with "langs is a mandatory argument"

Fixed -- thanks

> 3. Adding --langs=en-US, fails with
> "Beginning work on en-US
> Cannot locate main XML file: 'JBoss_Enterprise_Application_Platform.xml' at
> /usr/bin/publican line 622"

This happened because you changed the contents of the <title> tag; the same thing would happen if you altered the <title> tag of any document built in Publican. The home page for a Publican website is just an <article> like any other -- the sole difference being the "web_home: 1" set in the publican.cfg file.

The original wording of step 3 did not list <title> among the tags that you could change. However, I've now modified both step 1 and step 3 to discuss the implications of the <title> tag in more detail, including how to prevent the title displaying on the home page.

> 4. Step 4 covers two completely different things - web_home, and search. Should
> be split up    

Step 4 covers editing the publican.cfg file. Since all but one of the changes there are purely optional, I'm reluctant to split each possible change discussed into its own step. However, I've changed the presentation of the optional parameters to clarify them slightly (I hope).

Thanks again for helping make the documentation better!

Cheers
Rudi
Comment 2 Ruediger Landmann 2010-09-30 20:40:10 EDT
*** Bug 638811 has been marked as a duplicate of this bug. ***
Comment 3 Andrew Ross 2010-10-10 19:19:37 EDT
Found a minor typo in the path:

6.2.4. Installing, updating and removing documents

"Publican builds an RPM package and places it in the /tmp/rpms/noarch/"

On F13:
 - There was no /tmp/rpms directory
 - Perhaps this ./tmp/rpm/noarch/ is the location?

Note You need to log in before you can comment on or make changes to this bug.