Bug 614271 - [ibus] abrt detected ibus crash (SIGSEGV)
[ibus] abrt detected ibus crash (SIGSEGV)
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ibus (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: fujiwara
QE Internationalization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-13 21:40 EDT by Kenichi Takemura
Modified: 2014-08-04 18:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-28 00:29:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of abrt (192.88 KB, image/png)
2010-07-13 21:40 EDT, Kenichi Takemura
no flags Details
Backtrace of ibus (15.21 KB, text/plain)
2010-07-13 21:42 EDT, Kenichi Takemura
no flags Details

  None (edit)
Description Kenichi Takemura 2010-07-13 21:40:09 EDT
Description of problem:

IBus crashed due to SIGSEGV.
I attach backstrace and screenshot.


Version-Release number of selected component (if applicable):


How reproducible:

One time.

Steps to Reproduce:
1. Install IBus and all input method packages.
2. Repeat Restart, Quit, Start several times. 
3. Remove ibus-table-additional by yum and restart IBus
3. Remove ibus-rawcode by yum and restart IBus
  
Actual results:

IBus has gone.

Expected results:

IBus does not crash.

Additional info:
Comment 1 Kenichi Takemura 2010-07-13 21:40:51 EDT
Created attachment 431640 [details]
Screen shot of abrt
Comment 3 Kenichi Takemura 2010-07-13 21:41:48 EDT
Package: ibus-1.3.4-1.el6.x86_64
Comment 4 Kenichi Takemura 2010-07-13 21:42:20 EDT
Created attachment 431641 [details]
Backtrace of ibus
Comment 5 fujiwara 2010-07-13 23:42:01 EDT
I cannot reproduce your problem.

Since you got one time only and I don't see any problems, currently I'd think
this would be low priority or closed as WORKSFORME.

If you always can see your problem, please provide the furthermore information.
e.g.
From your backtrace, it seems ibus panel crashed. Your stack was caused by C
but ibus panel is Python.
Please run ibus panel by manual and see what warnings are output when ibus
crashes.

% ps -ef | grep ibus
tester   26389 26386  python /usr/share/ibus/ui/gtk/main.py
% kill 26389
% env IBUS_PREFIX=/usr python /usr/share/ibus/ui/gtk/main.py
Comment 6 RHEL Product and Program Management 2010-07-15 10:19:10 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 7 Kenichi Takemura 2010-07-27 01:41:05 EDT
I cannot reproduce this bug.
Please close this bug.

I will reopen if I see this again.
Comment 8 fujiwara 2010-07-28 00:29:33 EDT
Thanks.

Note You need to log in before you can comment on or make changes to this bug.