Bug 614280 - [RHEL 6 Beta2] Dell Virtual Floppy being labeled /dev/sda during installation
[RHEL 6 Beta2] Dell Virtual Floppy being labeled /dev/sda during installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Tom Coughlan
Red Hat Kernel QE team
:
Depends On:
Blocks: 645454
  Show dependency treegraph
 
Reported: 2010-07-13 22:23 EDT by Mark Wu
Modified: 2011-02-17 10:29 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-23 16:36:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Wu 2010-07-13 22:23:03 EDT
Description of problem:
While installing RHEL6 Beta2 on Dell R900 with DRAC which has Virtual Media enabled, the virtual disk is assigned to /dev/sda while the RAID is set to /dev/sdb. But in previous beta's the Virtual Floppy that the DRAC presents has been set to /dev/sdb.

This is kind of important to those of us who use kickstart's to build the machines.  

Version-Release number of selected component (if applicable):
anaconda-13.21.50-9.el6.x86_64
kernel-2.6.32-37.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. enable Virtual Media provided by DRAC
2. start installing RHEL6 Beta2
3.
  
Actual results:
Virtual Floppy that the DRAC presents is set to /dev/sda

Expected results:
For the Virtual Floppy that the DRAC presents should be set to /dev/sdb and not /dev/sda.

Additional info:
It seems related to https://bugzilla.redhat.com/show_bug.cgi?id=529710
Comment 1 RHEL Product and Program Management 2010-07-15 11:04:23 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 2 Mark Wu 2010-07-16 04:57:09 EDT
Since this problem is important for kickstart installation, so could you consider setting it to blocker? 
Thanks.
Comment 4 Tom Coughlan 2010-11-19 17:51:10 EST
The kernel can assign "sd" names in any order. 

Doesn't RHEL 6 Anaconda (and kickstart) provide a way to deal with this? (Sorry, I am not familiar with it.)
Comment 5 David Cantrell 2010-11-19 20:44:12 EST
(In reply to comment #4)
> The kernel can assign "sd" names in any order. 
> 
> Doesn't RHEL 6 Anaconda (and kickstart) provide a way to deal with this?
> (Sorry, I am not familiar with it.)

You can use the ignoredisk command in the kickstart file.

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html-single/Installation_Guide/index.html#s1-kickstart2-options

For example:

ignoredisk --drives=sda

You can also specify drives using the by-id, by-label, by-path, or by-uuid names in /dev/disk as well as use wildcards to specify groups of drives to ignore.

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html-single/Migration_Planning_Guide/index.html#id2237802

For example:

ignoredisk --drives=/dev/disk/by-path/pci-0000:00:1f.2-scsi-0:0:0:0*
Comment 6 Linda Wang 2010-11-23 11:28:22 EST
looks like there is a way to deal with this issue, so
this is
Comment 7 Tom Coughlan 2010-11-23 16:36:37 EST
I'll close this BZ, on the assumption that the solution in comment 5 is acceptable. If it is not, the reopen.

Note You need to log in before you can comment on or make changes to this bug.