Bug 614347 - sa-update quits with numeric error
Summary: sa-update quits with numeric error
Status: CLOSED DUPLICATE of bug 612879
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl-Archive-Tar   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: perl-maint-list
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-14 08:10 UTC by tomczyk
Modified: 2010-07-14 10:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 08:35:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description tomczyk 2010-07-14 08:10:48 UTC
Description of problem:
After updating CentOS 5.5 to latest version perl-Archive-Tar-1.39.1-1.el5_5.1.noarch.rpm 
sa-update (spamassassin version 3.2.5) is quiting with this error:
Argument "1.39_01" isn't numeric in subroutine entry at /usr/bin/sa-update line 81.


Version-Release number of selected component (if applicable):
perl-Archive-Tar-1.39.1-1.el5_5.1.noarch.rpm


How reproducible:
update to perl-Archive-Tar-1.39.1-1.el5_5.1.noarch.rpm and run sa-update


Additional info:
Changin $VERSION vlauer in in /usr/lib/perl5/vendor_perl/5.8.8/Archive/Tar.pm

from
$VERSION = "1.39_01";

to
$VERSION = "1.3901";

"fixed" this. 
sa-update complains about any non-numeric character after the first "." in $VERSION

Comment 1 Petr Pisar 2010-07-14 08:35:11 UTC

*** This bug has been marked as a duplicate of bug 612879 ***


Note You need to log in before you can comment on or make changes to this bug.