Bug 61436 - ifconfig's showing double info. when 11 NICs installed
ifconfig's showing double info. when 11 NICs installed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-19 12:19 EST by Danny Trinh
Modified: 2015-03-04 20:10 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-16 19:02:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifconfig of 10 NICs and 11 NICs (1.62 KB, application/octet-stream)
2002-03-19 12:22 EST, Danny Trinh
no flags Details
ifconfig & /proc/vet/dev files of 10 NICs & 12NICs configurations. (2.51 KB, application/octet-stream)
2002-04-08 11:50 EDT, Danny Trinh
no flags Details

  None (edit)
Description Danny Trinh 2002-03-19 12:19:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
When the system had 11 NICs installed, ifconfig shows double info. of eth1 - 
eth10. This doesn't happen if the system has only 10 NICs

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Hardware: PE4600 + 1 embedded eepro100 + 5 dual pro100 NICs
2.Install Hampton B2
3.run ifconfig, and check the output info
4.remove the line "alias eth10 ..." in /etc/modules.conf
5.remove /etc/sysconfig/network-scripts/ifcfg-eth10 file
6.reboot PE4600, press F2 for BIOS setup, then disable the embedded NIC.
7.reboot PE4600
8.run ifconfig again and check its output
	

Actual Results:  ifconfig shows double info.

Expected Results:  normal info as it used to be

Additional info:
Comment 1 Danny Trinh 2002-03-19 12:22:33 EST
Created attachment 49004 [details]
ifconfig of 10 NICs and 11 NICs
Comment 2 Danny Trinh 2002-03-21 12:57:22 EST
See this problem in beta 3 also.
Comment 3 Phil Knirsch 2002-03-26 04:28:57 EST
I've had another bugreport with ISDN cards that showed exactly the same
symptoms. Problem is, i don't have the hardware here and therefore can't
reproduce the bug, so it's going to be fairly tricky to find a fix or even the
root of the bug.

Maybe i can fix it for the ISDN devices which should then hopefully result in a
fix for this bug as well.

FYI the ISDN bug is 56429.

Read ya, Phil
Comment 4 Phil Knirsch 2002-03-28 10:30:49 EST
Could you append the output of

  cat /proc/net/dev

and

  ip addr

for 10 and 11 nics for that machine here as well? I suspect it's a parsing
problem somewhere (see the ISDN bug) as /proc/net/dev, ip and route all show the
correct number of devices, and i suspect the same to be true for this bug.

Thanks,

Read ya, Phil
Comment 5 Danny Trinh 2002-03-29 16:20:45 EST
After we upgrade Jaguar's main board, the problem goes away. I have tested with 
BIOS version A02. Also, I run the tests on 2.4.18-0.12bigmem, smp, and up 
kernels. ifconfig sees correctly 12 NIC cards.
Comment 6 Danny Trinh 2002-04-05 16:54:00 EST
I saw this on beta 4 again.
Comment 7 Phil Knirsch 2002-04-08 08:51:54 EDT
Still need the output of /proc/net/dev for 10 and 11 nics.

I don't have access to the hardware and therefore can't reproduce this bug
making it impossible to debug or even fix the problem.

Read ya, Phil
Comment 8 Danny Trinh 2002-04-08 11:50:54 EDT
Created attachment 52667 [details]
ifconfig & /proc/vet/dev files of 10 NICs & 12NICs configurations.
Comment 9 John A. Hull 2002-04-08 11:59:41 EDT
Phil, are you in Raleigh?? We sent Red Hat 6 Dual-Port Pro 100+ NICs last month 
that should help replicate the problem.
Comment 10 Phil Knirsch 2002-04-08 12:38:38 EDT
Unfortunately i am not located in Raleigh, therefore the hardware there doesn't
really help me a lot. I might ask on of the guys over there to put it in some
box, but this is very ineffective.

I'll try to get by with the /proc/net/dev output and see wether thats already
enough info to debug and create a fix.

Read ya, Phil
Comment 11 Jeremy Katz 2002-04-12 00:27:33 EDT
Ick, net-tools is ugly code.  Fixed in 1.60-4 and better.
Comment 12 Danny Trinh 2002-05-15 15:52:45 EDT
This bug appears in Pensacola gold version also.
Comment 13 Danny Trinh 2002-05-16 19:01:58 EDT
I reopen this bug because I saw this in Pensacola also.
Comment 14 Phil Knirsch 2002-08-20 09:12:31 EDT
Unfortunately this fix didn't make it into Pensacola final anymore.

You can use the 7.3 version of the net-tools, though if necessary. The only
difference is this small fix actually.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.