Bug 614406 - abrt did not found correct component when python died when interpreting yum process
abrt did not found correct component when python died when interpreting yum p...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
abrt_hash:0f942e761185876465ab4491450...
:
Depends On: 614332
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 08:40 EDT by Michal Nowak
Modified: 2015-02-01 17:52 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 614332
Environment:
Last Closed: 2010-08-04 06:26:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2010-07-14 08:40:00 EDT
+++ This bug was initially created as a clone of Bug #614332 +++

abrt version: 1.1.5
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/yum upgrade
component: yum
crash_function: _getopt_internal_r
executable: /usr/bin/python
global_uuid: 0f942e761185876465ab44914503bb3c9196013c
kernel: 2.6.35-0.27.rc4.git0.fc14.x86_64
package: yum-3.2.27-17.fc14
rating: 4
reason: Process /usr/bin/python was killed by signal 4 (SIGILL)
release: Fedora release 14 (Rawhide)
time: 1279089410
uid: 0

--- Additional comment from mnowak@redhat.com on 2010-07-14 03:05:03 EDT ---

Created an attachment (id=431686)
File: backtrace

--- Additional comment from mnowak@redhat.com on 2010-07-14 03:06:32 EDT ---

I was just doing yum upgrade, suddenly process have died.


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

abrt thought it's yum crash but it was python's.

abrt should have found correct component.
Comment 1 Bug Zapper 2010-07-30 08:34:25 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Jiri Moskovcak 2010-08-04 06:26:14 EDT
This is not a bug we blame the script for the python crashes, it's quite difficult to determine if the crash was caused by a bug in a python interpreter or by the script (yes, bad script can cause python to SEGV), but usually it's the script to blame for the crash, so that's why abrt blamed yum.

Jirka

Note You need to log in before you can comment on or make changes to this bug.