Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 614430 - Remote configuration Conflicts field
Remote configuration Conflicts field
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: wallaby-utils (Show other bugs)
Development
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: Will Benton
Lubos Trilety
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 09:38 EDT by Lubos Trilety
Modified: 2010-10-20 07:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Trilety 2010-07-14 09:38:36 EDT
Description of problem:
Parameter and feature Conflicts field doesn't work like it should.

Version-Release number of selected component (if applicable):
wallaby-0.6.1-2

How reproducible:
100%

Steps to Reproduce:
1. create two new parameters, one has the other in conflicts field
   E.g.
   NEW_PARAM1
   Dependencies:
   Conflicts:

   NEW_PARAM2
   Dependencies:
   Conflicts:
     NEW_PARAM1
2. add both parameters on the same node
   E.g. 'condor_configure_pool -a -n node -p NEW_PARAM1,NEW_PARAM2'
3. activate configuration changes
  
Actual results:
changes are accepted and configuration is activated

Expected results:
Conflict should be detected and activation should fail like when there are some not resolved dependency in configuration

Additional info:
similar scenario can be applied for features
Comment 1 Will Benton 2010-07-19 18:30:49 EDT
Parameter conflict checking is now supported, and feature conflict checking is improved; these changes are upstream in commit e3700af.
Comment 2 Lubos Trilety 2010-08-09 09:28:18 EDT
Tested with (version):
wallaby-0.9.2-1

Tested on:
RHEL5 x86_64,i386  - passed

>>> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.