This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 614505 - sudo yum update failing on openafs dependency
sudo yum update failing on openafs dependency
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: packaging-team-maint
BaseOS QE Security Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 11:53 EDT by Kyle Skrinak
Modified: 2014-01-21 01:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 16:50:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kyle Skrinak 2010-07-14 11:53:41 EDT
Description of problem:
Error message after failing to update

Version-Release number of selected component (if applicable):
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
kernel-i686 is needed by (installed) kmod-openafs-xen-1.4.11-1.1.2.6.18_164.el5.i686
Complete!


How reproducible:
sudo yum update

Steps to Reproduce:
1. sudo yum update
2. See verification screen:
Installing:
 kernel                   i686   2.6.18-194.8.1.el5           updates      17 M
 kernel-devel             i686   2.6.18-194.8.1.el5           updates     5.4 M
Updating:
 gnome-python2-extras     i386   2.14.2-7.el5                 updates      24 k
 gnome-python2-gtkhtml2   i386   2.14.2-7.el5                 updates      15 k
 kernel-headers           i386   2.6.18-194.8.1.el5           updates     1.0 M
Removing:
 kernel                   i686   2.6.18-164.el5               installed    41 M
 kernel-devel             i686   2.6.18-164.el5               installed    16 M
Removing for dependencies:
 kmod-openafs             i686   1.4.11-1.1.2.6.18_164.el5    installed   578 k

3.
  
Actual results:
Installing:
 kernel                   i686   2.6.18-194.8.1.el5           updates      17 M
 kernel-devel             i686   2.6.18-194.8.1.el5           updates     5.4 M
Updating:
 gnome-python2-extras     i386   2.14.2-7.el5                 updates      24 k
 gnome-python2-gtkhtml2   i386   2.14.2-7.el5                 updates      15 k
 kernel-headers           i386   2.6.18-194.8.1.el5           updates     1.0 M
Removing:
 kernel                   i686   2.6.18-164.el5               installed    41 M
 kernel-devel             i686   2.6.18-164.el5               installed    16 M
Removing for dependencies:
 kmod-openafs             i686   1.4.11-1.1.2.6.18_164.el5    installed   578 k


Expected results:
Updated system

Additional info:
Comment 1 seth vidal 2010-07-20 09:56:28 EDT
can you run:

rpm -q --provides kernel-2.6.18-164.el5.i686

and 

repoquery -q --provides kernel-2.6.18-194.8.1.el5

I suspect the newer one lacks the kernel-i686 provides

you can get around this most likely by removing kmod-openafs-xen
Comment 2 Kyle Skrinak 2010-07-20 22:46:48 EDT
yum remove kmod-openafs-xen fixed the problem. Thanks!

Note You need to log in before you can comment on or make changes to this bug.