Bug 614509 - Duplicate mail downloads from pop3 server
Duplicate mail downloads from pop3 server
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 11:58 EDT by Peter L R Smith
Modified: 2011-03-09 09:22 EST (History)
5 users (show)

See Also:
Fixed In Version: evolution-data-server-2.32.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-21 01:49:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 538716 None None None Never

  None (edit)
Description Peter L R Smith 2010-07-14 11:58:44 EDT
Description of problem:
On Fedora 13 Linux 2.6.33.6-147.fc13.x86_64

Evolution 2.3.2-1.fc13@x86_64, downloads duplicate mails when signing in to the mail server from different overseas locations

The problem is that duplicate mails always become a problem when I am
travelling.  It seems that when changing locations evolution does not recognise
that I have already downloaded mails still on the pop3 server (not deleted for 7
days) and downloads them again.   This means that sometimes I download the same
mail 4 times (departure airport lounge, transit airport lounge, hotel, overseas
office).  This results in many duplicated mails in my mailboxes.  Is this expected behaviour from evolution or a bug?    

Version-Release number of selected component (if applicable):
Evolution 2.3.2-1.fc13@x86_64

How reproducible:
Only reproducible from some locations.


Steps to Reproduce:
1.Logon to mailbox and download mails
2.Travel to a hotel with internet.  Logon to mailbox.  Mails downloaded again even if they have been downloaded before and still exist on the local machine.
3.
  
Actual results:

Duplicate mails in mbox

Expected results:

No duplicates

Additional info:
Comment 1 Jeff Raber 2010-07-14 14:26:41 EDT
Changing version to 13.
Comment 2 Matthew Barnes 2010-07-14 14:38:50 EDT
It sounds like what you really want is an IMAP account.
Comment 3 John Paul Adrian Glaubitz 2011-02-18 06:13:50 EST
Hi,

I am experiencing the same problem with Evolution 2.30.3 on Debian Squeeze, I haven't tested my Fedora 14 installation yet.

I would bump the priority to "medium", at least, since POP3 downloads are the _only_ possibility for Hotmail users to use an email client other than Windows Live Mail. When using WLM, one can use DeltaSync, a proprietary protocol similar to IMAP, to sync your email client with Hotmail. However, on all other clients you're stuck with POP3.

And since I do not want to delete the mails from the server after downloading them (to be able to access the mail from different locations and mail clients), I check the appropriate option in Evolutions preferences.

As you can guess, I accumulated arond 15k mails in my local folder from the repeated mail downloads, within just one or two weeks.

And since there a ALOT of Hotmail users (it's one of the largest free mail providers in the world), this bug certainly affects ALOT of people. Thus, I'd highly recommend to raise the priority.

@Matthew: That only works if you're willing to give up you're Hotmail account, which many people aren't. Luckily for me, I don't use Hotmail as my primary account and I receive a very low volume of mail, the bug is still annoying for me though.

On MacOS X, Apple's client "Apple Mail" handles Hotmail accounts over POP3 properly without downloading mails over and over again.


Regards,

Adrian
Comment 4 Milan Crha 2011-02-21 01:49:00 EST
Thanks for an update on this. I checked the upstream bugzilla (as you stated this is reproducible on Debian too, thus it's nothing specific to Fedora), and through [1] I found that this is got fixed in bug [2] since 2.32.1 and later version of evolution-data-server. Feel free to comment on the upstream bug if it doesn't work for you. Thanks.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=628766
[2] https://bugzilla.gnome.org/show_bug.cgi?id=538716
Comment 5 John Paul Adrian Glaubitz 2011-03-09 08:21:04 EST
Hi Milan,

I currently do not have an account for the GNOME bug tracker. But I just wanted to let you know, that I recently upgraded my version of Evolution on Debian to 2.32.2 from Debian unstable and the problem still persists.

The strange thing is, however, that the duplicate emails do not appear immediately. That is, when I click "Send / Receive", no duplicate emails will be downloaded. However, after having Evolution run a certain time in the background with automatic polling (1 minute interval) turned on, my Hotmail inbox will accumulate several dozen duplicates.

So it looks like that after a certain time interval has passed, Evolution discards the information about the downloaded emails and downloads them again. Or it may also be associated to emails being downloaded to through automatic polling in the background (since it doesn't occur for me when hitting "Send / Receive"). But since the emails do not duplicate every minute (which is my polling interval), I'd rather go for the theory with the expiration time.

As I said, I tested that on Debian. I will try to give it a try on a current Fedora release with at least Evolution 2.32.1 as well. If the bug appears to be fixed in Fedora, but not in Debian, I will file a bug report in the latter case.

Thanks,

Adrian
Comment 6 Milan Crha 2011-03-09 09:07:31 EST
Hmm, in that case it might not be the cache expiration issue. It can also be a server issue, who knows. What's the "certain time interval", approximately? I can try to setup it here to see whether it'll be reproducible or not, though I do not keep evolution running for long usually.
Comment 7 John Paul Adrian Glaubitz 2011-03-09 09:22:32 EST
I will setup a kvm virtual machine with Fedora 14 and an installation of Debian unstable. Then I will try to determine the exact parameters (time interval etc) for which the bug occurs.

I checked the source of the Debian package, btw, and it turned out that your patch is indeed included in Debian. It just might be that the patch solves the problem only partly, but I will find out.

Thanks,

Adrian

Note You need to log in before you can comment on or make changes to this bug.