Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 614510 - [RHEL6][Kernel] BUG: unable to handle kernel paging request at ..... RIP free_block
[RHEL6][Kernel] BUG: unable to handle kernel paging request at ..... RIP free...
Status: CLOSED DUPLICATE of bug 610947
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Larry Woodman
Red Hat Kernel QE team
http://rhts.redhat.com/testlogs/2010/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 12:02 EDT by Jeff Burke
Modified: 2010-07-19 14:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-19 14:11:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2010-07-14 12:02:03 EDT
Description of problem:
 While testing 2.6.32-48.el6.x86_64.debug kernel the system panics

Version-Release number of selected component (if applicable):
 2.6.32-48.el6.x86_64.debug

How reproducible:
 Unknown 

Actual results:
BUG: unable to handle kernel paging request at ffffeba400000000
IP: [<ffffffff8116bebe>] free_block+0x9e/0x230
PGD 0 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/devices/pci0000:00/0000:00:1c.0/0000:04:00.0/0000:05:00.0/irq
CPU 4 
Modules linked in: sunrpc p4_clockmod freq_table speedstep_lib ipv6 dm_mirror dm_region_hash dm_log bnx2 dcdbas ses enclosure serio_raw sg iTCO_wdt iTCO_vendor_support i5k_amb hwmon i5000_edac edac_core shpchp ext4 mbcache jbd2 sd_mod crc_t10dif sr_mod cdrom megaraid_sas ata_generic pata_acpi ata_piix usb_storage radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core dm_mod [last unloaded: blowfish]

Modules linked in: sunrpc p4_clockmod freq_table speedstep_lib ipv6 dm_mirror dm_region_hash dm_log bnx2 dcdbas ses enclosure serio_raw sg iTCO_wdt iTCO_vendor_support i5k_amb hwmon i5000_edac edac_core shpchp ext4 mbcache jbd2 sd_mod crc_t10dif sr_mod cdrom megaraid_sas ata_generic pata_acpi ata_piix usb_storage radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core dm_mod [last unloaded: blowfish]
Pid: 16, comm: ksoftirqd/4 Not tainted 2.6.32-48.el6.x86_64.debug #1 PowerEdge 2950
RIP: 0010:[<ffffffff8116bebe>]  [<ffffffff8116bebe>] free_block+0x9e/0x230
RSP: 0018:ffff880005603da8  EFLAGS: 00010086
RAX: ffffeba400000000 RBX: ffff88007f6b09c0 RCX: 0000000000000001
RDX: ffffea0000000000 RSI: ffff8800390da000 RDI: 0000000000000000
RBP: ffff880005603df8 R08: ffff88007f424e00 R09: 0000000000000001
R10: 0000000000000001 R11: 0000000000000001 R12: ffff88003c62e000
R13: ffff88007cec1b80 R14: 0000000000000004 R15: 000000000000101a
FS:  0000000000000000(0000) GS:ffff880005600000(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: ffffeba400000000 CR3: 000000000d89d000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process ksoftirqd/4 (pid: 16, threadinfo ffff88007cef0000, task ffff88007ceec4c0)
Stack:
 ffff88007f424e58 0000001000000000 0000000000000000 ffff88007f424e00
<0> ffff880005603df8 0000000000000010 ffff88007cec1b10 ffff88007f424e00
<0> ffff88007f6b09c0 ffff88007cec1b60 ffff880005603e58 ffffffff8116c345
Call Trace:
 <IRQ> 
 [<ffffffff8116c345>] cache_flusharray+0x95/0x180
 [<ffffffff8116bc46>] kmem_cache_free+0x256/0x2b0
 [<ffffffff810ae017>] ? trace_hardirqs_on_caller+0x67/0x190
 [<ffffffff8117b58b>] free_object_rcu+0x9b/0xa0
 [<ffffffff810f020d>] __rcu_process_callbacks+0x12d/0x3e0
 [<ffffffff810f04eb>] rcu_process_callbacks+0x2b/0x50
 [<ffffffff81077345>] __do_softirq+0xd5/0x220
 [<ffffffff810143cc>] call_softirq+0x1c/0x30
 <EOI> 
 [<ffffffff810160ad>] ? do_softirq+0xad/0xe0
 [<ffffffff81076c80>] ksoftirqd+0x80/0x120
 [<ffffffff81076c00>] ? ksoftirqd+0x0/0x120
 [<ffffffff81096856>] kthread+0x96/0xa0
 [<ffffffff810142ca>] child_rip+0xa/0x20
 [<ffffffff81013c10>] ? restore_args+0x0/0x30
 [<ffffffff810967c0>] ? kthread+0x0/0xa0
 [<ffffffff810142c0>] ? child_rip+0x0/0x20
Code: 89 c7 48 89 45 c0 e8 c2 ef ed ff 48 c1 e8 0c 48 8d 14 c5 00 00 00 00 48 c1 e0 06 48 29 d0 48 ba 00 00 00 00 00 ea ff ff 48 01 d0 <48> 8b 10 66 85 d2 0f 88 23 01 00 00 84 d2 0f 89 70 01 00 00 4c 
RIP  [<ffffffff8116bebe>] free_block+0x9e/0x230
 RSP <ffff880005603da8>
CR2: ffffeba400000000
---[ end trace 2278caac0655cd97 ]---


Expected results:


Additional info:
Comment 3 RHEL Product and Program Management 2010-07-15 11:16:04 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Larry Woodman 2010-07-19 14:11:23 EDT

*** This bug has been marked as a duplicate of bug 610947 ***

Note You need to log in before you can comment on or make changes to this bug.