Bug 61456 - tree omits large files from listing
Summary: tree omits large files from listing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tree   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-19 23:02 UTC by dharris
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-20 08:07:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dharris 2002-03-19 23:02:06 UTC
When I use tree on a directory with files greater than 2GB, the large files do 
not show up on the listing. I am using XFS (http://oss.sgi.com/projects/xfs/), 
so I am able to have files this large. The find and ls programs both show these 
large files correctly.

Version: tree-1.2-13

How Reproducible: Always

SHELL SESSION SHOWING PROBLEM:

[root@fermi david-laptop]# ls -la
total 19534980
drwxr-xr-x    2 root     root           90 Mar 19 17:49 .
drwxr-xr-x   12 root     root         4096 Mar 19 09:48 ..
-rw-r--r--    1 root     root     10489618432 Mar 19 12:45 disk-hda1
-rw-r--r--    1 root     root     54190080 Mar 19 17:22 disk-hda2
-rw-r--r--    1 root     root     9196830720 Mar 19 17:19 disk-hda3
-rw-r--r--    1 root     root     263176192 Mar 19 17:27 disk-hda5
-rw-r--r--    1 root     root            0 Mar 19 17:49 md5sums-fermi

[root@fermi david-laptop]# tree 
.
|-- disk-hda2
|-- disk-hda5
`-- md5sums-fermi

0 directories, 3 files

[root@fermi david-laptop]# find
.
./disk-hda1
./disk-hda3
./disk-hda2
./disk-hda5
./md5sums-fermi

[root@fermi david-laptop]# pwd
/mnt1/david-laptop

[root@fermi david-laptop]# mount | grep /mnt1
/dev/hdd1 on /mnt1 type xfs (rw)

Comment 1 Tim Waugh 2002-03-20 08:07:15 UTC
I see this too.  It'll be because it isn't compiled with the right flags I expect.

Comment 2 Tim Waugh 2002-03-22 14:26:43 UTC
Fixed package is tree-1.2-17.


Note You need to log in before you can comment on or make changes to this bug.