Bug 614672 - gdm does not detect smartcard insertion
gdm does not detect smartcard insertion
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-14 19:18 EDT by Chandrasekar Kannan
Modified: 2015-01-04 18:43 EST (History)
7 users (show)

See Also:
Fixed In Version: gdm-2.30.4-14.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:28:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2010-07-14 19:18:48 EDT
Description of problem:

- at the gdm greeter menu, "Smartcard authentication" is selected. 
- no card is inserted. text says "Please insert your smart card or enter your username"
- I insert my gemalto 64k card into my omnikey reader
- nothing happens. 

Version-Release number of selected component (if applicable):
esc-1.1.0-21.el6.i686
ccid-1.3.9-3.el6.i686
pcsc-lite-1.5.2-5.el6.i686
pcsc-lite-libs-1.5.2-5.el6.i686
coolkey-1.1.0-14.el6.i686
gdm-2.30.4-5.el6.i686
gnome-screensaver-2.28.3-6.el6.i686
gnome-settings-daemon-2.28.2-6.el6.i686


How reproducible:

- Always

Steps to Reproduce:

1. see description
2.
3.
  
Actual results:

- nothing happens

Expected results:

- - card should be detected and gdm should ask for my PIN


Additional info:

log to detect the card...
Jul 14 16:14:11 dhcp-115 pcscd: ifdhandler.c:964:IFDHPowerICC() action: PowerUp, usb:076b/3021:libhal:/org/freedesktop/Hal/devices/usb_device_76b_3021_noserial_if0 (lun: 0)
Jul 14 16:14:11 dhcp-115 pcscd: ifdhandler.c:964:IFDHPowerICC() action: PowerUp, usb:076b/3021:libhal:/org/freedesktop/Hal/devices/usb_device_76b_3021_noserial_if0 (lun: 0)
Jul 14 16:14:12 dhcp-115 pcscd: eventhandler.c:429:EHStatusHandlerThread() Card inserted into OmniKey CardMan 3121 00 00
Jul 14 16:14:12 dhcp-115 pcscd: eventhandler.c:429:EHStatusHandlerThread() Card inserted into OmniKey CardMan 3121 00 00
Jul 14 16:14:12 dhcp-115 pcscd: Card ATR: 3B 95 95 40 FF AE 01 03 00 00 
Jul 14 16:14:12 dhcp-115 pcscd: Card ATR: 3B 95 95 40 FF AE 01 03 00 00
Comment 2 RHEL Product and Program Management 2010-07-15 11:18:37 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Chandrasekar Kannan 2010-07-15 11:27:56 EDT
proposing as a blocker. This is a feature of rhel6 and it needs to work. if it doesn't, it needs to be considered a Regression.
Comment 4 Jack Magne 2010-07-15 14:23:06 EDT
It looks like insertions and removals are being ignored by the greeter. If the "Cancel" button is hit and then click "Smartcard Authentication", the token is accessed and the pin is requested.
Comment 5 Ray Strode [halfline] 2010-07-15 17:02:12 EDT
devack+
Comment 6 Ray Strode [halfline] 2010-07-15 19:20:32 EDT
So I tried this (while talking to Jack):

- Insert my exalto e-gate card
- GDM screen automatically selects the smartcard authentication item
- I get a screen that says:


Smart card PIN: [                                       ]
                 Welcome Ray Strode!

[ Cancel ] [ Login ]

and after typing my password and clicking "Login" it logs me in.

Note we also discovered that the driver for my smartcard has since been removed from rhel.  I was just lucky in that when it was removed it was never obsoleted so it wasn't auto removed from my system as I yum updated.

Jack is going to send me a more modern smartcard that reproduces the issue so I can help investigate.
Comment 8 Ray Strode [halfline] 2010-07-16 13:13:46 EDT
So yesterday Jack gave me remote access to his machine and we debugged together .  We discovered one issue with the way the greeter decides which drivers to listen to events from.  I spent some time last night rewriting how the driver selection code works, and Jack reported this morning that my changes work fine.

I'll build those changes shortly.

Smartcards arrived today.  I haven't tried them yet.  Thanks much.
Comment 9 Asha Akkiangady 2010-07-28 16:59:49 EDT
Tested with Gemalto 64 usb token, tokens are recognized fairly well. When token is inserted, greeter menu displays a message 'Cancelling' instead of 'Checking'.

1) Boot the computer, and wait until login screen loads, click on 'Smartcard
Authentication' login option.
2) Insert smart card
Greeter menu displays Cancelling and then requests for the token pin.
Comment 11 Asha Akkiangady 2010-07-30 17:46:36 EDT
The test in comment #9 is performed with gdm-2.30.4-13.el6. The issue mentioned in comment 9 requires a fix.
Comment 12 Ray Strode [halfline] 2010-08-03 15:29:24 EDT
I've corrected the issue discovered in comment 9 by dropping the message in that scenario entirely.

Changing the message at this point would require new translations and be a more invasive patch.
Comment 15 Asha Akkiangady 2010-08-06 13:22:42 EDT
Tested smart card login with Gemalto 64K usb token and Gemalto 64K smart card with SCR331 reader, smart card detection works fine.

1) Boot the computer, and wait until login screen loads, click on 'Smart card
Authentication' login option.
2) Insert a smart card.

After the bug fix, Greeter menu requests for the token pin directly without displaying the smart card checking status. Greeter menu does not display message 'Cancelling' any more.

Packages:
esc-1.1.0-21.el6.i686
ccid-1.3.9-3.el6.i686
pcsc-lite-1.5.2-6.el6.i686
pcsc-lite-libs-1.5.2-6.el6.i686
coolkey-1.1.0-15.el6.i686
gdm-2.30.4-15.el6.i686
gdm-libs-2.30.4-15.el6.i686
gnome-screensaver-2.28.3-8.el6.i686
gnome-settings-daemon-2.28.2-11.el6.i686
pam_pkcs11-0.6.2-7.el6.i686

Marking the bug verified.
Comment 17 releng-rhel@redhat.com 2010-11-10 15:28:13 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.