Bug 614702 - virt install failed in beaker but can pass in rhts
Summary: virt install failed in beaker but can pass in rhts
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: beah   
(Show other bugs)
Version: 0.5
Hardware: All Linux
medium
medium vote
Target Milestone: ---
Assignee: Marian Csontos
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 593365
TreeView+ depends on / blocked
 
Reported: 2010-07-15 03:32 UTC by yanfu,wang
Modified: 2011-06-13 18:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 18:00:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description yanfu,wang 2010-07-15 03:32:11 UTC
Description of problem:
/distribution/virt/install failed in beaker, but can pass in rhts.

How reproducible:
always

pls refer to below job links:
failed jobs in beaker:
https://beaker.engineering.redhat.com/jobs/7130
https://beaker.engineering.redhat.com/jobs/7007

pass jobs in rhts:
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=166227
http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=166401

  
Actual results:
/distribution/virt/install failed.

Expected results:
/distribution/virt/install should pass.

Additional info:

Comment 1 Bill Peck 2010-07-18 23:48:11 UTC
Marian,

I believe this is due to the change in daemon --user not using a login shell any more. 

Can you change the init scripts to source /etc/profile.d/cobbler.sh yourself?

Comment 2 Bill Peck 2010-07-19 13:06:22 UTC
Marian reports that he has a new version of the harness which uses the login shell.  This should go out in the 0.5.50 release which is scheduled for this Wednesday unless we find a last minute issue.


Note You need to log in before you can comment on or make changes to this bug.