Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 614766 - PAM truncates /var/log/faillog on upgrade
PAM truncates /var/log/faillog on upgrade
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pam (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Tomas Mraz
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 04:03 EDT by Tomas Mraz
Modified: 2015-09-27 22:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: pam-1.1.1-6.el6
Doc Type: Bug Fix
Doc Text:
When the pam packages were updated, the /var/log/tallylog and /var/log/faillog files were overwritten with empty files because of an incorrect condition check in the %post script. This has been corrected, and PAM no longer attempts to overwrite tallylog and faillog files when they exist prior to update.
Story Points: ---
Clone Of: 614765
Environment:
Last Closed: 2011-05-19 10:02:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0685 normal SHIPPED_LIVE pam bug fix and enhancement update 2011-05-18 14:10:29 EDT

  None (edit)
Description Tomas Mraz 2010-07-15 04:03:14 EDT
pam package truncates /var/log/faillog and /var/log/tallylog on upgrade.

The script in %post contains incorrect test whether the files already exist or not making it overwriting the files with a zero length file unconditionally.

There is no reason to make extra errata for this problem but it needs to be fixed in case of future PAM errata including Z-stream erratas.
Comment 4 Laura Bailey 2011-05-06 02:36:26 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When the pam packages were updated, the /var/log/tallylog and 
/var/log/faillog files were overwritten with empty files because of an incorrect condition check in the %post script. This has been corrected, and PAM no longer attempts to create new tallylog and faillog files when they exist prior to update.
Comment 5 Laura Bailey 2011-05-06 02:43:59 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,2 +1 @@
-When the pam packages were updated, the /var/log/tallylog and 
+When the pam packages were updated, the /var/log/tallylog and /var/log/faillog files were overwritten with empty files because of an incorrect condition check in the %post script. This has been corrected, and PAM no longer attempts to overwrite tallylog and faillog files when they exist prior to update.-/var/log/faillog files were overwritten with empty files because of an incorrect condition check in the %post script. This has been corrected, and PAM no longer attempts to create new tallylog and faillog files when they exist prior to update.
Comment 6 errata-xmlrpc 2011-05-19 10:02:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0685.html

Note You need to log in before you can comment on or make changes to this bug.