Bug 614792 - virt-v2v | can't install the driver automatically if the firstboot without iso files available,
virt-v2v | can't install the driver automatically if the firstboot without is...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks: 615977
  Show dependency treegraph
 
Reported: 2010-07-15 05:44 EDT by Mohua Li
Modified: 2013-04-30 19:13 EDT (History)
9 users (show)

See Also:
Fixed In Version: virt-v2v-0.7.1-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 615977 (view as bug list)
Environment:
Last Closed: 2011-08-05 13:39:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohua Li 2010-07-15 05:44:48 EDT
Description of problem:
after import the windows guest to rhevm, boot the vm guest first time without the rhev-tools iso file available, then shutdown the machine, and try the second time with the  rhev-tools iso file available, you could find the rhev-tools is attached to the cdrom,

but won't install the driver anyway, try to install the driver, after reboot, we got BSOD,



Version-Release number of selected component (if applicable):
virt-v2v-0.6.1-1.el5


How reproducible:
always

Steps to Reproduce:
1,import the windows guest to rhev,
2,start the guest without the iso files available,
3,shutdown the guest,
3,upload the iso files to the iso domain, and make sure the iso domain is attach to the relate data domain,
4,boot the guest again,
5,already attach the guest, but won't install,
6,manually install the driver,
7,after reboot, got BSOD 
  
Actual results:
can't install the driver automatically, 

Expected results:
install the driver automatically, and won't get any BSOD

Additional info:
Comment 2 RHEL Product and Program Management 2010-08-09 15:36:27 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 Rita Wu 2011-05-26 03:01:07 EDT
Verified with virt-v2v-0.7.1-4.el5.

The new v2v mechanism will try to install virtio driver via copying drivers into corresponding dir instead of CDUpgrader's help. So this issue has been resolved automatically after mechanism update.
Comment 7 errata-xmlrpc 2011-08-05 13:39:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1125.html

Note You need to log in before you can comment on or make changes to this bug.