Bug 614801 - Graphical anomalies in GL applications in KVM virtual machine
Graphical anomalies in GL applications in KVM virtual machine
Status: CLOSED DUPLICATE of bug 609460
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mesa (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Dave Airlie
desktop-bugs@redhat.com
: Triaged
: 673425 (view as bug list)
Depends On: 609460
Blocks: 599016
  Show dependency treegraph
 
Reported: 2010-07-15 06:02 EDT by Ngo Than
Modified: 2011-08-23 07:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 609460
Environment:
Last Closed: 2011-08-23 07:50:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ngo Than 2010-07-15 06:02:13 EDT
+++ This bug was initially created as a clone of Bug #609460 +++

Description of problem:
There are at least two graphical anomalies under KDE in vritual machine:
1. Image corruption in khtml-related applications such as konqueror, khelpcenter
2. Some images seems to have shifted hue (e.g. the Air wallpaper don't appear blue, but yellow instead).

SEE ATTACHED SCREENSHOT

Version-Release number of selected component (if applicable):
host:
kernel-firmware-2.6.32-37.el6.noarch
kernel-headers-2.6.32-37.el6.x86_64
kernel-2.6.32-37.el6.x86_64
xorg-x11-server-Xorg-1.7.7-17.el6.x86_64
xorg-x11-drv-intel-2.11.0-6.el6.x86_64
libvirt-0.8.1-12.el6.x86_64
qemu-kvm-0.12.1.2-2.90.el6.x86_64
qemu-kvm-tools-0.12.1.2-2.90.el6.x86_64

guest:
kernel-firmware-2.6.32-30.el6.noarch
kernel-2.6.32-30.el6.i686
xorg-x11-server-Xorg-1.7.7-2.el6.i686
xorg-x11-drv-cirrus-1.3.2-1.1.el6.i686


How reproducible:
tried on lenovo thinkpad t400 and hp elitoBook 8440p

Steps to Reproduce:
1. install virt-manager
2. install latest (i386) rhel as a virtual machine with KDE environment
3. start kde session on the virtual machine
4. start konqueror and verify image corruption
5. start both [eog | okular] /usr/share/wallpapers/Air/contents/images/1024x768.jpg and verify different colors (should be blue)
  
Actual results:
see attached screenshot

Expected results:
no image corruption in konqueror, Air wallpaper should appear blue in okular

--- Additional comment from mhasko@redhat.com on 2010-06-30 07:24:12 EDT ---

Created an attachment (id=427954)
graphics anomalities

--- Additional comment from pm-rhel@redhat.com on 2010-06-30 07:43:27 EDT ---

This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

--- Additional comment from airlied@redhat.com on 2010-07-05 18:42:53 EDT ---

if you take a screenshot inside the VM and copy it out and view it somewhere is the corruption still there?

just want to rule out the vnc stuff.

--- Additional comment from mhasko@redhat.com on 2010-07-12 09:32:24 EDT ---

The image corruption is still visible, if the screenshot is copied from the VM, i.e. the background image color is shifted, images are still corrupted.

2 attachments added

--- Additional comment from mhasko@redhat.com on 2010-07-12 09:33:41 EDT ---

Created an attachment (id=431179)
screenshot from guest VM

--- Additional comment from mhasko@redhat.com on 2010-07-12 09:34:21 EDT ---

Created an attachment (id=431180)
screenshot from host machine

--- Additional comment from ajax@redhat.com on 2010-07-12 13:40:38 EDT ---

This is not an X bug.  This is two distinct bugs, probably in QtImage or whatever it's called these days.

In the 1024x768 wallpaper image, the top-left pixel is #06b0fe, but okular is rendering it as #feb006.  No idea _why_ it would be doing that, since the channel masks in qemu's cirrus device are not swizzled relative to a normal desktop, but there you go.

In the konqueror screenshot, RHEL6beta_720x60.jpg is clearly stretched by about 4/3 horizontally.  Since the emulated cirrus device is 24bpp, this is almost certainly a case of the jpeg being expanded to a 32bpp buffer in memory and then uploaded without stripping out the padding channel.

Reassigning to qt.

--- Additional comment from than@redhat.com on 2010-07-14 10:16:37 EDT ---

glxgears has the same problem like in konqueror.

--- Additional comment from pknirsch@redhat.com on 2010-07-14 13:02:00 EDT ---

As we're past Snap8 for packages for RHEL-6 now we require blocker flags for bugs. This bug doesn't qualify as a blocker, so we're moving it to RHEL-6.1 for further review and/or fixing.

Than has found a possibly fix for the color issue from the first screenshot. He wants to double check with Trolltech first though and discuss with them (upstream) whether this is the right fix. We aim to release the final fix for 6.1 then.

As mentioned in the previous comment we believe though that the second problem is actually the same as the glxgears one, at least the visual errors are strikingly similar. We'll clone this bug for that specific issue then and reassign it to Mesa/GL tomorrow.

So we can provide a fixed Qt version, but as it isn't really blocking installations and/or working with installations we're targetting 

Thanks & regards, Phil
Comment 2 RHEL Product and Program Management 2010-07-15 10:59:28 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 RHEL Product and Program Management 2011-01-07 11:01:14 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 4 RHEL Product and Program Management 2011-02-01 01:07:19 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 Ngo Than 2011-02-01 05:36:34 EST
*** Bug 673425 has been marked as a duplicate of this bug. ***
Comment 6 RHEL Product and Program Management 2011-02-01 13:28:38 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 7 RHEL Product and Program Management 2011-04-03 22:35:08 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 8 Ngo Than 2011-08-23 07:50:59 EDT

*** This bug has been marked as a duplicate of bug 609460 ***

Note You need to log in before you can comment on or make changes to this bug.