Bug 61487 - 2.4.18-0.5smp doesn't boot
2.4.18-0.5smp doesn't boot
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-20 10:29 EST by Bernhard Rosenkraenzer
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-20 14:40:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2002-03-20 10:29:18 EST
Description of Problem: 
On a dual Pentium III 700 (Asus P2B-D mainboard), 2.4.18-0.5smp crashes on startup; the 
part of the dump readable without a serial console or turning on framebuffer mode [this 
happens before shift-PgUp starts working] is: 
 
inlock.h:137! 
invalid operand: 0000 
CPU: 0 
EIP: 0010:[<c0155683>] Not tainted 
EFLAGS: 00010282 
EIP is at get_super_Rsmp_5b7ef68b [] 0x403 
eax: 0000005e ebx: 00000000 ecx: c0314f04 edx: 0000074c 
esi: c02d98ea edi: c0155657 ebp: c03194c0 esp: c032ff10 
ds: 0018 es: 0018 ss: 0018 
Process swapper (pid: 0, stackpage=c032f000) 
Stack: c02d97e0 00000089 00000202 c146a000 00000001 c03a9d80 00000000 00000000 
       00000000 00000000 c03194c0 c03194c0 c0155b75 c03194c0 00000000 00000000 
       c02ec244 00000000 d3fee104 c0155d91 c03194c0 00000000 c02ec244 00000000 
Call Trace: [<c0155b75>] get_super_Rsmp_5b7ef68b [] 0x815 
[<c0155d91>] get_super_Rsmp_5b7ef68b [] 0xb11 
[<c0105000>] gdt_Rsmp_455fbf86 [] 0x4d94 
[<c0154584>] register_filesystem_Rsmp_b6229c7f [] 0x64 
[<c0105000>] gdt_Rsmp_455fbf86 [] 0x4d94 
[<c0105000>] gdt_Rsmp_455fbf86 [] 0x4d94 
 
Code: 0f 0b 59 5b f0 fe 0d 84 6d 31 c0 0f 88 b8 0b 00 00 a1 80 6d 
<0>Kernel panic: Attempted to kill the idle task! 
In idle task - nnot syncing 
 
 
Version-Release number of selected component (if applicable): 
kernel-smp-2.4.18-0.5.i686.rpm 
 
How Reproducible: 
100% 
 
Additional Information: 
Windows emulation is good for end users, but emulating even *this* behavior of Windows is 
taking it a step too far ;)
Comment 1 Arjan van de Ven 2002-03-20 10:35:23 EST
What is the last 2.4.18 that did boot ?
Comment 2 Bernhard Rosenkraenzer 2002-03-20 10:39:41 EST
2.4.18-0.4smp works like a charm. 
Comment 3 Arjan van de Ven 2002-03-20 10:53:31 EST
Pete: this looks like it can be "more unnamed majors" related..
Comment 4 Pete Zaitcev 2002-03-20 11:12:28 EST
*OH GAWD, NOOOOO*
Hold on a sec, I'll check it out
Comment 5 Pete Zaitcev 2002-03-20 14:40:05 EST
Take 2.4.18-0.6. Sorry for the breakage and thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.