Bug 614885 - Deprecation of ccs_tool cluster.conf creation/editing capability
Summary: Deprecation of ccs_tool cluster.conf creation/editing capability
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Fabio Massimo Di Nitto
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-15 13:44 UTC by Chris Feist
Modified: 2011-05-19 13:03 UTC (History)
8 users (show)

Fixed In Version: cluster-3.0.12-29.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 13:03:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (5.33 KB, patch)
2011-01-14 09:32 UTC, Fabio Massimo Di Nitto
lhh: review+
Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0537 normal SHIPPED_LIVE cluster and gfs2-utils bug fix update 2011-05-18 17:57:40 UTC

Description Chris Feist 2010-07-15 13:44:10 UTC
Since the capabilities of ccs_tool will be superceded by the new CLI in 6.1, it probably makes sense to deprecate the functionality in ccs_tool 6.1 and beyond to prevent customer confusion.  We won't remove functionality (since it'll be in 6.0, but we may want to include a notice that that functionality is deprecated).

Comment 3 Sayan Saha 2010-09-27 19:21:59 UTC
Document only the ccs_tool capabilities that are not "edit" centric.

Comment 6 Fabio Massimo Di Nitto 2011-01-14 09:32:15 UTC
Created attachment 473486 [details]
proposed patch

Proposed patch to update ccs_tool man page.

the patch is RHEL6 specific, does not fit upstream.

Comment 8 Fabio Massimo Di Nitto 2011-01-19 10:17:31 UTC
The package with the fix has been built. John do you need a clone for this bug to fix/check the official documentation too?

Comment 10 Dean Jansa 2011-04-19 21:10:58 UTC
Man page updated. Verified in cman-3.0.12-41.el6.

Comment 11 errata-xmlrpc 2011-05-19 13:03:47 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0537.html


Note You need to log in before you can comment on or make changes to this bug.