Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 614911 - PyXML causes segfault of Python parsing certain XML files: contains own copy of pyexpat - need compat fix for expat-2.0.1
PyXML causes segfault of Python parsing certain XML files: contains own copy ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: PyXML (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Roman Rakus
Michal Nowak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 10:36 EDT by Dave Malcolm
Modified: 2014-01-12 19:12 EST (History)
7 users (show)

See Also:
Fixed In Version: PyXML-0.8.4-19.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:32:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-07-15 10:36:41 EDT
Description of problem:
PyXML seems to have its own copy of pyexpat.so, and seems to shadow it if it's installed.

It seems to be missing the fix I made for bug 583931 for compatibility with expat-2.0.1 in the main python rpm:
* Mon Jun 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.6.2-10
- Fix an incompatibility between pyexpat and the system expat-2.0.1 that led to
a segfault running test_pyexpat.py (patch 117)

This leads to a segfault when parsing certain XML files; running test_pyexpat.py will show it up.

Version-Release number of selected component (if applicable):
python-2.6.5-2.el6.x86_64
python-test-2.6.5-2.el6.x86_64
PyXML-0.8.4-18.el6.x86_64
expat-2.0.1-9.1.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. python /usr/lib*/python2.6/test/test_pyexpat.py with PyXML installed

Actual results:
test_ordered_attributes (__main__.SetAttributeTest) ... ok
...(snip)...
test_parse_only_xml_data (__main__.sf1296433Test) ... Segmentation fault (core dumped)

Expected results:
All tests should pass; no segfault

Additional info:
Shouldn't we consolidate on having a single copy of pyexpat.so?
Comment 5 Roman Rakus 2010-07-19 13:41:41 EDT
(In reply to comment #0)
> Description of problem:
> PyXML seems to have its own copy of pyexpat.so, and seems to shadow it if it's
> installed.
True
> 
> It seems to be missing the fix I made for bug 583931 for compatibility with
> expat-2.0.1 in the main python rpm:
> * Mon Jun 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.6.2-10
> - Fix an incompatibility between pyexpat and the system expat-2.0.1 that led to
> a segfault running test_pyexpat.py (patch 117)
> 
> This leads to a segfault when parsing certain XML files; running
> test_pyexpat.py will show it up.
> 
True
> Version-Release number of selected component (if applicable):
> python-2.6.5-2.el6.x86_64
> python-test-2.6.5-2.el6.x86_64
> PyXML-0.8.4-18.el6.x86_64
> expat-2.0.1-9.1.el6.x86_64
> 
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. python /usr/lib*/python2.6/test/test_pyexpat.py with PyXML installed
> 
> Actual results:
> test_ordered_attributes (__main__.SetAttributeTest) ... ok
> ...(snip)...
> test_parse_only_xml_data (__main__.sf1296433Test) ... Segmentation fault (core
> dumped)
> 
> Expected results:
> All tests should pass; no segfault
> 
> Additional info:
> Shouldn't we consolidate on having a single copy of pyexpat.so?    
Yep. Since the python itself has pyexpat (using lib expat) it is nonsense to have PyXML at all.
Comment 6 Roman Rakus 2010-07-19 13:48:24 EDT
Correcting my words:
Since the python itself has pyexpat (using lib expat) it is nonsense to
have it in PyXML at all.
In other words, I will get a rid of pyexapt.so from PyXML
Comment 9 Roman Rakus 2010-07-20 08:40:46 EDT
Ready to commit. Awaiting all ack+s
Comment 10 Roman Rakus 2010-07-21 09:28:34 EDT
Fixed in PyXML-0.8.4-19.el6
Comment 15 releng-rhel@redhat.com 2010-11-10 14:32:36 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.