Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 614920 - Missing libudev-devel version in BuildRequires
Missing libudev-devel version in BuildRequires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 10:50 EDT by Petr Lautrbach
Modified: 2010-07-27 07:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: systemd-4-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 07:50:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Lautrbach 2010-07-15 10:50:05 EDT
Description of problem:
There is missing needed version of libudev-devel in systemd.spec file:

BuildRequires:  libudev-devel

Version-Release number of selected component (if applicable):
systemd-3-3.fc14

Steps to Reproduce:
$ rpm -q libudev-devel
libudev-devel-147-2.21.el6.x86_64

$ rpmbuild --rebuild systemd-3-3.fc14.src.rpm
no complaints about prerequisites
...
checking pkg-config is at least version 0.9.0... yes
checking for UDEV... configure: error: Package requirements ( libudev >= 160 ) were not met:

Requested 'libudev >= 160' but version of libudev is 147
Comment 1 Michal Schmidt 2010-07-27 07:50:45 EDT
systemd-4-3 has:
BuildRequires:  libudev-devel >= 160

Note You need to log in before you can comment on or make changes to this bug.