This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 61495 - up2date crashes with python segmentation fault
up2date crashes with python segmentation fault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-20 12:57 EST by unionave
Modified: 2015-01-07 18:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 00:03:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description unionave 2002-03-20 12:57:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.8) Gecko/20020206

Description of problem:
Launching up2date causes a crash with an error message that says, "Application
python has crashed due to a fatal error (sementation fault)" My system is full
updated and I'm able to use up2date if I run it from a command line with the
--nox option. It's the GUI version that doesn't work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Launch up2date
2.
3.
	

Additional info:
Comment 1 Adrian Likins 2002-03-20 14:08:37 EST
can you send me the output of:

rpm -qa | grep python 

and 

rpm -qa | grep gtk

Do other python-gtk apps work (say, printconf?)

Also, what versions of Red Hat Linux and up2date?
Comment 2 unionave 2002-03-20 18:09:03 EST
Thank you for your prompt reply. I'm running Red hat 6.2 and my up2date file is
version 2.7.46-6.x.1. As far as printconf is concerned, I don't seem to have
that installed on my machine. I have attached the outputs of the commands you
requested. I hope this helps:

python-xmlrpc-1.5.1-6.x.7
pythonlib-1.23-1
rpm-python-4.0.2-6x
python-popt-0.6-1
python-1.5.2-27.6.x

rep-gtk-libglade-0.15-ximian.4
gtk+10-1.0.6-6
libgtkhtml19-0.16.1-ximian.1
gtk+-1.2.10-ximian.21
gtk-engines-thinice-1.0.4-ximian.1
gtkhtml-1.0.1-ximian.1
pygtk-0.6.9-1.ximian.2
gtk+-devel-1.2.10-ximian.21
rep-gtk-0.15-ximian.4
libgtkhtml20-1.0.1-ximian.1
gtk-themes-0.1-ximian.2
pygtk-libglade-0.6.9-1.ximian.2
gtk-engines-0.12-ximian.1
libgtkhtml18-0.15.0-ximian.2
rep-gtk-gnome-0.15-ximian.4
Comment 3 Adrian Likins 2002-03-20 18:14:46 EST
Well, my first impulse is to question the ximian packages.

Segfaults in python are almost always the results of a segfault
in one of the C libraries that have been linked in. 

Since it seems like the segfaults only happen with the gui
version, my first suspect would have to be the gtk and pygtk
libraries. 

In the past, some versions of the ximian pygtk packages have been
know to cause segfaults in the manner you described, but I
was under the impression those bugs have been fixed for a while.
Is this a set of old ximian packages? 

My money would be on some sort of bug in the ximian packages
(or a weird interaction with our packages) that is causing the
segfault.
Comment 4 unionave 2002-03-20 18:30:05 EST
   I'm not suprised, in a way, because this problem started occurring after a
recent set of updates were downloaded from Ximian, INCLUDING the pygtk packages.
I wrote to them first about the problem but they never responded. That's when I
thought I'd see if Red Hat had any thoughts on the subject. Should I try
replacing any files?
Comment 5 Adrian Likins 2002-03-20 18:41:03 EST
My approache would be to reinstall the original  Red Hat Linux packages.
I know they work ;->

You may need to remove the ximian packages first, if they are
newer than the Red Hat ones.
Comment 6 unionave 2002-03-21 00:03:30 EST
I took your advice and solved the problem by replacing the Ximian versions of
pygtk and pygtk-libglade with the Red Hat versions. The up2date feature now
works as it should. Thank you for your help.
Comment 7 Josef Komenda 2002-03-21 12:03:09 EST
Fixed, closing.

Note You need to log in before you can comment on or make changes to this bug.