Bug 61501 - PERL: op/cmp and lib/bigfltpm tests failed
PERL: op/cmp and lib/bigfltpm tests failed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-20 14:25 EST by Christopher Holmes
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-22 17:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Holmes 2002-03-20 14:25:10 EST
Description of Problem:

PERL: op/cmp and lib/bigfltpm tests failed

Version-Release number of selected component (if applicable):

perl-5.6.0-17.src.rpm

How Reproducible:

Always

Steps to Reproduce:

1. rpm -i  perl-5.6.0-17.src.rpm 
2. cd /usr/src/redhat/SPECS
3. rpm -ba  perl.spec
4. cd  /usr/src/redhat/BUILD/perl-5.6.0
5. rm -f config.sh Policy.sh
6. sh Configure -de 
7.  make
8. make test

Actual Results:

op/cmp...............FAILED at test 0
lib/bigfltpm.........FAILED at test 351

Expected Results:

op/cmp...............ok
lib/bigfltpm.........ok

Additional Information:
	
expected results achieved on intel RedHat7.2
Comment 1 Chip Turner 2002-03-20 21:48:23 EST
Perl 5.6.1 is the latest version available for Red Hat 7.2; have you tested it
to see if it demonstrates the same flaws?  It should pass all tests on i386.
Comment 2 Christopher Holmes 2002-03-21 11:43:07 EST
I tested perl-5.6.1. You are correct, it passed all the tests (252) on Intel. 

On Alpha, I see the following 3 failures. 

lib/bigfltpm.........FAILED at test 351
lib/complex..........FAILED at test 0
lib/trig.............FAILED at test 0

Failed 3 test scripts out of 250, 98.80% okay.

more detailed test:
=================

scrib/bigfltpm........dubious                                                  
	Test returned status 0 (wstat 8, 0x8)
DIED. FAILED tests 351-370
	Failed 20/370 tests, 94.59% okay

lib/complex.........dubious                                                  
	Test returned status 0 (wstat 8, 0x8)


lib/trig............dubious                                                  
	Test returned status 0 (wstat 8, 0x8)

Failed Test    Status Wstat Total Fail  Failed  List of Failed
---------------------------------------------
lib/bigfltpm.t	   0     8   370   20   5.41%  351-370
lib/complex.t 	   0     8    ??   ??       %  ??
lib/trig.t    	   0     8    ??   ??       %  ??
7 tests and 85 subtests skipped.
Failed 3/258 test scripts, 98.84% okay. 20/10168 subtests failed, 99.80%
okay.



Also, running the test individually:

./perl lib/bigfltpm.t
1..370
ok 1
ok 2
.
.
ok 349
ok 350
Floating point exception

./perl lib/complex.t  
Floating point exception

./perl lib/trig.t 
Floating point exception
Comment 3 Phil Copeland 2002-04-22 00:58:33 EDT
Hands up all those that need an alpha to test this on... (hint) the deadline is
This Thursday....


Phil
=--=
Comment 4 Chip Turner 2002-04-22 03:34:07 EDT
I don't think the error is huge, but I would like to check on it.  Please direct
me to a machine and username/pw to log in and run the tests manually and I'll
poke it to see what's wrong.
Comment 5 Chip Turner 2002-04-25 17:10:57 EDT
When rebuilding perl-5.6.1-26.72.3.src.rpm, I have all tests pass on the alpha
machine I am testing on.  Is this the same perl you are building?  Specifically:

lib/bigfloat.........ok
lib/complex..........ok
lib/trig.............ok

The test machine I have identifies itself as:
cpu                     : Alpha
cpu model               : EV6
cpu variation           : 7
cpu revision            : 0
cpu serial number       : 
system type             : Tsunami
system variation        : Webbrick
system revision         : 0
system serial number    : NI93814294
cycle frequency [Hz]    : 462962962 
timer frequency [Hz]    : 1024.00
page size [bytes]       : 8192
phys. address bits      : 44
max. addr. space #      : 255
BogoMIPS                : 921.84
kernel unaligned acc    : 0 (pc=0,va=0)
user unaligned acc      : 0 (pc=0,va=0)
platform string         : COMPAQ AlphaServer DS10 466 MHz
cpus detected           : 1
Comment 6 Phil Copeland 2002-04-29 11:59:45 EDT
Chip, did you just rebuild perl in the 7.2-alpha tree?

[copeland@porkchop copeland]$ latest-pkg dist-7.2-alpha perl
/mnt/redhat/beehive/comps/dist/7.2-ent/perl/5.6.1-26.72.4/SRPMS/perl-5.6.1-26.72.4.src.rpm

Cheers

Phil
=--=
Comment 7 Chip Turner 2002-04-29 13:08:46 EDT
Yes.  Works on this test machine.

[root@dhcp59-234 root]# rpm --rebuild perl-5.6.1-26.72.4.src.rpm 
...
lib/bigfloat.........ok
lib/complex..........ok
lib/trig.............ok
...
Comment 8 Christopher Holmes 2002-05-14 13:43:43 EDT
This bug can be CLOSED.
Verified perl-5.6.1-26.72.3.src.rpm on RH 7.2 (0507 kit) and all tests were 
successful. 

Thanks!

It was tested on ev67 and ev6:

cpu			: Alpha
cpu model		: EV67
cpu variation		: 7
cpu revision		: 0
cpu serial number	: 
system type		: Tsunami
system variation	: Monet
system revision		: 0
system serial number	: 4030DRSZ1008
cycle frequency [Hz]	: 666666666 
timer frequency [Hz]	: 1024.00
page size [bytes]	: 8192
phys. address bits	: 44
max. addr. space #	: 255
BogoMIPS		: 1326.92
kernel unaligned acc	: 0 (pc=0,va=0)
user unaligned acc	: 0 (pc=0,va=0)
platform string		: COMPAQ Professional Workstation XP1000
cpus detected		: 1

AND

cpu			: Alpha
cpu model		: EV6
cpu variation		: 7
cpu revision		: 0
cpu serial number	: 
system type		: Tsunami
system variation	: Webbrick
system revision		: 0
system serial number	: 4032DQMZ1068
cycle frequency [Hz]	: 462353668 est.
timer frequency [Hz]	: 1024.00
page size [bytes]	: 8192
phys. address bits	: 44
max. addr. space #	: 255
BogoMIPS		: 921.84
kernel unaligned acc	: 0 (pc=0,va=0)
user unaligned acc	: 0 (pc=0,va=0)
platform string		: COMPAQ AlphaServer DS10 466 MHz
cpus detected		: 1
Comment 9 Christopher Holmes 2002-05-22 17:45:10 EDT
I tried perl-5.6.1-26.72.3.src.rpm based on RH 7.2 - 0520.0 kit on COMPAQ 
AlphaServer DS10 466 MHz and looks like there are 5 discrepancies compared to 
the previous kit (0507). 

lib/bigfltpm.........FAILED at test 351
lib/complex..........FAILED at test 0
lib/gdbm.............skipping test on this platform
lib/ndbm.............skipping test on this platform
lib/trig.............FAILED at test 0

Failed 3 test scripts out of 252, 98.81% okay.
   ### Since not all tests were successful, you may want to run some
   ### of them individually and examine any diagnostic messages they
   ### produce.  See the INSTALL document's section on "make test".
   ### If you are testing the compiler, then ignore this message 
   ### and run 
   ###      ./perl harness
   ### in the directory ./t.
   ###
   ### Since most tests were successful, you have a good chance to
   ### get information with better granularity by running
   ###     ./perl harness 
   ### in directory ./t.
u=0.629883  s=0.200195  cu=42.9463  cs=8.19043  scripts=252  tests=10505
make: *** [test] Error 1

NOTE:
-----
With 0507 kit: 

All tests successful.
u=0.666992  s=0.217773  cu=44.835  cs=8.16602  scripts=256  tests=11681
Comment 10 Christopher Holmes 2002-05-22 17:50:55 EDT
Forgot to mention that I also tried 0520.0 kit on the following machine and 
only 2 tests fail. The failures are different thought! 

cpu			: Alpha
cpu model		: EV67
cpu variation		: 7
cpu revision		: 0
cpu serial number	: 
system type		: Tsunami
system variation	: Webbrick
system revision		: 0
system serial number	: AY03114092
cycle frequency [Hz]	: 549450549 
timer frequency [Hz]	: 1024.00
page size [bytes]	: 8192
phys. address bits	: 44
max. addr. space #	: 255
BogoMIPS		: 1095.32
kernel unaligned acc	: 0 (pc=0,va=0)
user unaligned acc	: 0 (pc=0,va=0)
platform string		: COMPAQ AlphaServer DS10 550 MHz
cpus detected		: 1

lib/anydbm............/perl: relocation 
error: ../lib/auto/NDBM_File/NDBM_File.so: undefined symbol: dbm_open
FAILED at test 0

lib/ndbm............../perl: relocation 
error: ../lib/auto/NDBM_File/NDBM_File.so: undefined symbol: dbm_open
FAILED at test 0

Failed 2 test scripts out of 254, 99.21% okay.
Comment 11 Phil Copeland 2002-05-24 14:14:04 EDT
BUZZZT!
drop steps 5,6,7... ie go directly from step 4 to step 8 (in the first record in
this bug report)

perl is fine.(tested CS20 7.2 everything install)

Closed

Phil
=--=
Comment 12 Christopher Holmes 2002-05-24 17:57:02 EDT
My appologies...

I had SERVER only configuration installed! 
(the test indeed fails in this case regardless of skipping steps [5 to 7])

It does pass on EVERYTHING installed configuration. 

rgds,
KT

Note You need to log in before you can comment on or make changes to this bug.