Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 615086 - gdm greeter - Other... prompts for smartcard PIN
gdm greeter - Other... prompts for smartcard PIN
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
: Regression
: 616767 616791 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 17:34 EDT by Chandrasekar Kannan
Modified: 2015-01-04 18:43 EST (History)
7 users (show)

See Also:
Fixed In Version: gdm-2.30.4-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:28:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (494.93 KB, image/png)
2010-07-15 17:34 EDT, Chandrasekar Kannan
no flags Details

  None (edit)
Description Chandrasekar Kannan 2010-07-15 17:34:52 EDT
Created attachment 432235 [details]
screenshot

Description of problem:

- enable smartcard logon. 
- Have an enrolled smartcard plugged in
- logout
- gdm will automatically select smartcard authentication and ask for PIN
- hit cancel
- select Other in hopes to login as 'root' for example...
- selecting Other still asks for SmartCard PIN.
- See attached screenshot.

Version-Release number of selected component (if applicable):
esc-1.1.0-21.el6.i686
ccid-1.3.9-3.el6.i686
pcsc-lite-1.5.2-5.el6.i686
pcsc-lite-libs-1.5.2-5.el6.i686
coolkey-1.1.0-14.el6.i686
gdm-2.30.4-8.el6.i686
gnome-screensaver-2.28.3-6.el6.i686
gnome-settings-daemon-2.28.2-6.el6.i686


How reproducible:

- always

Steps to Reproduce:
1. see description
2.
3.
  
Actual results:
- see description

Expected results:
- selecting other should always ASK for a username and definitely not the smartcard pin.

Additional info:
Comment 1 Ray Strode [halfline] 2010-07-16 17:04:45 EDT
I guess we really want Other to be password only, not fingerprint or smartcard.  That was a thinko on my part.
Comment 2 Ray Strode [halfline] 2010-07-28 17:27:13 EDT
*** Bug 616767 has been marked as a duplicate of this bug. ***
Comment 3 Ray Strode [halfline] 2010-08-06 00:53:51 EDT
I have some local fixes for this bug.  I'll commit them tomorrow after I've done some smoke testing.
Comment 4 Ray Strode [halfline] 2010-08-06 14:27:23 EDT
This should be all set now.
Comment 5 Ray Strode [halfline] 2010-08-06 14:31:53 EDT
*** Bug 616791 has been marked as a duplicate of this bug. ***
Comment 7 Vladimir Benes 2010-08-16 07:58:40 EDT
it works well now, Other is password only, Smartcard has no username prompt and you can use all types of auth via user name
-> VERIFIED
Comment 8 releng-rhel@redhat.com 2010-11-10 15:28:14 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.