Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 615096 - Traceback when unchecking "Prioritized" in Failover Domains
Traceback when unchecking "Prioritized" in Failover Domains
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-15 18:42 EDT by Chris Feist
Modified: 2010-11-10 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: luci-0.22.2-9.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 17:11:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Feist 2010-07-15 18:42:19 EDT
Description of problem:
In a failover domain if you set the checkbox "No Failback" and no other checkboxes and then hit "Update Properties" you get a traceback:

AttributeError: FailoverDomain instance has no attribute 'clear_member_nodeis'
Comment 1 Chris Feist 2010-07-15 18:45:05 EDT
Looks like this happens if you set "Prioritized" hit "Update Properties" and the try to unset "Prioritized" and hit "Update Priorities".
Comment 2 Chris Feist 2010-07-16 15:58:41 EDT
Looks like a mis-spelled variable causes this traceback.  Fixed in 3614120e4b3d0b326404ce141a84a1223312e6f4
Comment 3 Fabio Massimo Di Nitto 2010-07-22 04:47:30 EDT
tested a bunch of combinations with No Failback , Prioritized on/off and it seems to working just fine.
Comment 6 releng-rhel@redhat.com 2010-11-10 17:11:54 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.