Bug 61510 - anaconda backtrace/related to grub.conf?
Summary: anaconda backtrace/related to grub.conf?
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-20 21:26 UTC by Jón Fairbairn
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-10 23:42:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
floppy dump from anaconda with backtrace (566.25 KB, text/plain)
2002-03-20 21:30 UTC, Jón Fairbairn
no flags Details
A rough guess at what /boot/grub/grub.conf might have looked like (256 bytes, text/plain)
2002-03-20 23:16 UTC, Jón Fairbairn
no flags Details

Description Jón Fairbairn 2002-03-20 21:26:54 UTC
Description of Problem:
backtrace after installing packages over nfs during upgrade of laptop
(hp omnibook 800CT) from rh6.2 to 7.2

Version-Release number of selected component (if applicable):
busybox-anaconda-0.51.062801-3.i386.rpm
anaconda-runtime-7.2-7.i386.rpm
anaconda-7.2-7.i386.rpm


How Reproducible:
I'm not going to try. I'd have to reinstall rh6.2 and wouldn't be sure that that
would be the same installation

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
	Intend to attach backtrace.

Comment 1 Jón Fairbairn 2002-03-20 21:30:47 UTC
Created attachment 49266 [details]
floppy dump from anaconda with backtrace

Comment 2 Jeremy Katz 2002-03-20 22:37:04 UTC
Did you have an /etc/grub.conf prior to the upgrade?

Comment 3 Jón Fairbairn 2002-03-20 22:53:58 UTC
No, sorry. The system was, and is, booted using lilo. If there really was one
there at all it got there by accident from an automated script that installed it
when I wasn't looking. (The machine is mostly maintained remotely, but I had to
do the upgrade locally). What would have happened is that a script would have
been run to generate the file. I'll attach a typical grub.conf generated by the
script, but can't guarantee that it looks much like what was there before.

The current /etc/grub.conf is symlinked to /boot/grub/grub.conf, and that dates
from the time of the upgrade.


Comment 4 Jón Fairbairn 2002-03-20 23:16:01 UTC
Created attachment 49305 [details]
A rough guess at what /boot/grub/grub.conf might have looked like

Comment 5 Jeremy Katz 2002-04-10 21:30:35 UTC
It looks like there was an /etc/grub.conf that wasn't readable but existed (like
a symlink to something non-existent or an absolute symlink).  I've made some
changes so that this won't cause the installer to crash for future releases.

Comment 6 Jón Fairbairn 2002-04-10 22:51:41 UTC
Yes, the link is absolute, so that probably was the cause.

Comment 7 Mike McLean 2003-01-10 23:42:36 UTC
The symlinks checks have been around for a while, closing.


Note You need to log in before you can comment on or make changes to this bug.