Bug 615140 - Upgrading EC2 Enhanced
Upgrading EC2 Enhanced
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Release_Notes (Show other bugs)
Development
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: Lana Brindley
ecs-bugs
:
: 617233 (view as bug list)
Depends On:
Blocks: 548214
  Show dependency treegraph
 
Reported: 2010-07-15 22:23 EDT by Robert Rati
Modified: 2013-10-23 19:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The EC2 Enhanced AMIs have been upgraded Consequence: Configuration changes are required for the feature to work properly. Fix: MRG Grid's configuration on the AMI needs to have the following parameters added: EC2E_DAEMON_LOG = $(LOG)/CaroniaLog MAX_EC2E_DAEMON_LOG = 1000000 JOB_HOOKS_LOG = $(LOG)/JobHooksLog MAX_JOB_HOOKS_LOG = 10000000 And: EC2E_DAEMON = /usr/sbin/caroniad EC2ENHANCED_HOOK_PREPARE_JOB = $(LIBEXEC)/hooks/hook_prepare_job.py EC2ENHANCED_HOOK_UPDATE_JOB_INFO = $(LIBEXEC)/hooks/hook_update_job_status.py EC2ENHANCED_HOOK_JOB_EXIT = $(LIBEXEC)/hooks/hook_job_exit.py Needs to be changed to: EC2E_DAEMON = $(SBIN)/caroniad EC2ENHANCED_JOB_HOOK_PREPARE_JOB = $(LIBEXEC)/hooks/hook_prepare_job.py EC2ENHANCED_JOB_HOOK_UPDATE_JOB_INFO = $(LIBEXEC)/hooks/hook_update_job_status.py EC2ENHANCED_JOB_HOOK_JOB_EXIT = $(LIBEXEC)/hooks/hook_job_exit.py Result: MRG Grid EC2 Enhanced will work as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-14 16:42:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2010-07-15 22:23:28 EDT
Description of problem:
After upgrading the EC2 Enhanced AMIs, a minor configuration change is required for the feature to work properly.  MRG Grid's configuration on the AMI needs to have the following parameters added:
EC2E_DAEMON_LOG = $(LOG)/CaroniaLog
MAX_EC2E_DAEMON_LOG = 1000000
JOB_HOOKS_LOG = $(LOG)/JobHooksLog
MAX_JOB_HOOKS_LOG = 10000000


And:
EC2E_DAEMON = /usr/sbin/caroniad
EC2ENHANCED_HOOK_PREPARE_JOB = $(LIBEXEC)/hooks/hook_prepare_job.py
EC2ENHANCED_HOOK_UPDATE_JOB_INFO = $(LIBEXEC)/hooks/hook_update_job_status.py
EC2ENHANCED_HOOK_JOB_EXIT = $(LIBEXEC)/hooks/hook_job_exit.py

Needs to be changed to:
EC2E_DAEMON = $(SBIN)/caroniad
EC2ENHANCED_JOB_HOOK_PREPARE_JOB = $(LIBEXEC)/hooks/hook_prepare_job.py
EC2ENHANCED_JOB_HOOK_UPDATE_JOB_INFO = $(LIBEXEC)/hooks/hook_update_job_status.py
EC2ENHANCED_JOB_HOOK_JOB_EXIT = $(LIBEXEC)/hooks/hook_job_exit.py


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lana Brindley 2010-09-16 23:59:41 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: The EC2 Enhanced AMIs have been upgraded
Consequence: Configuration changes are required for the feature to work properly.
Fix: MRG Grid's configuration on the AMI needs to
have the following parameters added:
EC2E_DAEMON_LOG = $(LOG)/CaroniaLog
MAX_EC2E_DAEMON_LOG = 1000000
JOB_HOOKS_LOG = $(LOG)/JobHooksLog
MAX_JOB_HOOKS_LOG = 10000000

And:
EC2E_DAEMON = /usr/sbin/caroniad
EC2ENHANCED_HOOK_PREPARE_JOB = $(LIBEXEC)/hooks/hook_prepare_job.py
EC2ENHANCED_HOOK_UPDATE_JOB_INFO = $(LIBEXEC)/hooks/hook_update_job_status.py
EC2ENHANCED_HOOK_JOB_EXIT = $(LIBEXEC)/hooks/hook_job_exit.py

Needs to be changed to:
EC2E_DAEMON = $(SBIN)/caroniad
EC2ENHANCED_JOB_HOOK_PREPARE_JOB = $(LIBEXEC)/hooks/hook_prepare_job.py
EC2ENHANCED_JOB_HOOK_UPDATE_JOB_INFO =
$(LIBEXEC)/hooks/hook_update_job_status.py
EC2ENHANCED_JOB_HOOK_JOB_EXIT = $(LIBEXEC)/hooks/hook_job_exit.py

Result: MRG Grid EC2 Enhanced will work as expected.
Comment 2 Lana Brindley 2010-09-20 17:59:52 EDT
*** Bug 617233 has been marked as a duplicate of this bug. ***
Comment 3 Lana Brindley 2010-09-22 23:58:45 EDT
Revision 0.1 of the release notes will available for review on the stage shortly.

LKB
Comment 4 Lana Brindley 2010-10-14 16:42:17 EDT
Release Notes have now  been published:
http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_MRG/1.3/html/MRG_Release_Notes/index.html

LKB

Note You need to log in before you can comment on or make changes to this bug.