Bug 61525 - missing dependency to openssl lib in package
missing dependency to openssl lib in package
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-20 17:37 EST by Vadim Zaliva
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 05:33:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Zaliva 2002-03-20 17:37:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020212

Description of problem:
Currently ucd-snmp-devel package does not depend from openssl-devel
package. You can remove openssl-devel w/o warning. 
However if you do remove openssl-devel package, ucd-snmp-devel package
become unusable, since it depends on openssl libraries.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. remove openssl-devel package
2. try to compile program using ucd-snmp libraries

	

Actual Results:  compilation fails


Expected Results:  should compile OK


Additional info:

Obvious fix is put dependency in ucd-snmp SPEC file to
openssl-devel package.
Comment 1 Phil Knirsch 2002-03-26 05:33:49 EST
Easy, will fix.

Read ya, Phil
Comment 2 Phil Knirsch 2002-04-05 06:48:11 EST
Fixed in rawhide (ucd-snmp-4.2.4.pre3-2)

Read ya Phil

Note You need to log in before you can comment on or make changes to this bug.