Bug 61531 - evolution leaving many processes around.
evolution leaving many processes around.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-20 18:00 EST by Stephen John Smoogen
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 22:27:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2002-03-20 18:00:39 EST
Description of Problem:

After running evolution around for the day and a half, I found that a lot of
evolution-address processes are sitting around in the table even after I have
exited evolution.

A ps -auxww showed 

smoogen:{smoogen}$ ps auxww | grep evol | grep address
smoogen   4195  0.0  1.2 14912 6636 ?        S    08:27   0:00
evolution-addressbook
--oaf-activate-iid=OAFIID:GNOME_Evolution_Addressbook_SelectNamesFactory
--oaf-ior-fd=18
smoogen   4223  0.0  1.2 14912 6636 ?        S    08:27   0:00
evolution-addressbook
--oaf-activate-iid=OAFIID:GNOME_Evolution_Addressbook_SelectNamesFactory
--oaf-ior-fd=26
smoogen   4335  0.0  1.2 14912 6636 ?        S    08:53   0:00
evolution-addressbook
--oaf-activate-iid=OAFIID:GNOME_Evolution_Addressbook_SelectNamesFactory
--oaf-ior-fd=24
smoogen   4442  0.0  1.2 14912 6636 ?        S    09:00   0:00
evolution-addressbook
--oaf-activate-iid=OAFIID:GNOME_Evolution_Addressbook_SelectNamesFactory
--oaf-ior-fd=30
smoogen   4960  0.0  1.2 14912 6636 ?        S    11:03   0:00
evolution-addressbook
--oaf-activate-iid=OAFIID:GNOME_Evolution_Addressbook_SelectNamesFactory
--oaf-ior-fd=33
smoogen   4990  0.0  1.4 15316 7284 ?        S    11:03   0:00
evolution-addressbook
--oaf-activate-iid=OAFIID:GNOME_Evolution_Addressbook_SelectNamesFactory
--oaf-ior-fd=32
<About 40 others sitting around also>

Attaching to them via gdb they are all 'polling'

(gdb) where
#0  0x40bddf27 in poll () from /lib/libc.so.6
#1  0x40aea1a1 in g_main_poll () from /usr/lib/libglib-1.2.so.0
#2  0x40ae9b23 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#3  0x40ae9eec in g_main_run () from /usr/lib/libglib-1.2.so.0
#4  0x408a0333 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#5  0x401d203c in bonobo_main () from /usr/lib/libbonobo.so.2
#6  0x0805d5c3 in main ()
#7  0x40b13189 in __libc_start_main () from /lib/libc.so.6

This is a stock 'Red Hat Linux 7.2.91 box'
Comment 1 Jeremy Katz 2002-03-20 18:25:05 EST
You've got to be hitting some sort of bonobo bug here if you're seeing this and
also the gtkhtml editor being unable to pop up (bug #61489) at all often.

Alex, Havoc -- heard of anything else like this?  I don't remember anything like
this from the evolution lists, not that that is at all conclusive.
Comment 2 Alexander Larsson 2002-03-20 18:28:15 EST
Isn't evolution-addressbook supposed to be a singleton object?

This looks like a bug/race in oaf.
Comment 3 Jeremy Katz 2002-03-20 18:52:12 EST
Yeah, you're right; thinking about other things this afternoon.   It also makes
sense as one of the changes in oaf 0.6.8 supposedly fixes a multiple activation
race which would be exactly what's being seen here.

Smooge - can you try installing the updated oaf packages from
http://people.redhat.com/~katzj/RPMS/ and see if it helps at all?
Comment 4 Stephen John Smoogen 2002-03-20 19:45:39 EST
Have downloaded and updated to oaf. I will see if that 'fixes' the problem and
will report in tomorrow.
Comment 5 Stephen John Smoogen 2002-03-20 20:24:36 EST
A quick update. I upgraded oaf package and logged out of X completely. I killed
the 'evolution-addressbook' applications via a 'kill -HUP' and waited 30
seconds. The only remaining application running was a gconfd-1 that had been
running since 08:00 this morning. It exited when I tried to attach a gdb to it?!?

Will tell more in the morning after using evolution for a while.
Comment 6 Jay Turner 2002-03-21 08:00:52 EST
Smooge, what's the state of things now?  Thanks!
Comment 7 Stephen John Smoogen 2002-03-21 11:35:27 EST
Hi guys.. I am 2 hours off the east coast :).. so sorry for the delay.

Both problems are still occuring. [You may want to combine the 2 evolution bugs
if they are caused by the same thing.]

Problem 1) HTML editor has changed slightly to just saying:

Unknown error 

I then wait 20 seconds and it most of the time recovers.

Problem 2)

After exiting evolution with 30 minutes of usage (and answering 3 emails)..
there was one 'turd' process hanging around.

smoogen   8258  0.4  1.3 15208 6984 ?        S    09:27   0:00
evolution-addressbook
--oaf-activate-iid=OAFIID:GNOME_Evolution_Addressbook_SelectNamesFactory
--oaf-ior-fd=26

Checking for anything that mentions oaf

smoogen:{smoogen}$ ps uaxww | grep oaf
smoogen   6489  0.0  1.2 16200 6360 ?        S    Mar20   0:00 wombat
--oaf-activate-iid=OAFIID:Bonobo_Moniker_wombat_Factory --oaf-ior-fd=10
smoogen   6493  0.0  0.7  8628 3904 ?        S    Mar20   0:00
bonobo-moniker-xmldb --oaf-activate-iid=OAFIID:Bonobo_Moniker_xmldb_Factory
--oaf-ior-fd=12
smoogen   6511  0.0  1.0 12936 5424 ?        S    Mar20   0:00
evolution-alarm-notify
--oaf-activate-iid=OAFIID:GNOME_Evolution_Calendar_AlarmNotify_Factory
--oaf-ior-fd=17
smoogen   8238  0.1  0.4  3704 2280 ?        S    09:26   0:00 oafd
--ac-activate --ior-output-fd=38
smoogen   8250  0.0  1.1 15500 5852 ?        S    09:27   0:00 wombat
--oaf-activate-iid=OAFIID:Bonobo_Moniker_wombat_Factory --oaf-ior-fd=14
smoogen   8254  0.0  0.7  8628 3904 ?        S    09:27   0:00
bonobo-moniker-xmldb --oaf-activate-iid=OAFIID:Bonobo_Moniker_xmldb_Factory
--oaf-ior-fd=24
smoogen   8258  0.1  1.3 15208 6984 ?        S    09:27   0:00
evolution-addressbook
--oaf-activate-iid=OAFIID:GNOME_Evolution_Addressbook_SelectNamesFactory
--oaf-ior-fd=26

I am going to upgrade to skipjack in a short while to see if this helps the
problem any.
Comment 8 Stephen John Smoogen 2002-03-25 12:54:59 EST
Ok I have installed Beta3 and I am still seeing 'extra' processes from the
mail-widget while evolution is running. It would seem that after pressing the
'send' the mail-client doesnt exit etc.

The change is that upon exiting evolution all the processes now exit with it
versus sitting around in limbo. I will try to attach to one of these 'fewmet'
processes and see where it is waiting.
Comment 9 Jeremy Katz 2002-06-04 00:15:23 EDT
I still have yet to see this at all on any of my machines... have you managed to
get more information?
Comment 10 Stephen John Smoogen 2002-06-04 08:49:26 EDT
I am going to create a new user and see if it is some sort of configuration that
got carried on from my first install of evolution. It hadnt become the big
problem it was earlier.. so I just considered it an annoyance.
Comment 11 Stephen John Smoogen 2002-06-04 22:26:57 EDT
Please close. Problem seems to have been fixed in final beta. I only have 4
evolution-mail processes running after a complete day of twiddling bits.. which
is good.
Comment 12 Jeremy Katz 2002-06-04 23:35:03 EDT
Always more than willing to oblige ;-)

Note You need to log in before you can comment on or make changes to this bug.