Bug 61533 - user cannot change expired password at login
user cannot change expired password at login
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: passwd (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-20 20:17 EST by david.howdle
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 14:23:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david.howdle 2002-03-20 20:17:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:

  All new passwords are rejected when login attempts to change expired password.

  A user with an expired password can not change it to a new one when prompted 
  to do so at the login prompt.  The message "is too simple" is displayed, no 
  matter how complex or random the new password entered is.  There is no 
  problem changing the password with the passwd command in the shell.

  1.Expire user password
  2.Login as that user and attempt to enter a new password

  Red Hat Linux release 7.1 (Seawolf)
  Kernel 2.4.2-2 on an i686
  login: dhh
  Password:
  You are required to change your password immediately (password aged)
  Changing password for dhh
  (current) UNIX password:
  New UNIX password:
  BAD PASSWORD: is too simple
  New UNIX password:
  BAD PASSWORD: is too simple
  New UNIX password:

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

  All new passwords are rejected when login attempts to change expired password.

  A user with an expired password can not change it to a new one when prompted 
  to do so at the login prompt.  The message "is too simple" is displayed, no 
  matter how complex or random the new password entered is.  There is no 
  problem changing the password with the passwd command in the shell.

  1.Expire user password
  2.Login as that user and attempt to enter a new password

  Red Hat Linux release 7.1 (Seawolf)
  Kernel 2.4.2-2 on an i686
  login: dhh
  Password:
  You are required to change your password immediately (password aged)
  Changing password for dhh
  (current) UNIX password:
  New UNIX password:
  BAD PASSWORD: is too simple
  New UNIX password:
  BAD PASSWORD: is too simple
  New UNIX password:	

Additional info:
Comment 1 T. Warfield 2003-04-24 14:30:21 EDT
I've had reports from my users that are experiencing the same thing
Comment 2 Tomas Mraz 2005-03-24 14:23:03 EST
Works for me on FC3. If you can reproduce this behaviour on the current
RHEL/Fedora releases, please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.