Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 615331 - Regression in Bugzilla 3.4.7 causes Mylyn to fail
Regression in Bugzilla 3.4.7 causes Mylyn to fail
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bugzilla (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-16 10:19 EDT by Dennis Wagelaar
Modified: 2010-08-27 02:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: bugzilla-3.4.8-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-27 02:52:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 577851 None None None Never

  None (edit)
Description Dennis Wagelaar 2010-07-16 10:19:07 EDT
Description of problem:
Eclipse Mylyn (Eclipse 3.5) no longer works with Bugzilla 3.4.7. It previously worked with bugzilla 3.2.x from Fedora 11. The httpd log contains the following:

config.cgi: Can't locate object method "match" via package "Bugzilla::Component" at Bugzilla/Product.pm line 138, <DATA> line 228.

Version-Release number of selected component (if applicable):
bugzilla-3.4.7-1.fc12.noarch

How reproducible:
Try to create a new bug in Eclipse Mylyn.

Steps to Reproduce:
1. Go to the Mylyn task list.
2. Click the "New task" button.
3. Select the bugzilla repository and click "Finish".
  
Actual results:
Eclipse gives "Initialization of task failed. The provided data is insufficient." The '/var/log/httpd/ssl_error_log' contains the message given earlier.

Expected results:
New bug added; no error in httpd log.

Additional info:
Comment 1 Emmanuel Seyman 2010-07-21 11:22:49 EDT
(In reply to comment #0)
>
> Eclipse Mylyn (Eclipse 3.5) no longer works with Bugzilla 3.4.7.

Strange, it should work.

Dennis, can you check that Mylyn is configured with the appropriate Bugzilla version : (Task Repositories (View) → right+click the repository → Properties).

If that's correct, can you tell me what request triggered the error (you'll need to look in /var/log/httpd/ssl_access_log).
Comment 2 Frédéric Buclin 2010-07-21 12:24:50 EDT
This is not a bug with Mylyn, but a regression in Bugzilla 3.4.7, which I fixed some time ago, see bmo bug 577851:

 https://bugzilla.mozilla.org/show_bug.cgi?id=577851

This fix will be included in Bugzilla 3.4.8, which should be released soon.
Comment 3 Emmanuel Seyman 2010-07-21 19:59:37 EDT
(In reply to comment #2)
> 
> This fix will be included in Bugzilla 3.4.8, which should be released soon.    

Thanks, Frédéric. I'll release 3.4.8 as an update as soon as it's released.
Comment 4 Dennis Wagelaar 2010-07-22 01:25:10 EDT
The Mylyn configuration said that the config was valid for Bugzilla 3.0 - 3.4. The HTTP request that sets it off (/var/log/httpd/ssl_access_log) is this one:

  "HEAD /bugzilla/config.cgi?ctype=rdf HTTP/1.1" 500 -

Also, the patch given in https://bugzilla.mozilla.org/show_bug.cgi?id=577851
 (remove 2 lines of code) works for me.

Thanks for your replies!
Comment 5 Fedora Update System 2010-08-18 18:24:01 EDT
bugzilla-3.4.8-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/bugzilla-3.4.8-2.fc13
Comment 6 Fedora Update System 2010-08-18 18:24:19 EDT
bugzilla-3.4.8-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/bugzilla-3.4.8-1.fc12
Comment 7 Fedora Update System 2010-08-19 21:29:25 EDT
bugzilla-3.4.8-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bugzilla'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/bugzilla-3.4.8-1.fc12
Comment 8 Fedora Update System 2010-08-27 02:51:44 EDT
bugzilla-3.4.8-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-08-27 02:54:44 EDT
bugzilla-3.4.8-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.