Bug 615591 - xorg 1.8.99 crashes when using gimp or xchat
Summary: xorg 1.8.99 crashes when using gimp or xchat
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: icewm   
(Show other bugs)
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gilboa Davara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-17 11:01 UTC by lethalwp
Modified: 2018-04-11 14:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 16:45:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg>file (72.62 KB, text/plain)
2010-07-21 10:39 UTC, lethalwp
no flags Details
part of messages.log (59.19 KB, text/plain)
2010-07-21 10:40 UTC, lethalwp
no flags Details
rpm -qa (111.21 KB, text/plain)
2010-07-21 10:40 UTC, lethalwp
no flags Details
xorg log (21.82 KB, text/plain)
2010-07-21 10:40 UTC, lethalwp
no flags Details
startx > file 2>&1 (6.44 KB, text/plain)
2010-07-21 10:41 UTC, lethalwp
no flags Details

Description lethalwp 2010-07-17 11:01:30 UTC
Description of problem:
it's not the only way to make xorg crash, but it's the only one i remember,
when using gimp in rawhide, copy part of a image, paste as new, close the new window,  xorg crashes

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.8.99.904-6.20100702.fc14.x86_64
happened on earlier rawhides too,  was fine in fc13

How reproducible:
always

Steps to Reproduce:
1. open an image in gimp
2. select a square in the image, go to edit->copy
3. edit-> paste as new
4. close the new window, choose "discard"

  
Actual results:
crash

Expected results:
window closing, no crash

Additional info:

Comment 1 lethalwp 2010-07-17 15:35:58 UTC
another easier way to crash X:

open xchat,  connect to:
/server irc.freenode.net


close xchat by clicking on the X, after the "you're connected" warning say: "yes, close"

x will crash

Comment 2 Matěj Cepl 2010-07-19 08:09:47 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, reproduce the issue, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 3 lethalwp 2010-07-21 10:39:30 UTC
Created attachment 433374 [details]
dmesg>file

Comment 4 lethalwp 2010-07-21 10:40:10 UTC
Created attachment 433375 [details]
part of messages.log

Comment 5 lethalwp 2010-07-21 10:40:36 UTC
Created attachment 433376 [details]
rpm -qa

Comment 6 lethalwp 2010-07-21 10:40:55 UTC
Created attachment 433377 [details]
xorg log

Comment 7 lethalwp 2010-07-21 10:41:19 UTC
Created attachment 433378 [details]
startx > file 2>&1

Comment 8 lethalwp 2010-07-21 10:45:39 UTC
after doing more research,
i begin to think it's icewm (or depending libraries) related,

when i try with the default window manager, i cannot reproduce the problem

There are not many information in the logs :/


I've tried to rebuild the src.rpm from fedora, just to be sure the library linkings were ok, it didn't help.

I've then tried to attach gdb on the running icewm,  it seems it didn't segfault, just got a message: "program exited with code 01"


i'll try with a newer icewm (maybe cvs?), and if the behaviour improves, i'll keep you informed.

Comment 9 lethalwp 2010-07-21 11:01:47 UTC
tried with 1.2.38pre2 and 1.3.7pre2
same behaviour

Comment 10 Matěj Cepl 2010-07-21 13:23:59 UTC
(In reply to comment #8)
> after doing more research,
> i begin to think it's icewm (or depending libraries) related,

I am sorry, but I really think, that switching to icewm component would be more profitable here. I don't see absolutely anything which would indicate Xorg fault.

Icewm maintainer, if you think this is xorg please switch back with additional information, why you think so.

Thank you for reporting the issue and making Fedora better.

Comment 11 Gilboa Davara 2010-07-23 07:16:45 UTC
I'll install rawhide on VM and see if I can reproduce it.

Just to be certain, you are seeing it with icewm-1.2.37-7?

- Gilboa

Comment 12 lethalwp 2010-07-23 09:19:16 UTC
yes, and also with newer official versions from icewm.sf.net,
didn't try cvs

Comment 13 Bug Zapper 2010-07-30 12:38:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 14 lethalwp 2010-08-04 22:31:46 UTC
did you have any luck reproducing the error?

Sometimes i think it's related to the "focus following cursor" mode:
when i have a certain popup window (with java software independant of fedora), click right on the OK button it works,   but if i miss the ok, clicked just next to it, then click ok;  i get the crash also.

Comment 15 Gilboa Davara 2010-08-05 08:03:24 UTC
Nope.
My Rawhide VM died.
I'm trying to free some time to reinstall it.

- Gilboa

Comment 16 lethalwp 2010-08-11 16:45:24 UTC
it looks like the update of libX11 of today fixed this issue
(libX11-1.3.4-3)

Closing this report, it's good for me


Note You need to log in before you can comment on or make changes to this bug.