Bug 615707 - kernel 2.6.35-0.41 oops in input_set_keycode() causes boot failure
Summary: kernel 2.6.35-0.41 oops in input_set_keycode() causes boot failure
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 616005 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-18 06:56 UTC by sd.domrep
Modified: 2010-07-19 20:04 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-07-19 20:04:31 UTC


Attachments (Terms of Use)
screen picture of Lenovo 3000 C100 boot process (657.58 KB, application/zip)
2010-07-18 06:58 UTC, sd.domrep
no flags Details

Description sd.domrep 2010-07-18 06:56:40 UTC
Description of problem:
kernel 2.6.35-0.41 doesn't boot on Lenovo 3000 C100

-0.40 does.

Version-Release number of selected component (if applicable):
kernel 2.6.35-0.41

How reproducible:
Just boot.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Results are:
1. Boot process stuck about 15-30 seconds before kernel actually start to read initrd image. Usually it hangs 1 or 2 seconds, 0.41 hangs for 15-30.

Then it just stuck in the udevd session.

I attached pictures of my screen, so you can see it yourself.

Expected results:


Additional info:

Comment 1 sd.domrep 2010-07-18 06:58:47 UTC
Created attachment 432671 [details]
screen picture of Lenovo 3000 C100 boot process

Comment 2 Jóhann B. Guðmundsson 2010-07-19 12:22:24 UTC
Happens on a Dell Inspiron 6000 as well

Comment 3 sd.domrep 2010-07-19 13:23:44 UTC
Ooops

There is another "oops" in 2.6.35-047

I opened new bug:
https://bugzilla.redhat.com/show_bug.cgi?id=616005

Comment 4 sd.domrep 2010-07-19 13:26:58 UTC
But this one looks like solved, so we can close this bug.

Comment 5 Kyle McMartin 2010-07-19 14:11:14 UTC
*** Bug 616005 has been marked as a duplicate of this bug. ***

Comment 6 Kyle McMartin 2010-07-19 14:55:34 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=2328982 try this build please, it might fix things.
(I think the problem is that old_keycode is uninitialized in the else clause case of input_set_keycode...)

Comment 7 sd.domrep 2010-07-19 17:39:45 UTC
Confirm, that 2.6.35-0.47.rc5.git2.bz615707.fc14.i686.PAE works.

Just installed and booted successfully.

Comment 8 sd.domrep 2010-07-19 17:40:11 UTC
There is no "oops"

Comment 9 Jarod Wilson 2010-07-19 17:48:52 UTC
Will be included in 2.6.35-0.48.rc5.git2 (building now) and later, thanks for confirming the fix.

Comment 10 sd.domrep 2010-07-19 17:58:06 UTC
If you think this bug may be closed, please close it.
I do not really know the rules of BZ.
Thanks.

Comment 11 Jarod Wilson 2010-07-19 20:04:31 UTC
Sure, will do. Fix is built into this kernel (and later), patch will get sent upstream shortly:

http://kojipkgs.fedoraproject.org/packages/kernel/2.6.35/0.49.rc5.git2.fc14/


Note You need to log in before you can comment on or make changes to this bug.