Bug 615776 - Anaconda did not erase all old packages during relase update
Anaconda did not erase all old packages during relase update
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-18 13:39 EDT by Germano Massullo
Modified: 2010-07-19 10:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-19 10:24:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Germano Massullo 2010-07-18 13:39:57 EDT
This computer since Fedora 11 has always been relase-updated with internet, not disks.
In Fedora 12 once I had a problem updating with yum, and asking in an Italian Forum we found out that was a problem about old packages from the old Fedora 11 relase. ( http://www.fedoraonline.it/modules/newbb/viewtopic.php?forum=19&topic_id=12288 it is in Italian, but I wrote it here in the case you want to give a look to the code posted there...)

NOW, in Fedora 13, I have the same problem when trying to update with yum: here the messages (dipendenza mancante means missing dependency)


Esecuzione rpm_check_debug
ERRORE tra rpm_check_debug e depsolve:
kernel-uname-r = 2.6.32.11-99.fc12.i686.PAE is needed by (installed) kmod-nvidia-2.6.32.11-99.fc12.i686.PAE-1:195.36.15-1.fc12.2.i686
kernel-uname-r = 2.6.32.11-99.fc12.i686.PAE is needed by (installed) kmod-VirtualBox-OSE-2.6.32.11-99.fc12.i686.PAE-3.1.4-1.fc12.7.i686
kernel-uname-r = 2.6.32.12-115.fc12.i686.PAE is needed by (installed) kmod-nvidia-2.6.32.12-115.fc12.i686.PAE-1:195.36.24-1.fc12.2.i686
kernel-uname-r = 2.6.32.12-115.fc12.i686.PAE is needed by (installed) kmod-VirtualBox-OSE-2.6.32.12-115.fc12.i686.PAE-3.1.4-1.fc12.11.i686
Riportare questo errore su http://yum.baseurl.org/report
kmod-VirtualBox-OSE-2.6.32.11-99.fc12.i686.PAE-3.1.4-1.fc12.7.i686 ha una dipendenza mancante di kernel-uname-r = ('0', '2.6.32.11', '99.fc12.i686.PAE')
kmod-VirtualBox-OSE-2.6.32.12-115.fc12.i686.PAE-3.1.4-1.fc12.11.i686 ha una dipendenza mancante di kernel-uname-r = ('0', '2.6.32.12', '115.fc12.i686.PAE')
1:kmod-nvidia-2.6.32.11-99.fc12.i686.PAE-195.36.15-1.fc12.2.i686 ha una dipendenza mancante di kernel-uname-r = ('0', '2.6.32.11', '99.fc12.i686.PAE')
1:kmod-nvidia-2.6.32.12-115.fc12.i686.PAE-195.36.24-1.fc12.2.i686 ha una dipendenza mancante di kernel-uname-r = ('0', '2.6.32.12', '115.fc12.i686.PAE')


Caused by the presency of old packages from Fedora 12. I've posted the list of these packages in comment number two, to not make this post full of code.

I reported the bug(?) under Anaconda because I think that it's a problem of Anaconda if now I still have packages from Fedora 12.
Comment 1 Germano Massullo 2010-07-18 13:41:15 EDT
gsim85-0.3-2.fc12.i686
libdvdnav-4.1.4-0.1.svn1184.fc12.i686
libcaca-0.99-0.9.beta16.fc12.i686
avr-gdb-6.6-11.fc12.i686
libxslt-1.1.26-1.fc12.i686
liborigin-20080225-4.fc12.i686
liboil-0.3.16-4.fc12.i686
libart_lgpl-debuginfo-2.3.20-5.fc12.i686
diffutils-2.8.1-25.fc12.i686
system-config-keyboard-1.3.1-1.fc12.i686
GeoIP-devel-1.4.7-0.1.20090931cvs.fc12.i686
gnuplot-4.2.6-1.fc12.i686
pax-3.4-10.fc12.i686
nodoka-metacity-theme-0.3.90-4.fc12.noarch
ptouch-driver-1.3-2.fc12.i686
libdca-0.0.5-5.fc12.i686
wavpack-4.60-1.fc12.i686
antlr-2.7.7-6.fc12.i686
uisp-20050207-6.fc12.i686
fbset-2.1-29.fc12.i686
libebml-0.7.8-3.fc12.i686
libXau-devel-1.0.5-1.fc12.i686
rhino-1.7-0.7.r2.fc12.noarch
libavc1394-0.5.3-9.fc12.i686
SDL_sound-1.0.3-4.fc12.i686
preupgrade-1.1.7-1.fc12.noarch
lua-5.1.4-4.fc12.i686
OpenSceneGraph-libs-2.8.2-3.fc12.i686
c2050-0.3b-3.fc12.i686
leonidas-backgrounds-common-11.0.0-2.fc12.noarch
testdisk-6.11-6.fc12.i686
pkcs11-helper-1.07-4.fc12.i686
dirac-libs-1.0.2-3.fc12.i686
texlive-texmf-errata-dvips-2007-7.fc12.noarch
libshout-2.2.2-5.fc12.i686
libsamplerate-0.1.7-2.fc12.i686
ipsec-tools-0.7.3-4.fc12.i686
acpid-1.0.10-2.fc12.i686
libusb-0.1.12-22.fc12.i686
guile-lib-0.1.6-3.fc12.noarch
sk2py-0.1-4.fc12.noarch
libfreebob-1.0.11-6.fc12.i686
pycairo-1.8.6-2.fc12.i686
rubyripper-0.5.7-2.fc12.noarch
gsm-1.0.13-2.fc12.i686
g-wrap-1.9.11-4.fc12.i686
gdbm-1.8.0-33.fc12.i686
libgnomecups-debuginfo-0.2.3-7.fc12.i686
libmad-0.15.1b-13.fc12.i586
paktype-fonts-common-2.0-5.fc12.noarch
fluid-soundfont-common-3.1-4.fc12.noarch
jakarta-commons-dbcp-1.2.1-13.7.fc12.noarch
cloog-ppl-0.15.7-1.fc12.i686
octave-forge-20090607-15.fc12.i686
fakenes-0.5.9-0.1.beta3.fc12.i686
radeontool-1.5-6.fc12.i686
gerbv-2.3.0-3.fc12.i686
aspell-it-2.2_20050523-4.fc12.i686
xvidcore-1.2.1-3.fc12.i686
arm-gp2x-linux-gcc-4.1.2-11.fc12.i686
jakarta-commons-beanutils-1.7.0-12.3.fc12.i686
arm-gp2x-linux-glibc-2.3.6-7.fc12.noarch
gnuchess-5.07-14.fc12.i686
rootfiles-8.1-6.fc12.noarch
libvisual-0.4.0-9.fc12.i686
zvbi-0.2.33-4.fc12.i686
gimp-help-2.4.2-5.fc12.noarch
hal-info-20090716-3.fc12.noarch
kdnssd-avahi-0.1.3-0.9.20080116svn.fc12.i686
fedorainfinity-screensaver-theme-1.0.0-3.fc12.noarch
mx-3.1.1-5.fc12.i686
bea-stax-1.2.0-0.5.rc1.fc12.i686
rp-pppoe-3.10-6.fc12.i686
finger-0.17-39.fc12.i686
yakuake-2.9.6-2.fc12.i686
lxdream-0.9.1-1.fc12.i586
tomcat5-jasper-5.5.27-7.4.fc12.noarch
libdap-3.9.3-2.fc12.i686
xorg-x11-fonts-Type1-7.2-9.fc12.noarch
xorg-x11-fonts-100dpi-7.2-9.fc12.noarch
ed-1.1-3.fc12.i686
pycairo-devel-1.8.6-2.fc12.i686
mingetty-1.08-4.fc12.i686
tomcat5-jasper-eclipse-5.5.27-7.4.fc12.noarch
dmidecode-2.10-1.39.fc12.i686
ghostscript-fonts-5.50-23.fc12.noarch
libwpg-0.1.3-4.fc12.i686
dbus-qt-0.70-7.fc12.i686
pinball-0.3.1-15.fc12.i686
gresistor-0.0.1-16.fc12.noarch
liblastfm-0.3.0-2.fc12.i686
xorg-x11-fonts-ISO8859-1-100dpi-7.2-9.fc12.noarch
kmod-nvidia-2.6.32.11-99.fc12.i686.PAE-195.36.15-1.fc12.2.i686
opensp-1.5.2-12.fc12.i686
libnl-1.1-8.fc12.i686
pnm2ppa-1.04-18.fc12.i686
freehdl-0.0.7-2.fc12.i686
nodoka-filesystem-0.3.90-4.fc12.noarch
libvncserver-0.9.7-3.fc12.i686
khmeros-base-fonts-5.0-7.fc12.noarch
kftpgrabber-0.8.1-11.fc12.i686
bluecurve-cursor-theme-8.0.2-5.fc12.noarch
taglib-extras-1.0.1-1.fc12.i686
b43-fwcutter-012-2.fc12.i686
pharosc-magic-8.3-3.fc12.noarch
libart_lgpl-2.3.20-5.fc12.i686
zlib-debuginfo-1.2.3-23.fc12.i686
which-2.19-5.fc12.i686
alleggl-0.4.3-6.fc12.i686
openshot-1.0.0-1.fc12.noarch
fedora-screensaver-theme-1.0.0-5.fc12.noarch
jomolhari-fonts-0.003-8.fc12.noarch
ql23xx-firmware-3.03.27-3.fc12.noarch
zlib-1.2.3-23.fc12.i686
opengl-games-utils-0.1-9.fc12.noarch
compat-readline5-5.2-17.fc12.i686
portaudio-19-9.fc12.i686
tomcat5-jsp-2.0-api-5.5.27-7.4.fc12.noarch
rubyripper-gui-0.5.7-2.fc12.noarch
libmsn-4.0-0.15.beta8.fc12.i686
tslib-1.0-2.fc12.i686
thai-scalable-tlwgtypo-fonts-0.4.12-2.fc12.noarch
keyutils-libs-1.2-6.fc12.i686
xorg-x11-xauth-1.0.2-7.fc12.i686
libxslt-python-1.1.26-1.fc12.i686
libSM-debuginfo-1.1.0-7.fc12.i686
audiofile-0.2.6-11.fc12.i686
time-1.7-37.fc12.i686
cjet-0.8.9-9.fc12.i686
leonidas-backgrounds-kdm-11.0.0-2.fc12.noarch
commoncpp2-1.7.3-2.fc12.i686
dbus-python-0.83.0-6.fc12.i686
leonidas-kde-theme-11.0.3-1.fc12.noarch
irqbalance-0.55-25.fc12.i686
pkgconfig-0.23-9.fc12.i686
cabextract-1.2-3.fc12.i686
libXau-1.0.5-1.fc12.i686
kmod-nvidia-2.6.32.12-115.fc12.i686.PAE-195.36.24-1.fc12.2.i686
libzrtpcpp-1.4.3-2.fc12.i686
alchemist-1.0.37-8.fc12.i686
classpathx-mail-1.1.1-9.1.fc12.i686
screen-4.0.3-15.fc12.i686
PyOpenGL-3.0.0-2.fc12.noarch
libmp4v2-devel-1.5.0.1-10.fc12.i686
tk-8.5.7-3.fc12.i686
libmusicbrainz-2.1.5-11.fc12.i686
texlive-texmf-errata-2007-7.fc12.noarch
php-pecl-apc-3.1.3p1-1.fc12.i686
lzma-libs-4.32.7-3.fc12.i686
libwmf-lite-0.2.8.4-21.fc12.i686
python-numeric-24.2-14.fc12.i686
liblqr-1-0.4.1-1.fc12.i686
arm-gp2x-linux-gcc-c++-4.1.2-11.fc12.i686
words-3.0-16.fc12.noarch
zisofs-tools-1.0.8-5.fc12.i686
libupnp-1.6.6-3.fc12.i686
rarian-0.8.1-5.fc12.i686
libpano13-2.9.14-2.fc12.i686
gputils-0.13.7-2.fc12.i686
libusb-devel-0.1.12-22.fc12.i686
arpack-2.1-12.fc12.i686
SDL_net-1.2.7-6.fc12.i686
libnc-dap-3.7.4-2.fc12.i686
qt-qsa-1.1.5-7.fc12.i686
libieee1284-devel-0.2.11-8.fc12.i686
bzip2-devel-1.0.5-6.fc12.i686
giflib-4.1.6-3.fc12.i686
dinotrace-9.4a-5.fc12.i686
jakarta-oro-2.0.8-6.3.fc12.i686
gtkglext-libs-1.2.0-10.fc12.i686
irsim-9.7.68-3.fc12.i686
system-config-display-2.2-1.fc12.i686
system-config-boot-0.4.1-1.fc12.i686
libdbi-drivers-0.8.3-5.fc12.i686
libiodbc-3.52.7-1.fc12.i686
bc-1.06.95-1.fc12.i686
xorg-x11-fonts-ISO8859-15-100dpi-7.2-9.fc12.noarch
bzip2-1.0.5-6.fc12.i686
c2070-0.99-6.fc12.i686
dotconf-1.0.13-9.fc12.i686
python-nss-0.8-1.fc12.i686
libfontenc-1.0.5-2.fc12.i686
khmeros-fonts-common-5.0-7.fc12.noarch
ftplib-3.1-6.fc12.i686
chmlib-0.40-2.fc12.i686
picocom-1.4-8.fc12.i686
libipoddevice-0.5.3-8.fc12.i686
libgnomecups-0.2.3-7.fc12.i686
keyutils-libs-devel-1.2-6.fc12.i686
thai-scalable-loma-fonts-0.4.12-2.fc12.noarch
libwpd-0.8.14-4.fc12.i686
wsdl4j-1.5.2-7.6.fc12.i686
jzlib-1.0.7-7.3.fc12.i686
pinfo-0.6.9-11.fc12.i686
libdbi-dbd-mysql-0.8.3-5.fc12.i686
xorg-x11-drv-ast-0.89.9-1.fc12.i686
akmods-0.3.6-3.fc12.noarch
gimp-data-extras-2.0.2-3.fc12.noarch
solar-kde-theme-0.1.19-1.fc12.noarch
libupnp-devel-1.6.6-3.fc12.i686
python-pycurl-7.19.0-4.fc12.i686
pbm2l7k-990321-7.fc12.i686
lzo-2.03-3.fc12.i686
libsmi-0.4.8-3.fc12.i686
stix-fonts-0.9-13.fc12.noarch
solar-backgrounds-common-0.92.0-3.fc12.noarch
sgpio-1.2.0.10-4.fc12.i686
efibootmgr-0.5.4-7.fc12.i686
libjpeg-6b-46.fc12.i686
guile-cairo-devel-1.4.0-8.fc12.i686
bcm43xx-fwcutter-006-6.fc12.i686
plotutils-2.5-7.fc12.i686
libofa-0.9.3-16.fc12.i686
gmameui-0.2.10-1.fc12.i586
physfs-1.0.2-2.fc12.i686
rpcbind-0.2.0-4.fc12.i686
libmng-1.0.10-4.fc12.i686
libtunepimp-0.5.3-16.fc12.i686
ustr-1.0.4-9.fc12.i686
libXaw-1.0.6-4.fc12.i686
nss-mdns-0.10-8.fc12.i686
thai-scalable-sawasdee-fonts-0.4.12-2.fc12.noarch
alliance-libs-5.0-31.20090901snap.fc12.i686
gstreamer-python-0.10.16-1.fc12.i686
junit-3.8.2-6.4.fc12.i686
gtkterm-0.99.5-11.fc12.i686
backintime-kde-0.9.26-3.fc12.noarch
sinjdoc-0.5-9.fc12.i686
pikloops-0.2.5-5.fc12.i686
tkcvs-8.2-3.fc12.noarch
log4j-1.2.14-6.3.fc12.i686
guile-gnome-platform-2.16.1-4.fc12.i686
thai-scalable-norasi-fonts-0.4.12-2.fc12.noarch
ttmkfdir-3.0.9-32.fc12.i686
pbm2l2030-1.4-5.fc12.i686
min12xxw-0.0.9-5.fc12.i686
neXtaw-0.15.1-14.fc12.i686
leonidas-backgrounds-lion-dual-11.0.0-2.fc12.noarch
procmail-3.22-25.fc12.i686
iwl4965-firmware-228.61.2.24-2.fc12.noarch
libotr-3.2.0-4.fc12.i686
xsettings-kde-0.11-1.fc12.i686
ql2200-firmware-2.02.08-3.fc12.noarch
kmod-VirtualBox-OSE-2.6.32.11-99.fc12.i686.PAE-3.1.4-1.fc12.7.i686
joystick-1.2.15-25.fc12.i686
tomcat5-servlet-2.4-api-5.5.27-7.4.fc12.noarch
libSM-1.1.0-7.fc12.i686
libcdaudio-0.99.12p2-13.fc12.i686
hyphen-it-0.20071127-5.fc12.noarch
gsoap-2.7.13-2.fc12.i686
xosd-2.2.14-13.fc12.i686
wireless-tools-29-5.1.fc12.i686
jakarta-commons-logging-1.0.4-9.8.fc12.i686
hamcrest-1.1-9.2.fc12.i686
magic-8.0.54-1.fc12.i686
gds2pov-0.20080229-3.fc12.i686
fuse-sshfs-2.2-5.fc12.i686
system-config-rootpassword-1.99.6-1.fc12.noarch
thai-scalable-garuda-fonts-0.4.12-2.fc12.noarch
libstroke-0.5.1-23.fc12.i686
thai-scalable-fonts-compat-0.4.12-2.fc12.noarch
OpenThreads-2.8.2-3.fc12.i686
ilmbase-1.0.1-6.fc12.i686
libcaptury-0.3.0-0.4.20080323gitcca4e3c.fc12.i686
mythes-it-2.0.9l-4.fc12.noarch
soundtouch-1.4.0-3.fc12.i686
bea-stax-api-1.2.0-0.5.rc1.fc12.i686
arm-gp2x-linux-SDL-1.2.9-6.fc12.noarch
ftp-0.17-51.fc12.i686
opencore-amr-0.1.2-1.fc12.i686
faac-1.28-2.fc12.i686
kmod-VirtualBox-OSE-2.6.32.12-115.fc12.i686.PAE-3.1.4-1.fc12.11.i686
ppl-0.10.2-10.fc12.i686
libXtst-1.0.99.2-3.fc12.i686
thai-scalable-kinnari-fonts-0.4.12-2.fc12.noarch
pharosc-xcircuit-8.3-3.fc12.noarch
libwmf-0.2.8.4-21.fc12.i686
vbetool-1.2.2-1.fc12.i686
LabPlot-1.6.0.2-8.fc12.i686
jakarta-commons-net-2.0-2.fc12.noarch
anaconda-yum-plugins-1.0-5.fc12.noarch
electric-8.09-1.fc12.noarch
kino-1.3.4-2.fc12.i686
printer-filters-1.1-4.fc12.noarch
xalan-j2-2.7.0-9.5.fc12.i686
libmatroska-0.8.1-5.fc12.i686
libsigc++20-2.2.4.2-1.fc12.i686
thai-scalable-tlwgtypewriter-fonts-0.4.12-2.fc12.noarch
ffmpeg2dirac-0.1.0-4.fc12.i686
libofx-0.9.1-2.fc12.i686
aspell-en-6.0-11.fc12.i686
python-ethtool-0.3-5.fc12.i686
notify-python-0.1.1-8.fc12.i686
thai-scalable-fonts-common-0.4.12-2.fc12.noarch
lx-20030328-5.fc12.i686
python-sqlite2-2.3.5-2.fc12.i686
libmpeg2-0.5.1-8.fc12.i686
gnokii-0.6.28-1.fc12.i686
libgssglue-0.1-8.fc12.i686
texlive-texmf-errata-fonts-2007-7.fc12.noarch
xcb-util-0.3.6-1.fc12.i686
libwiimote-0.4-9.fc12.i686
jakarta-commons-el-1.0-18.1.fc12.noarch
ccrtp-1.7.1-2.fc12.i686
esound-libs-0.2.41-3.fc12.i686
rng-utils-2.0-4.fc12.i686
dfu-programmer-0.5.1-3.fc12.i686
vconfig-1.9-8.fc12.i686
rarian-compat-0.8.1-5.fc12.i686
bzip2-libs-1.0.5-6.fc12.i686
zlib-devel-1.2.3-23.fc12.i686
spambayes-1.0.4-9.fc12.noarch
suitesparse-3.4.0-2.fc12.i686
libmng-devel-1.0.10-4.fc12.i686
pcre-7.8-3.fc12.i686
speedcrunch-0.10-3.fc12.i686
python-formencode-1.2.2-2.fc12.noarch
libcapseo-0.3.0-0.3.20081031git431a293.fc12.i686
libXScrnSaver-devel-1.2.0-1.fc12.i686
alliance-5.0-31.20090901snap.fc12.i686
jakarta-commons-launcher-1.1-4.4.fc12.i686
xorg-x11-drv-apm-1.2.2-1.fc12.i686
g-wrap-devel-1.9.11-4.fc12.i686
libmpcdec-1.2.6-6.fc12.i686
linsmith-0.99.12-2.fc12.i686
libjpeg-debuginfo-6b-46.fc12.i686
xorg-x11-fonts-ISO8859-9-100dpi-7.2-9.fc12.noarch
axis-1.2.1-7.fc12.i686
lzo-minilzo-2.03-3.fc12.i686
tremulous-data-1.1.0-7.fc12.noarch
leonidas-backgrounds-11.0.0-2.fc12.noarch
GeoIP-1.4.7-0.1.20090931cvs.fc12.i686
jakarta-commons-discovery-0.4-5.3.fc12.noarch
kbd-1.15-9.fc12.i686
libbeagle-0.3.9-5.fc12.i686
backintime-common-0.9.26-3.fc12.noarch
hyphen-en-2.4-5.fc12.noarch
lesstif-0.95.2-1.fc12.i686
plib-1.8.5-3.fc12.i686
gnugo-3.8-2.fc12.i686
arm-gp2x-linux-kernel-headers-2.6.12.0-4.fc12.noarch
notification-daemon-engine-nodoka-0.1.0-11.fc12.i686
hyphen-2.4-5.fc12.i686
arm-gp2x-linux-zlib-1.2.3-8.fc12.noarch
qwtplot3d-0.2.7-9.fc12.i686
irda-utils-0.9.18-10.fc12.i686
vhd2vl-2.0-5.fc12.i686
flac-1.2.1-6.fc12.i686
ebook-tools-libs-0.1.1-5.fc12.i686
openslp-1.2.1-14.fc12.i686
libupnp-debuginfo-1.6.6-3.fc12.i686
kdnssd-avahi-devel-0.1.3-0.9.20080116svn.fc12.i686
OpenEXR-libs-1.6.1-8.fc12.i686
classpathx-jaf-1.0-15.1.fc12.i686
psmisc-22.6-13.fc12.i686
qca2-2.0.2-2.fc12.i686
jigdo-0.7.3-9.fc12.i686
rdate-1.4-14.fc12.i686
libdc1394-2.1.2-3.fc12.i686
tremulous-1.1.0-10.fc12.i686
SDL_net-devel-1.2.7-6.fc12.i686
libXScrnSaver-1.2.0-1.fc12.i686
thai-scalable-tlwgtypist-fonts-0.4.12-2.fc12.noarch
indent-2.2.10-5.fc12.i686
mozilla-filesystem-1.9-5.fc12.i686
lrzsz-0.12.20-27.fc12.i686
ql2100-firmware-1.19.38-3.fc12.noarch
pikdev-0.9.2-8.fc12.i686
libXp-1.0.0-15.fc12.i686
supertux-0.3.1-9.fc12.i686
bison-2.4.1-4.fc12.i686
scrub-2.1-3.fc12.i686
pyxf86config-0.3.37-7.fc12.i686
gnuplot-common-4.2.6-1.fc12.i686
pharosc-alliance-8.3-3.fc12.noarch
tinyxml-2.5.3-5.fc12.i686
thai-scalable-tlwgmono-fonts-0.4.12-2.fc12.noarch
gnome-mime-data-2.18.0-5.fc12.noarch
libieee1284-0.2.11-8.fc12.i686
libmp4v2-1.5.0.1-10.fc12.i686
libopensync-0.22-5.fc12.i686
usbutils-0.86-2.fc12.i686
guile-cairo-1.4.0-8.fc12.i686
mpage-2.5.6-8.fc12.i686
dvd+rw-tools-7.1-4.fc12.i686
gnuplot-latex-4.2.6-1.fc12.noarch
openobex-1.4-4.fc12.i686
thai-scalable-waree-fonts-0.4.12-2.fc12.noarch
libglade2-debuginfo-2.6.4-3.fc12.i686
xorg-x11-fonts-ISO8859-1-75dpi-7.2-9.fc12.noarch
bcel-5.2-7.1.fc12.i686
kshutdown-1.0.1-4.fc12.i686
texlive-texmf-errata-latex-2007-7.fc12.noarch
netgen-1.3.7-19.fc12.i686
minizip-1.2.3-23.fc12.i686
smp_utils-0.94-3.fc12.i686
objectweb-asm-3.1-7.1.fc12.noarch
lensfun-0.2.4-1.fc12.i686
libXtst-devel-1.0.99.2-3.fc12.i686
libiptcdata-1.0.4-2.fc12.i686
thai-scalable-umpush-fonts-0.4.12-2.fc12.noarch
m4-1.4.13-4.fc12.i686
ktechlab-0.3.70-3.20090304svn.fc12.i686
libutempter-1.1.5-4.fc12.i686
aalib-libs-1.4.0-0.18.rc5.fc12.i686
jakarta-commons-httpclient-3.1-0.5.fc12.i686
libical-0.43-5.fc12.i686
qucs-0.0.15-4.fc12.i686
fluid-soundfont-lite-patches-3.1-4.fc12.noarch
xorg-x11-fonts-misc-7.2-9.fc12.noarch
dash-0.5.5.1-3.fc12.i686
rdesktop-1.6.0-7.fc12.i686
libjpeg-devel-6b-46.fc12.i686
lshw-B.02.14-3.fc12.i686
libglade2-2.6.4-3.fc12.i686
nas-libs-1.9.1-6.fc12.i686
makebootfat-1.4-9.fc12.i686
jakarta-commons-collections-3.2.1-3.fc12.i686
isomd5sum-1.0.5-3.fc12.i686
libdbi-0.8.3-3.fc12.i686
python-imaging-1.1.6-17.fc12.i686
libSM-devel-1.1.0-7.fc12.i686
duel3-0.1-0.8.20060225.fc12.i686
speex-1.2-0.12.rc1.fc12.i686
dumb-0.9.3-9.fc12.i686
libXau-debuginfo-1.0.5-1.fc12.i686
pharosc-synopsys-8.3-3.fc12.noarch
guile-gnome-platform-devel-2.16.1-4.fc12.i686
libglademm24-2.6.7-3.fc12.i686
fftw2-2.1.5-19.fc12.i686
fribidi-0.19.2-2.fc12.i686
pidgin-otr-3.2.0-3.fc12.i686
libconfig-1.3.2-1.fc12.i686
libmodplug-0.8.7-2.fc12.i686
kdeaddons-debuginfo-3.5.10-4.fc12.i686
pam_smb-1.1.7-11.fc12.i686
tcpdump-4.0.0-3.20090921gitdf3cb4.fc12.i686
pharosc-8.3-3.fc12.noarch
libfli-1.7-6.fc12.i686
thai-scalable-purisa-fonts-0.4.12-2.fc12.noarch
Comment 2 Germano Massullo 2010-07-18 13:42:05 EDT
Should I report also the yum error at http://yum.baseurl.org/report like yum suggests?
Comment 3 Germano Massullo 2010-07-18 15:14:04 EDT
I forgot to write that the version upgrade was started with preupgrade
Comment 4 Chris Lumens 2010-07-19 10:24:09 EDT
There are several things that could be happening here.

First, anaconda does not remove old packages unless they have been obsoleted by something else.  If no newer package ever obsoletes something old (for example, the package just gets abandoned), it will not be removed.  The reason for this is simply that you could have something installed that you built locally or from some third-party repo that anaconda knows nothing about, and we don't want to just remove it.

Second, just because you have .fc12 packages around doesn't mean much.  Some of those could have just not been rebuilt since then.  You have quite a long list there, so I don't believe that's going to be the case for all of your packages.  It does explain some, though.

It's also possible that the kmod-nvidia package conflict with the kernel you outline above is screwing everything up.  If the kernel package can't be upgraded because of that conflict, that would likely prevent a bunch of other packages from being upgraded, which could then cascade into the list you see above.  Since kmod-nvidia is a third-party closed source package, we cannot offer any support for it.
Comment 5 Germano Massullo 2010-07-19 10:36:25 EDT
I solved the problem by removing these packages

kmod-VirtualBox-OSE-2.6.32.11-99.fc12.i686.PAE-3.1.4-1.fc12.7.i686
kmod-VirtualBox-OSE-2.6.32.12-115.fc12.i686.PAE-3.1.4-1.fc12.11.i686
1:kmod-nvidia-2.6.32.11-99.fc12.i686.PAE-195.36.15-1.fc12.2.i686
1:kmod-nvidia-2.6.32.12-115.fc12.i686.PAE-195.36.24-1.fc12.2.i686

Note You need to log in before you can comment on or make changes to this bug.