Bug 615798 - [abrt] crash in nicotine+-1.2.15-2.fc13: utils.py:116:showCountryTooltip:AttributeError: 'NoneType' object has no attribute 'startswith'
[abrt] crash in nicotine+-1.2.15-2.fc13: utils.py:116:showCountryTooltip:Attr...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nicotine+ (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Mohamed El Morabity
Fedora Extras Quality Assurance
abrt_hash:10d374d1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-18 17:55 EDT by vinced
Modified: 2010-12-27 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-27 20:09:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.04 KB, text/plain)
2010-07-18 17:55 EDT, vinced
no flags Details

  None (edit)
Description vinced 2010-07-18 17:55:39 EDT
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/nicotine.py
component: nicotine+
executable: /usr/bin/nicotine.py
kernel: 2.6.33.6-147.fc13.i686
package: nicotine+-1.2.15-2.fc13
reason: utils.py:116:showCountryTooltip:AttributeError: 'NoneType' object has no attribute 'startswith'
release: Fedora release 13 (Goddard)

backtrace
-----
utils.py:116:showCountryTooltip:AttributeError: 'NoneType' object has no attribute 'startswith'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/userlist.py", line 177, in OnTooltip
    return showCountryTooltip(widget, x, y, tooltip, 14, 'flag_')
  File "/usr/lib/python2.6/site-packages/pynicotine/gtkgui/utils.py", line 116, in showCountryTooltip
    if not value.startswith(stripprefix):
AttributeError: 'NoneType' object has no attribute 'startswith'

Local variables in innermost frame:
sourcecolumn: 14
x: 45
stripprefix: 'flag_'
title: 'Pays'
column: <gtk.TreeViewColumn object at 0xaa63cfc (GtkTreeViewColumn at 0xb2ee248)>
widget: <gtk.TreeView object at 0xaa63914 (GtkTreeView at 0xb2fa010)>
iter: <GtkTreeIter at 0xb6630b0>
cy: 0
cx: 25
value: None
incorrectpath: (0,)
y: 103
path: (3,)
model: <gtk.ListStore object at 0xaa63b94 (GtkListStore at 0xb2f7d60)>
droppos: <enum GTK_TREE_VIEW_DROP_INTO_OR_BEFORE of type GtkTreeViewDropPosition>
tooltip: <gtk.Tooltip object at 0xb6313ec (GtkTooltip at 0xa96e560)>

How to reproduce
-----
1. simply start nicotine+
2.
3.
Comment 1 vinced 2010-07-18 17:55:42 EDT
Created attachment 432737 [details]
File: backtrace
Comment 2 vinced 2010-07-19 18:33:17 EDT
Package: nicotine+-1.2.15-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.  start downloading
2.
3.
Comment 3 vinced 2010-07-30 00:38:17 EDT
Package: nicotine+-1.2.15-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.  I don't know, everything's fine, I'm tchatting, and everything's fine
2.
3.
Comment 4 vinced 2010-08-02 00:42:15 EDT
Package: nicotine+-1.2.15-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.  the user I was tchating with got disconnected
2.
3.
Comment 5 vinced 2010-08-03 01:16:25 EDT
Package: nicotine+-1.2.15-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.   I was tchating ... but eveything looks ok for me. I think my connection has a little problem because it gets disconnected and re-connected quite often. Or nicotine ?
2.
3.
Comment 6 vinced 2010-08-08 01:32:42 EDT
Package: nicotine+-1.2.15-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.   I have no idea
2.
3.
Comment 7 vinced 2010-08-08 02:48:43 EDT
Package: nicotine+-1.2.15-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.   I have no idea :/ maybe because of wireless connection ?
2.
3.
Comment 8 vinced 2010-08-17 23:10:55 EDT
Package: nicotine+-1.2.15-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.   I have no idea :/ 
2.
3.
Comment 9 vinced 2010-09-16 17:08:05 EDT
Package: nicotine+-1.2.15-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
 I did absolutely nothing, and in return the bug did nothing special to me.
Comment 10 vinced 2010-11-14 16:28:14 EST
Package: nicotine+-1.2.15-2.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
Sorry nothing to say ... I just right clicked on a user. But I want Nicotine+ to be even more perfect so I report this "bug" 
that did nothing.
Cheers
Comment 11 Mohamed El Morabity 2010-11-22 04:31:17 EST
Thanks for this report. Please test the latest version of nicotine+ available in
the stable repos:
   # yum update nicotine+
Comment 12 Mohamed El Morabity 2010-12-27 20:09:22 EST
No news is good news. Closing since there is no answer and a newer version is available.

Note You need to log in before you can comment on or make changes to this bug.