Bug 615828 - libvirt doesn't detect existing disks partition table, shows pool format='unknown'
libvirt doesn't detect existing disks partition table, shows pool format='unk...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
: 781263 (view as bug list)
Depends On:
Blocks: 781263
  Show dependency treegraph
 
Reported: 2010-07-18 22:42 EDT by wangyimiao
Modified: 2015-03-16 13:02 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 781263 (view as bug list)
Environment:
Last Closed: 2012-02-13 22:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager log (4.20 KB, application/octet-stream)
2010-11-30 03:47 EST, wangyimiao
no flags Details

  None (edit)
Description wangyimiao 2010-07-18 22:42:24 EDT
Description of problem:
Use 'pool-dumpxml' to dump a Physical disk pool create by virt-manager with format='auto'and check 'build pool',but the dumpxml result is display as "format type='unknown'".

Version-Release number of selected component (if applicable):
-libvirt-0.8.1-15.el6.x86_64
-qemu-kvm-0.12.1.2-2.94.el6.x86_64
-qemu-img-0.12.1.2-2.94.el6.x86_64
-kernel-2.6.32-50.el6.x86_64


How reproducible:
5/5

Steps to Reproduce:

1.Use virt-manager to create a Physical disk pool with format='auto' and check 'build pool'.

1).# virsh pool-list --all
Name                 State      Autostart 
-----------------------------------------
default              active     yes             
ewr                  active     yes  

2).# virsh pool-dumpxml ewr
<pool type='disk'>
  <name>ewr</name>
  <uuid>9e27b06d-688b-25cd-e294-6bee49a6a3ae</uuid>
  <capacity>500105249280</capacity>
  <allocation>0</allocation>
  <available>500105217024</available>
  <source>
    <device path='/dev/sdb'>
    <freeExtent start='32256' end='500105249280'/>
    </device>
    <format type='unknown'/>
  </source>
  <target>
    <path>/dev</path>
    <permissions>
      <mode>0700</mode>
      <owner>-1</owner>
      <group>-1</group>
    </permissions>
  </target>
</pool>
  
Actual results:

The dumpxml result is display as "format type='unknown'".

Expected results:

The argument format need to display a correct foramt.
Comment 2 RHEL Product and Program Management 2010-07-18 23:17:46 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Cole Robinson 2010-11-29 13:21:28 EST
Hmm, virt-manager throws an error if you try to build a disk pool with format 'auto'. I get:

ValueError: Must explicitly specify disk format if formatting disk device.

Can you provide exact steps to reproduce, or ~/.virt-manager/virt-manager.log output when reproducing?
Comment 4 wangyimiao 2010-11-30 03:47:09 EST
Created attachment 463665 [details]
virt-manager log

'virt-manager.log'-please sees the attachment.
Comment 5 Cole Robinson 2010-11-30 09:59:46 EST
Hmm, are you sure you selected the 'build' option this time? I still get an error if format=auto and build is selected.

Assuming you didn't select 'build', the bug here is that libvirt doesn't know how to detect an existing disks partition table. Reassigning to libvirt.
Comment 8 Dave Allan 2011-06-09 21:52:18 EDT
(In reply to comment #5)
> Hmm, are you sure you selected the 'build' option this time? I still get an
> error if format=auto and build is selected.
> 
> Assuming you didn't select 'build', the bug here is that libvirt doesn't know
> how to detect an existing disks partition table. Reassigning to libvirt.

Setting needinfo.
Comment 9 wangyimiao 2011-06-10 04:11:06 EDT
I retest it on virt-manger build:
virt-manager-0.8.4-8.el6.noarch

Interesting,can not reproduce that issue.And result same as the comment Comment 5, so I clarify issue steps to that:

1.Use virt-manager to create a Physical disk pool with format='auto'.

1).# virsh pool-list --all
Name                 State      Autostart 
-----------------------------------------
default              active     yes             
ewr                  active     yes  

2).# virsh pool-dumpxml ewr
<pool type='disk'>
  <name>ewr</name>
  <uuid>9e27b06d-688b-25cd-e294-6bee49a6a3ae</uuid>
  <capacity>500105249280</capacity>
  <allocation>0</allocation>
  <available>500105217024</available>
  <source>
    <device path='/dev/sdb'>
    <freeExtent start='32256' end='500105249280'/>
    </device>
    <format type='unknown'/>
  </source>
  <target>
    <path>/dev</path>
    <permissions>
      <mode>0700</mode>
      <owner>-1</owner>
      <group>-1</group>
    </permissions>
  </target>
</pool>

Actual results:

The dumpxml result is display as "format type='unknown'".

Expected results:

The argument format need to display a correct foramt.
Comment 11 Daniel Veillard 2012-02-13 22:22:30 EST
Since based on comment #9 the issue is not reproduced anymore,
I think it's fair to close this bug now,

Daniel
Comment 12 Ján Tomko 2015-03-16 13:02:50 EDT
*** Bug 781263 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.