Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 615874 - removing a cluster from luci does not clean the db properly
removing a cluster from luci does not clean the db properly
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 03:37 EDT by Fabio Massimo Di Nitto
Modified: 2010-07-19 17:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-19 17:34:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Massimo Di Nitto 2010-07-19 03:37:51 EDT
remove a cluster from luci, then create a new cluster with a new name, including the old nodes:

The following errors occurred while creating cluster "fabbione-rhel6": rhel6-node1 is already a member of a cluster named "fabbione", rhel6-node2 is already a member of a cluster named "fabbione"
Comment 2 Fabio Massimo Di Nitto 2010-07-19 03:48:00 EDT
It appears that this error is coming from ricci.

sequence: start cluster with old name, remove cluster from luci,
cluster.conf is not wiped from the nodes and ricci still reads the one on disk.

trying to create the new cluster (that at this point should be legal) with a new name re-using the old nodes fails because of ricci on the node still looking at the old config.
Comment 3 RHEL Product and Program Management 2010-07-19 03:57:57 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Fabio Massimo Di Nitto 2010-07-19 04:18:12 EDT
forgot to mention, this is using the latest code from luci.git
Comment 5 Chris Feist 2010-07-19 17:34:34 EDT
Right now when you delete a cluster, it only deletes it from luci.  It doesn't delete it from the nodes.  This is by design.  Otherwise there is no way to remove a cluster from luci.  We should probably include a "Destroy" cluster option that will remove the nodes from the cluster and removed the cluster.conf files.

I'll create a new bug with that option (616239).

Note You need to log in before you can comment on or make changes to this bug.