Bug 615889 - luci cannot start an imported cluster
luci cannot start an imported cluster
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-19 04:34 EDT by Fabio Massimo Di Nitto
Modified: 2010-11-10 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: luci-0.22.2-9.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 17:11:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Massimo Di Nitto 2010-07-19 04:34:48 EDT
<?xml version="1.0"?>

<cluster name="fabbione-rhel6" config_version="1" >
  <clusternodes>
    <clusternode name="rhel6-node1" votes="1" nodeid="1"/>
    <clusternode name="rhel6-node2" votes="1" nodeid="2"/>
  </clusternodes>
</cluster>

since the creating of the cluster doesn´t work yet, I created the minimal config to add a cluster to luci.

only ricci and modclusterd are running on the nodes.

luci imports the config just fine, reports that the cluster is not running.

Select both nodes in the UI and click "join the cluster", but nothing happens.

from /var/log/cluster/ no attempts to run service cman start or equivalent takes place.
Comment 1 Fabio Massimo Di Nitto 2010-07-19 04:36:15 EDT
forgot to mention, this is using the latest code from luci.git
Comment 2 Fabio Massimo Di Nitto 2010-07-19 05:11:48 EDT
Extra info:

if cman is running, it´s possible to send another start command and a stop command:

11:03:42,996 INFO  [luci.controllers.cluster] User "root" started nodes "rhel6-node1, rhel6-node2" in cluster "fabbione-rhel6"
11:04:30,885 INFO  [luci.controllers.cluster] User "root" stopped nodes "rhel6-node1, rhel6-node2" in cluster "fabbione-rhel6"

the cluster at this point is stopped, and we cannot start it anymore
Comment 3 Brian Brock 2010-07-23 13:23:48 EDT
cluster.conf created in 5.x?
Comment 4 Fabio Massimo Di Nitto 2010-07-23 13:29:04 EDT
No, all fresh for rhel6 and in this specific case it makes no difference.

The config snippet I pasted above would work anywhere.
Comment 8 releng-rhel@redhat.com 2010-11-10 17:11:59 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.